UI Development Environment - Setup Help

More
01 Jun 2018 00:23 #111367 by Sparky961
Many of the tutorials I've looked at show a screen that is supposed to be displayed when starting a new project, asking whether to choose between Libglade and GtkBuilder. What does one do if this window is absent?

I have recently installed Debian Stretch, and then installed Glade from packages but can't recall exactly which instructions I followed. I ended up with Glade 3.20.0 but no window as above and no LinuxCNC widgets.

Is there a better set of instructions for setting up a LinuxCNC UI development environment? Or is someone perhaps willing to step me through some troubleshooting?

Thanks
More
01 Jun 2018 01:41 #111371 by cmorley
libglade is very old now ... GtkBuilder is the modern library. gladevcp takes care of this for you anyways - it will use what is needed.

But for linuxcnc you must use Glade 3.8.0 to about 3.8.6 or so . 3.20 uses GTK3 widgets and linuxcnc uses GTK2 widgets.

I found this on the forum:
forum.linuxcnc.org/48-gladevcp/33309-gla...ollow-this-for-3-8-6

Chris M
The following user(s) said Thank You: Sparky961
More
01 Jun 2018 02:22 #111373 by Sparky961
Thanks for pointing the way. Search only works when you know what to search for. ;)
More
01 Jun 2018 03:23 - 01 Jun 2018 03:29 #111376 by Sparky961
Unfortunately that only got me so far. I was following the instructions starting from page 2 ( forum.linuxcnc.org/48-gladevcp/33309-gla...3-8-6?start=10#99607 ).

I removed glade 3.20 along with it's two dependencies using 'apt-get autoremove'. Then I followed the instructions verbatim. When I tried running glade-3 I received the same error as another poster in that thread:
glade-3: error while loading shared libraries: libgladeui-1.so.11: cannot open shared object file: No such file or directory

Unfortunately my issue didn't "magically go away" like the other guy's case...

I tried installing the package 'libgladeui-1-dev' but there was no package by that name.
Last edit: 01 Jun 2018 03:29 by Sparky961.
More
01 Jun 2018 04:00 #111377 by cmorley
what linux distribution are you using?
what version of linuxcnc are you using?
Are you using a compiled RIP version of linuxcnc or a linuxcnc package?
what did you do to get the 3.8 version of glade? ( according to the page you quoted you compiled it)
how are you launching glade?

Chris M
More
01 Jun 2018 12:17 #111388 by Sparky961
Linux distribution was from the Debian Stretch uspace ISO: 'linuxcnc-stretch-uspace-i386-r10.iso'. I believe I obtained it here: www.linuxcnc.org/testing-stretch-rtpreem...-uspace-i386-r10.iso

LinuxCNC is included. I went this route because I'm using a 7i76e Mesa card that needs uspace. See this previous thread for more details on how I arrived here: forum.linuxcnc.org/9-installing-linuxcnc...do-i-need-for-uspace

I believe this qualifies as a LinuxCNC package.

Yes, I downloaded source for Glade 3.8 and built/installed it as per the linked instructions. It's hard to analyze _all_ of the terminal output, but I didn't see any obvious error/failure messages.

I've attempted to launch Glade from a terminal window by typing "glade-3". Aside from trying to find a package containing the missing library, to no avail, I didn't perform any other steps after finding this problem.
More
01 Jun 2018 17:44 #111398 by cmorley
so I did a bit of investigating and experimenting - with limited success.
I am using mint 18.3 based on ubuntu's xenial - so a little different then you.

I cheated and tried using the debs from here:
linuxcnc.org/dists/wheezy/base/binary-amd64/
It's not usually recommended to use debs from different distribution series but xenial doesn't have a glade-gk2 deb.
I also compiled glade 3.8.6 to see if that worked.

In both cases glade did start up and display.
but would crash depending on what screen I tried to load or if I tried to add certain widgets.
( libgladeui-1 would segfault)

I haven't diagnosed any further.
you could try the debs your self - it may work on stretch.

Chris M
More
01 Jun 2018 18:25 #111404 by cmorley
well I tried on stretch and it failed in the same way. :(

Chris M
More
01 Jun 2018 18:48 #111406 by cmorley
Well crap I got it to work on mint 18.3 by removing libgladeui-2-6 package.
But stretch doesn't have that one installed...

Chris M
More
01 Jun 2018 23:26 #111420 by Sparky961
I have to say, I'm appreciative of your efforts to look into this. It also goes without saying that it doesn't get me farther ahead..... maybe.

There's nothing to say I'm stuck with the system currently installed. If there's a different set of solutions that have a better end result, I'm perfectly willing to wipe the computer and start over. The LinuxCNC config files are simple to migrate and that's the only thing the computer is used for - and hopefully working on some UI stuff.

I haven't looked at a wheezy live CD install lately, but I think it all just works out of the box. Is there nothing like this that can support the Mesa 7i76e?
Time to create page: 0.100 seconds
Powered by Kunena Forum