Motoren werden heiß

More
11 Jul 2017 14:36 #95668 by ingemarine
Hallo,

Ich habe das Problem, dass meine Motoren heiß werden. Ob ich die Maschine verfahre oder nicht spielt keine Rolle. Wenn ich Linux CNC einschalten, werden nach und nach die Motoren heiß. Merkwürdigerweise wird die Y Achse heißer als die anderen Achsen.

Mit sleep habe ich es schon versucht, habe die sleep Funktion in der .hal ganz unten eingefügt. Motoren werden leider immer noch heiß...

Maschine: Haase AL640 Profi

Pinbelegung:
1. Relais 1 (Bohrspindel ein/aus)
2. Richtung Motor X
3. Takt Motor X
4. Richtung Motor Y
5. Takt Motor Y
6. Richtung Motor Z
7. Takt Motor Z
8. Richtung Motor 4 (Wenn vorhanden)
9. Takt Motor 4 (Wenn vorhanden)
10.  Ref. Z invertiert 
11. Taster invertiert 
12.  Ref. Y
13. Ref. X
14. Relais 2
15. Ref. 4. Achse
16. Boost
17. Sleep
18. GND
19. GND
20. GND
21. GND
22. GND
23. GND
24. GND
25. GND

.hal:
# Generated by stepconf 1.1 at Mon Jul 10 17:05:12 2017
# Änderungen an dieser Datei werden beim nächsten
# Aufruf von stepconf überschrieben.
loadrt trivkins
loadrt [EMCMOT]EMCMOT base_period_nsec=[EMCMOT]BASE_PERIOD servo_period_nsec=[EMCMOT]SERVO_PERIOD num_joints=[TRAJ]AXES
loadrt hal_parport cfg="0 out"
setp parport.0.reset-time 5000
loadrt stepgen step_type=0,0,0

addf parport.0.read base-thread
addf stepgen.make-pulses base-thread
addf parport.0.write base-thread
addf parport.0.reset base-thread

addf stepgen.capture-position servo-thread
addf motion-command-handler servo-thread
addf motion-controller servo-thread
addf stepgen.update-freq servo-thread
net spindle-cmd-rpm     <= motion.spindle-speed-out
net spindle-cmd-rpm-abs <= motion.spindle-speed-out-abs
net spindle-cmd-rps     <= motion.spindle-speed-out-rps
net spindle-cmd-rps-abs <= motion.spindle-speed-out-rps-abs
net spindle-at-speed    => motion.spindle-at-speed
net spindle-on <= motion.spindle-on

net probe-in => motion.probe-input

net spindle-on      => parport.0.pin-01-out
setp parport.0.pin-02-out-invert 1
net xdir            => parport.0.pin-02-out
setp parport.0.pin-03-out-invert 1
net xstep           => parport.0.pin-03-out
setp parport.0.pin-03-out-reset 1
setp parport.0.pin-04-out-invert 1
net ydir            => parport.0.pin-04-out
setp parport.0.pin-05-out-invert 1
net ystep           => parport.0.pin-05-out
setp parport.0.pin-05-out-reset 1
net zdir            => parport.0.pin-06-out
net zstep           => parport.0.pin-07-out
setp parport.0.pin-07-out-reset 1
net home-z          <= parport.0.pin-10-in-not
net probe-in        <= parport.0.pin-11-in-not
net home-y          <= parport.0.pin-12-in-not
net home-x          <= parport.0.pin-13-in-not

setp stepgen.0.position-scale [AXIS_0]SCALE
setp stepgen.0.steplen 1
setp stepgen.0.stepspace 0
setp stepgen.0.dirhold 35000
setp stepgen.0.dirsetup 35000
setp stepgen.0.maxaccel [AXIS_0]STEPGEN_MAXACCEL
net xpos-cmd axis.0.motor-pos-cmd => stepgen.0.position-cmd
net xpos-fb stepgen.0.position-fb => axis.0.motor-pos-fb
net xstep <= stepgen.0.step
net xdir <= stepgen.0.dir
net xenable axis.0.amp-enable-out => stepgen.0.enable
net home-x => axis.0.home-sw-in

setp stepgen.1.position-scale [AXIS_1]SCALE
setp stepgen.1.steplen 1
setp stepgen.1.stepspace 0
setp stepgen.1.dirhold 35000
setp stepgen.1.dirsetup 35000
setp stepgen.1.maxaccel [AXIS_1]STEPGEN_MAXACCEL
net ypos-cmd axis.1.motor-pos-cmd => stepgen.1.position-cmd
net ypos-fb stepgen.1.position-fb => axis.1.motor-pos-fb
net ystep <= stepgen.1.step
net ydir <= stepgen.1.dir
net yenable axis.1.amp-enable-out => stepgen.1.enable
net home-y => axis.1.home-sw-in

setp stepgen.2.position-scale [AXIS_2]SCALE
setp stepgen.2.steplen 1
setp stepgen.2.stepspace 0
setp stepgen.2.dirhold 35000
setp stepgen.2.dirsetup 35000
setp stepgen.2.maxaccel [AXIS_2]STEPGEN_MAXACCEL
net zpos-cmd axis.2.motor-pos-cmd => stepgen.2.position-cmd
net zpos-fb stepgen.2.position-fb => axis.2.motor-pos-fb
net zstep <= stepgen.2.step
net zdir <= stepgen.2.dir
net zenable axis.2.amp-enable-out => stepgen.2.enable
net home-z => axis.2.home-sw-in

net estop-out <= iocontrol.0.user-enable-out
net estop-out => iocontrol.0.emc-enable-in

loadusr -W hal_manualtoolchange
net tool-change iocontrol.0.tool-change => hal_manualtoolchange.change
net tool-changed iocontrol.0.tool-changed <= hal_manualtoolchange.changed
net tool-number iocontrol.0.tool-prep-number => hal_manualtoolchange.number
net tool-prepare-loopback iocontrol.0.tool-prepare => iocontrol.0.tool-prepared

net sleep <= motion.in-position
net sleep => parport.0.pin-17-out

.ini:
# Generated by stepconf 1.1 at Mon Jul 10 17:05:12 2017
# Änderungen an dieser Datei werden beim nächsten
# Aufruf von stepconf überschrieben.

[EMC]
MACHINE = Haase_Klein
DEBUG = 0

[DISPLAY]
DISPLAY = axis
EDITOR = gedit
POSITION_OFFSET = RELATIVE
POSITION_FEEDBACK = ACTUAL
ARCDIVISION = 64
GRIDS = 10mm 20mm 50mm 100mm 1in 2in 5in 10in
MAX_FEED_OVERRIDE = 1.2
MIN_SPINDLE_OVERRIDE = 0.5
MAX_SPINDLE_OVERRIDE = 1.2
DEFAULT_LINEAR_VELOCITY = 4.00
MIN_LINEAR_VELOCITY = 0
MAX_LINEAR_VELOCITY = 40.00
INTRO_GRAPHIC = linuxcnc.gif
INTRO_TIME = 5
PROGRAM_PREFIX = /home/cnc/linuxcnc/nc_files
INCREMENTS = 5mm 1mm .5mm .1mm .05mm .01mm .005mm

[FILTER]
PROGRAM_EXTENSION = .png,.gif,.jpg Greyscale Depth Image
PROGRAM_EXTENSION = .py Python Script
png = image-to-gcode
gif = image-to-gcode
jpg = image-to-gcode
py = python

[TASK]
TASK = milltask
CYCLE_TIME = 0.010

[RS274NGC]
PARAMETER_FILE = linuxcnc.var

[EMCMOT]
EMCMOT = motmod
COMM_TIMEOUT = 1.0
COMM_WAIT = 0.010
BASE_PERIOD = 100000
SERVO_PERIOD = 1000000

[HAL]
HALFILE = Haase_Klein.hal
HALFILE = custom.hal
POSTGUI_HALFILE = custom_postgui.hal

[TRAJ]
AXES = 3
COORDINATES = X Y Z
LINEAR_UNITS = mm
ANGULAR_UNITS = degree
CYCLE_TIME = 0.010
DEFAULT_VELOCITY = 4.00
MAX_VELOCITY = 40.00

[EMCIO]
EMCIO = io
CYCLE_TIME = 0.100
TOOL_TABLE = tool.tbl

[AXIS_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 40.0
MAX_ACCELERATION = 300.0
STEPGEN_MAXACCEL = 375.0
SCALE = 160.0
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 200.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = -8.000000
HOME_LATCH_VEL = -3.125000
HOME_SEQUENCE = 1

[AXIS_1]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 40.0
MAX_ACCELERATION = 300.0
STEPGEN_MAXACCEL = 375.0
SCALE = 160.0
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 200.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = -8.000000
HOME_LATCH_VEL = -3.125000
HOME_SEQUENCE = 2

[AXIS_2]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 12.0
MAX_ACCELERATION = 100.0
STEPGEN_MAXACCEL = 125.0
SCALE = 160.0
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -110.0
MAX_LIMIT = 0.001
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 4.000000
HOME_LATCH_VEL = 3.125000
HOME_SEQUENCE = 0

Please Log in or Create an account to join the conversation.

More
11 Jul 2017 15:24 #95672 by tommylight
Replied by tommylight on topic Motoren werden heiß
Welche machine? Motoren? Drives? Mechr info bitte.
Wen sie die hand an motor fur 1 minute lassen, ess ist ales in ordnung.
Wen es brent an contact das ist nicht gut.
Es gibt cleine schalter an die drives fur die motor strom zu regeln, versuch mal das zu einschtelen.
Gruss,
Tom
The following user(s) said Thank You: Tchefter, ingemarine

Please Log in or Create an account to join the conversation.

More
11 Jul 2017 17:49 #95679 by rodw
Replied by rodw on topic Motoren werden heiß
If it is stepper motors that get hot, there is often a switch on the stepper controller that will make them cooler. Here is an example from the Leadshine DM542 driver.

Standstill Current Setting
SW4 is used for this purpose. OFF meaning that the standstill current is set to be half of the selected dynamic current, and ON meaning that standstill current is set to be the same as the selected dynamic current.The current automatically reduced to 50% of the selected dynamic current one second after the last pulse. Theoretically,this will reduce motor heating to 36% (due to P=I2*R) of the original value.
The following user(s) said Thank You: ingemarine

Please Log in or Create an account to join the conversation.

More
11 Jul 2017 19:35 #95689 by ingemarine
Replied by ingemarine on topic Motoren werden heiß
Danke für deine Antwort. Ich habe leadshine driver. Maschine = Haase AL. Motoren weiß ich gerade nicht. Werde ich morgen nachschauen.

Der Schalter sw 4 steht auf off. Laut Beschreibung bedeutet dies dann halben strom.

Gruß

Please Log in or Create an account to join the conversation.

More
12 Jul 2017 12:12 #95720 by ingemarine
Replied by ingemarine on topic Motoren werden heiß
also heute habe ich dass noch einmal ausprobiert. Ich habe den schalter SW 4 auf ON gestellt. Bringt kein unterschied ob er auf OFF steht oder auf ON wird gleich heiß das ganze.

Ich hatte vorher über Windows die Steuerung 4cam NC Drive www.4cam.de/seite30.html mit der Maschine laufen. Da werden die Motoren nicht warm... Sie bleiben unter 40° egal wie viel und wie lange ich mit der Maschine gefräst habe. Nun nach dem ich Linux CNC konfiguriert habe werden die Motoren heiß.

Von daher muss ich auch nichts mehr an der Hardware Konfigurieren sondern es muss eine Einstellung in CNC Linux sein die ich nicht richtig gemacht oder vergessen habe.

Maschine: Haase AL640 Profi
Endstufen: Leadshine ND556
Motor: Vexta 2 Phase 1,8°/Step PK268DA DC 2,1V 4,2A

bitte helft mir ich weiß nicht weiter.

MfG

Please Log in or Create an account to join the conversation.

More
12 Jul 2017 12:24 #95722 by tommylight
Replied by tommylight on topic Motoren werden heiß
Normaleweise soll es an die Leadshine drives ein tabele mit current im A ( ampere ) sein, shau mal an diese tabele und mach die microschalter an oder aus fur 2A zu geben.
Shau mal wie sind die drachte an motor geklemt sind, ob es die motoren haben 4 oder 8 drachte und ob es sind wie parallel oder serial gemacht.
MFG
The following user(s) said Thank You: ingemarine

Please Log in or Create an account to join the conversation.

More
12 Jul 2017 21:13 - 12 Jul 2017 21:29 #95741 by ingemarine
Replied by ingemarine on topic Motoren werden heiß
Ich gucke morgen ob die Motoren mit 4 oder 8 Kabeln angeschlossen sind. Aber anbei erstmal ein paar Fotos von meiner Maschine.
Attachments:
Last edit: 12 Jul 2017 21:29 by ingemarine.

Please Log in or Create an account to join the conversation.

More
13 Jul 2017 03:40 #95746 by Tchefter
Replied by Tchefter on topic Motoren werden heiß
Hallo, über SW1 SW2 SW3 kannst du das doch einstellen.
Die DIPs hab ich bei meiner billigen TB6560 red auch dran und funktioniert einwandfrei.

Gruß
The following user(s) said Thank You: ingemarine

Please Log in or Create an account to join the conversation.

More
13 Jul 2017 07:11 #95747 by ingemarine
Replied by ingemarine on topic Motoren werden heiß
Moin,

ja ich weiß dass man das kann, aber wie ich bereits geschrieben habe, war vorher eine andere Steuerung angeschlossen: www.4cam.de/seite30.html mit der Steuerung wurden die Motoren bei den jetzigen Einstellungen auch nicht heiß. Deswegen muss es doch eine Einstellungssache von Linux CNC sein. Und keine Einstellungssache von der Hardware.

MfG

Please Log in or Create an account to join the conversation.

More
13 Jul 2017 16:55 #95760 by Tchefter
Replied by Tchefter on topic Motoren werden heiß
Du kannst ja unter LinuxCNC über Stepconf, mehrere Maschinen anlegen.
Ich würde mich da jetzt mal mit einer neuen Config rantasten, von den Standardeinstellungen langsam
über auf Benutzerdefiniert.
Ich hatte vor der roten TB die blaue TB, da wurde bei mir auch alles heiß, Motoren und Steuerung.
Daher kann ich mir das jetzt nicht vorstellen das es von LinuxCNC kommt...
The following user(s) said Thank You: ingemarine

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum