Neuer User - Vorstellung und erste Probleme

More
05 Feb 2019 19:52 #125758 by Thomas_K
Hallo aus der nähe Hollabrunn in Niederösterreich...
Wie mein Username schon nahelegt heiße ich Thomas, bin 43, Betriebstechniker und absoluter Linux_noob :-)
Jetzt mal zu den Hintergrundinformationen:
Ich habe eine funtionierende eigenbau Portalfräse, diese betreibe ich mit mach3 und ess. das funktioniert auch soweit es mit Windows halt funtionieren kann (...und das hat mir schon einige Fräser gekostet).
Jetzt möchte ich den schritt zu Linuxcnc machen und habe mir auch gleich mal linuxcnc-2.7-wheezy.iso runtergeladen, auf einen usb-stick gebruzzelt und versucht auf einen AMD Athlon II X2 B22 / 2.8 GHz (HP Compaq 6005 sff) zu intallieren.
Der menüpunkt Install graphical fehlt, die Installation per Console Schlägt dann fehl weil anscheinend irgend eine datei bezüglich Display fehlt, da fällt der PC in eine Schleife.
Selbes Bild in zwei weiteren Rechnern. Also nochmal geladen.... selbes Ergebnis.
Als nächstes habe ich mir debian-7.11.0-amd64-netinst.iso gezogen, das funktionierte sehr gut zu Installiern, jedoch um eine Maschine zu steuern benötigt man ja einen RT-Kernel. Lt. einer Tabelle soll nur der Preemt-Kernel (langsamer?) mit amd64 Image arbeiten, ob es stimmt weiß ich nicht
>Linux_noob.
Jedenfalls bekomme ich damit einen maximalen Jitter von ca. 60.000ns.
Diese Installation habe ich dann noch in einen amd phenom ii 3.0ghz in einen M3N78-CM versucht, Ergebnis:
Läuft alles extrem flüssig, konnte dort feststellen das Linux anscheinend auch über eine art Aero-Oberfläche verfügt, Jitter jedoch die absolute Katastrophe.... 23.000.000ns nach Biostuning meistens so um die 15.000ns aber immer wieder ausreißer und der Jitter schnaltzt auf 100.000ns.
Der 3. Rechner ist ein ITX Board ASUS AT5IONT-I, wäre von der Bauform eigentlich meine Preferänz, Jitter konstant <12.000ns aber mit Latency Test + 1x glxgears nicht mehr richtig bedienbar.
Auf allen drei Rechnern habe ich auch linuxcnc-stretch-uspace-amd64.iso ausprobiert mit ähnlichen Jitter, vielleicht geringfügig besser.
Die geschichte mit isolcpus=1 und noirqballance habe ich schon umgesetzt.
Meine Erfahrung mit Linuxcnc beschränkt sich bisher also auf den Latency Test weil ich auch noch nicht richtig weiß mit welchen Rechner ich jetzt weitermachen soll.
Weitere Hardware habe ich Mesa 5I25+7I85s+7I75... für diese kombi finde ich natürlich wieder kein file zum Flashen, wobei ich mir nicht sicher bin ob ich für 7I75 überhaupt eines brauche.

Für Ratschläge und Hilfestellung für einen Lulu in sachen Linux und Mesa wäre ich wirklich Dankbar.
Lg
Thomas

Please Log in or Create an account to join the conversation.

More
05 Feb 2019 21:29 #125766 by PCW
Bei Mesa-Hardware ist eine Latenzzeit von 100.000 ns in Ordnung, da sie nur 10% der 1 kHz-Servo-Thread-Periode beträgt. Die Bitdatei für einen 7I85S ist 5i25_7i85sx2.bit (der 7I75 benötigt keine spezifische Unterstützung)
The following user(s) said Thank You: Thomas_K

Please Log in or Create an account to join the conversation.

More
14 Feb 2019 18:08 #126480 by pl7i92
Jitter 12000 davon träumen manche
ich fahr die meisten Maschinen mit parallelport und 100.000 mit 5m/min bei 0,01 jje schritt
KEINERLEI probleme keine schrittverluste über Stunden

Echt war Test 8sth Schicht
zurück auf Uhr und 0,03 DA Glaub ich nicht der MessUHR und das bei Zahnstangen(geschliffen) antrieb 30/1

Please Log in or Create an account to join the conversation.

More
22 Feb 2021 10:35 #199693 by felix77
Hallo Thomas, Deine Nachricht ist zwar schon älter aber ich hab mir gedacht ich schreib ein Hallo. Ich bin auch aus Niederösterreich Bezirk Horn.
Lg Ingo

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum