Mesures latence avec oscilloscope HAL

More
13 May 2019 19:43 - 13 May 2019 19:45 #133655 by electronm
Bonjour à tous,
je viens demander votre avis au sujet de la mesure de la latence.

J'ai fait de multiples test dont voici les résultats :


Test type 1 : 3 glxgears + VLC vidéo big buck bunny 1080p
Test type 2 : 3 glxgears
Test type 3 : Axis seulement avec un travail de fraisage



Je voudrais savoir pourquoi il y à un tel écart entre les mesures avec les outils (latency test, latency plot et latency hist), et les mesures à l’intérieur de axis (HAL meter et oscilloscope HAL).

Par contre j'ai regardé dans mon fichier de config .ini et je vois que "BASE_PERIOD = 75757".
Si j'ai bien compris HAL fait 1 pas toutes les deux périodes.
Alors je me dis que peut être 75757/2=37878ns
Donc si je fait 45220 - 37878 = 7342ns, et là c'est raccord avec mes mesures.
J'ai bon?

Du coups je me pose la question : quoi entrer dans la config de stepconf (base period max jitter), pour une configuration sûre.
10000ns ou 50000ns
Attachments:
Last edit: 13 May 2019 19:45 by electronm.

Please Log in or Create an account to join the conversation.

More
14 May 2019 06:34 #133697 by pl7i92
tout est à 100k pour les moteurs pas à pas


THE Wizzard will start at 10k
no need to go down if steppers are in use
only with servos it matters below 50k

Please Log in or Create an account to join the conversation.

More
14 May 2019 09:37 #133715 by electronm
"Tout est à 100k pour les moteurs pas à pas"?? c'est a dire?

Je n'utilise pas de servos moteur, mais des moteurs pas à pas.

Ma question, est simplement de savoir si on peut utiliser la mesure de base-thread.tmax et base-thread.time dans axis par l’intermédiaire du "HALmeter" ou de "oscilloscope HAL".

Si oui, comment interpréter les résultats.
Ou alors ce que j’essaie de faire n'est pas correcte.

Please Log in or Create an account to join the conversation.

Moderators: darty367
Time to create page: 0.117 seconds
Powered by Kunena Forum