Résolu : Linuxcnc 2.9 avec Debian 10 probleme True Type Tracer manquant

More
29 Jan 2023 08:37 #263158 by rodw
I don't know. I had such a problem trying to get v 2.9 running on buster over a year ago, I have never used Buster or v 2.8 since.
I hsve been using Bookworm or sometimes Bullseye using this script github.com/joco-nz/lcnc-bullseye-installer

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 09:14 #263159 by phillc54

I don't know. I had such a problem trying to get v 2.9 running on buster over a year ago

Interesting, I have noticed you mention this several times. I have run 2.9 on Buster in both VM's and on my plasma table config without any issues.

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 10:40 #263161 by rodw

I don't know. I had such a problem trying to get v 2.9 running on buster over a year ago
Interesting, I have noticed you mention this several times. I have run 2.9 on Buster in both VM's and on my plasma table config without any issues.

You might be closer to the development than I am so can time things better. But I had been running my plasma on Mint 17.3 for about 4-5 years as RIP, way before plasmac even started. Eventually, python versions rendered it obsolete and impossible to upgrade. After flirting with MX linux you suggested, it did not support some of my hardware. Mint at the time did not support the correct version of Python 3 so it was not an option. Also the ethernet card on the Odroid H2+ I use in a mill needed kernel 5.9 or higher so Buster was out on it. I went to Buster on my plasma and not long later making a higher version of Python 3 as a prerequisite for 2.9 prevented upgrading at the time.

So a few weeks before Bullseye was officially released, I installed it so there was no conflict between Python 2.7 and 3.x and everything worked. Once Linuxcnc got to Debian Bookworm, I started to experiment with it too to do deb installs instead of compiling from source. In the absence of debs for Bullseye, this was sensible,  There have been a few hiccups along the way but generally its all just worked.

My MIll was using ethercat and starting on Bulldeye, I could not get it installed but Grotius made a deb for me and that was quite painfull. After that, I was able to work out how to install ethercat from a Repo maintained by the etherlabmaster guys. Then I tried to get linuxcnc and ethercat installed on a Raspberry Pi 4B. I did actually achieve this and latency was good. but it was a long journey requiring compiling vtk and other bits but started with the official Debian Bullseye.

So it still goes on. The best GUI I've found for my mill is one built with QTPYVCP but it won't install on my older version of  Bullseye. I did try QTWoodpecker as it was one of the few that fit on my monitor but the probing is too complicated for a small mill conversion. Shame about that. So this week, I'll be reinstallling Bullseye and ethercat on my H2+ which I'm not looking forward to. Buster is too old to support modern hardware.

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 13:26 - 29 Jan 2023 13:55 #263165 by benhurburg

I don't know. I had such a problem trying to get v 2.9 running on buster over a year ago, I have never used Buster or v 2.8 since.
I hsve been using Bookworm or sometimes Bullseye using this script github.com/joco-nz/lcnc-bullseye-installer


I try to make the complete installation , I come back asap to inform you.

 

Last edit: 29 Jan 2023 13:55 by benhurburg.

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 17:28 - 29 Jan 2023 18:30 #263170 by benhurburg
J'ai suivi la procédure et j'ai réussi à installer Debian 11 + linuxcnc 2.9.0.
Je précise que lors de l'installation de linuxcnc ij'ai fait le choix " développeur " pour que ça fonctionne , j'ai aussi fait le choix "Probe = Yes "

I followed the procedure and successfully installed Debian 11 + linuxcnc 2.9.0.
I specify that during the installation of linuxcnc I made the choice "developer" so that it works, I also made the choice "Probe = Yes"
 
File Attachment:
Last edit: 29 Jan 2023 18:30 by benhurburg.

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 18:56 - 29 Jan 2023 19:38 #263175 by benhurburg
J'ai fait la mise à jour de 10 vers 11 en suivant ce lien:
phoenixnap.com/kb/upgrade-debian-10-to-11

Au passage en ligne pas de bureau , écran blanc.
installation de tasksel sous terminal ( ctrl+alt+F1)
$ sudo apt-get install tasksel
puis pour avoir l'application graphique:
$ sudo tasksel
Suivre les indications...
Last edit: 29 Jan 2023 19:38 by benhurburg.

Please Log in or Create an account to join the conversation.

More
31 Jan 2023 18:50 - 01 Feb 2023 10:36 #263385 by benhurburg
Seul Python 3.9 est installé.
J'ai besoin d'installer TrueTypeTracer 4.1 qui manque .
J'ai installé les dépendances manquantes (2 )  indiquées lors de la tentative d'installation de truetype-tracer
truetype-tracer_4.1-4_amd64.deb
linuxcnc.org/dists/stretch/base/binary-amd64/truetype-tracer_4.1-4_amd64.deb

relancé l'installation  c'est OK
Lancement de linuxcnc --> TTT apparait dans les options de Axis.
Problème résolu.
 
Last edit: 01 Feb 2023 10:36 by benhurburg.

Please Log in or Create an account to join the conversation.

Moderators: darty367
Time to create page: 0.155 seconds
Powered by Kunena Forum