How can I get GladeVCP?

More
27 Dec 2020 20:40 #193309 by zz912
I would like change Gmoccapy. So I need GladeVCP.

In manual is written:
linuxcnc.org/docs/2.8/html/gui/gladevcp....adevcp:prerequisites

but
sudo apt-get install glade-gtk2
dont work.

Could you help me, please?
pi@linuxcnc: $ uname -a
Linux linuxcnc 4.19.71-rt24-v7l+ #4 SMP PREEMPT RT Thu Apr 30 22:00:15 CDT 2020 armv7l GNU/Linux
The following user(s) said Thank You: macsddau@linuxcnc

Please Log in or Create an account to join the conversation.

More
29 Dec 2020 17:29 #193441 by macsddau@linuxcnc
Up ! Same for me

Please Log in or Create an account to join the conversation.

More
21 Jan 2021 14:22 #196092 by skrap58
Replied by skrap58 on topic How can I get GladeVCP?
Same for me

Please Log in or Create an account to join the conversation.

More
21 Jan 2021 17:17 #196115 by Todd Zuercher
This isn't a good answer, but it is the simplest solution for me. I have one of the older Wheezy based Linuxcnc ISO installed in a VM on the PC I develop my configs on. It has the right version of Glade installed by default. I set up the UI files there then copy them over to the machine where I want to use them.

There may be a solution for installing the GTK2 version of Glade on Buster, but I don't know it.

Please Log in or Create an account to join the conversation.

More
22 Jan 2021 23:16 #196294 by andypugh
Replied by andypugh on topic How can I get GladeVCP?
There is a package called imply "glade" though that might only work with gtk3.

On the Pi there is a package called "glade-3" which is glade-gtk2, though that might not help.

LinuxCNC did back-port glade-gtk2 on Wheezy, so you could try the deb package here: www.linuxcnc.org/dists/wheezy/base/binary-amd64/ though it might refuse to run on Buster.

Please Log in or Create an account to join the conversation.

More
23 Jan 2021 10:52 - 23 Jan 2021 10:53 #196323 by newbynobi
Replied by newbynobi on topic How can I get GladeVCP?
you will need to compile glade 3.8.6 from source code.

In this post I described how to install Mint 19 with glade 3.8.6, the part of installing glade should fit your needs. Please uninstall all glade using synaptic prior to installing glade 3.8.6

Norbert
Last edit: 23 Jan 2021 10:53 by newbynobi.

Please Log in or Create an account to join the conversation.

More
24 Jan 2021 17:31 #196434 by andypugh
Replied by andypugh on topic How can I get GladeVCP?

you will need to compile glade 3.8.6 from source code.


Not any more :-)

For Buster / amd64 I have put a package "glade-gtk2" on the LinuxCNC repository.
And there is a pre-existing package for Raspbian.

For Buster with the LinuxCNC 64-bit kernel:
sudo apt-get install glade-gtk2
For Raspbian on Pi
sudo apt-get install glade-3
The following user(s) said Thank You: BigJohnT, skrap58, Etaoin

Please Log in or Create an account to join the conversation.

More
26 Jan 2021 16:21 - 26 Jan 2021 16:22 #196632 by probotix
Replied by probotix on topic How can I get GladeVCP?
I cannot install glade2 on Buster:
E: Unable to locate package glade-gtk2

This is in my sources.list:
deb http://www.linuxcnc.org/ buster 2.8-rtpreempt base  
deb-src http://www.linuxcnc.org/ buster 2.8-rtpreempt base
Last edit: 26 Jan 2021 16:22 by probotix.

Please Log in or Create an account to join the conversation.

More
26 Jan 2021 17:02 #196635 by andypugh
Replied by andypugh on topic How can I get GladeVCP?

I cannot install glade2 on Buster:
E: Unable to locate package glade-gtk2


sudo apt-get update and try again?

Please Log in or Create an account to join the conversation.

More
26 Jan 2021 22:44 #196670 by joekline9
Replied by joekline9 on topic How can I get GladeVCP?
Ok it worked for me after the 'update'
Thanks

Please Log in or Create an account to join the conversation.

Moderators: mhaberler
Time to create page: 0.085 seconds
Powered by Kunena Forum