how to copy glade3 to glade folder

More
11 Mar 2023 21:59 - 11 Mar 2023 22:16 #266435 by my1987toyota
So I decided to run an install to test Debian 12 and Linuxcnc 2.9 on one of my computers.
for the most part everything has gone well. Until installing the Glade editor. Version 3.40.0
it doesn't see the linuxcnc emblems in usr / share / glade3. The standard Glade folder is
their but for some reason I cant copy and paste the emblems from the glade3 folder to
the glade folder. It will copy but the glade folder wont let me paste. My attempt to do
a symlink failed as well saying that I am not the owner and permission is denied.
Is their something else that I am missing?
 
Last edit: 11 Mar 2023 22:16 by my1987toyota.

Please Log in or Create an account to join the conversation.

More
12 Mar 2023 01:52 #266459 by cmorley
There is an option in the GLADE editor preference tab to set catalog library paths.

Try that instead.
The following user(s) said Thank You: my1987toyota

Please Log in or Create an account to join the conversation.

More
12 Mar 2023 03:08 - 12 Mar 2023 03:11 #266463 by my1987toyota
just tried that but I still can"t find the LCNC widgets in Glade. My efforts to do a symlink and a
permission chmod failed as well . I am sure I am just missing something stupid.
Last edit: 12 Mar 2023 03:11 by my1987toyota.

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 06:42 #266531 by phillc54
Both the following options work for me:

1 - from a terminal with Glade NOT opened, run the following:
sudo cp /usr/share/glade3/catalogs/hal_python.xml /usr/share/glade/catalogs/


2 - open Glade
goto preferences and click + for Extra Catalog and Templates paths
navigate to /usr/share/glade3/catalogs and click Open
close the dialog and close Glade

Open Glade and the LinuxCNC icons should be available.

Warning: Spoiler!


It seems that in python3 systems the Glade catalogs have moved from /usr/share/glade3 to /usr/share/glade. We will probably have to change something in the makefile (providing is doesn't upset Debian Buster configs).
 
Attachments:
The following user(s) said Thank You: daiman444, my1987toyota

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 00:41 #266620 by my1987toyota
Thank you phillc54. I had tried the + extra catalogs already and it didn't work for me.
Thankfully your terminal sudo copy did.

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 00:45 #266621 by HansU

1 - from a terminal with Glade NOT opened, run the following:sudo cp /usr/share/glade3/catalogs/hal_python.xml /usr/share/glade/catalogs/


Doing this gives me a part of the widgets, but those under VCP Actions etc. are missing:
 

Somewhere later on that VM I just noticed that I have all widgets available, just don't have any clue what caused this:

 

Adding an Extra Catalog does not have any effect for me.
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 06:37 #266638 by phillc54
That is odd, I have not seen that before...

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 20:49 #266702 by HansU
I figured out the reason.
The odd behavior is caused by Wayland (first picture). Switching to Xorg make those widgets appear magically :D
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 22:03 #266709 by phillc54
It may be worth trying this before opening Glade in Wayland:
export GDK_BACKEND="x11"

Please Log in or Create an account to join the conversation.

More
15 Mar 2023 07:30 #266728 by HansU
No that didn't solve it

Please Log in or Create an account to join the conversation.

Moderators: mhaberlerHansU
Time to create page: 0.174 seconds
Powered by Kunena Forum