PCI Parallel Port Card Disabled

19 Jul 2015 02:08 #60740 by drewsteriam5
I'm having trouble getting LinuxCNC to communicate with my Gecko 540 driver via a PCI single Parallel Port Card I just installed (This card: www.amazon.com/gp/product/B003D3MFHC).

When I run the lspci -vv command I get the following about the card:

01:00.0 Parallel controller: NetMos Technology Device 9900 (prog-if 03 [IEEE1284])

Subsystem: Device a000:2000

Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

Interrupt: pin A routed to IRQ 5

Region 0: I/O ports at 1100 [disabled]

Region 1: I/O ports at 1108 [disabled]

Region 2: [virtual] Memory at f0800000 (32-bit, non-prefetchable) [size=4K]

Region 5: [virtual] Memory at f0801000 (32-bit, non-prefetchable) [size=4K]

Capabilities: <access denied>

I tried going into the BIOS and seeing if there was anything obvious disabled that shouldn't be, but I came up empty on that front. This is a fresh install of the LinuxCNC Debian Wheezy 2.6 ISO on this site. If it makes any difference I installed LinuxCNC last night, then installed the PCI card today after the the install was already done.

I'm not sure where to go from here so any help would be appreciated. I was able to run the motors from the LiveCD on a different computer a few days ago, so I know the driver board works.


Please Log in or Create an account to join the conversation.

19 Jul 2015 15:56 #60754 by ArcEye
This rather old wiki covers it


There can be a problem with this distro for some reason, I came across it with Wheezy from a different install too.

sudo modprobe parport_pc

followed by

sudo rmmod ppdev
sudo rmmod lp
sudo rmmod parport_pc

should fix it by ensuring the parport low level driver is loaded, allowing access to the card.


Please Log in or Create an account to join the conversation.

07 Apr 2016 20:05 #72929 by kenwoodhf
I was wondering if you ever solve your problem. I bought the same card and am getting the same problem.
Thanks Jan

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum