How to increase Angular Velocity

More
15 Mar 2019 00:16 - 15 Mar 2019 00:58 #128618 by ljask
I'm running the axis_9axis simulator. Before I 'Home All' axes I can jog the A axis at high speed. (I bumped up all the MAX_VELOCITY / MAX_ANGULAR_VELOCITY parameters I could find.) After homing, the angular velocity is clamped at 60 (1 deg. / sec.). Any ideas why?
Update: When I "Unhome" the U axis (all other axes are homed) the A axis jog speed returns to normal.

Also, I am running a real 4 axis machine using the standard Sherline configuration. It too has the A axis velocity (as show in the Preview screen) at 60--and that is exactly what the rotary table does, turn 1 deg. / sec. I don't have access to that machine just now, but I think the issues are related. Any thoughts? Thanks.
Last edit: 15 Mar 2019 00:58 by ljask.

Please Log in or Create an account to join the conversation.

More
15 Mar 2019 01:51 #128625 by dgarrett
Version not specified but guessing it is master branch (2.8~pre), in the
axis_9axis.ini sim config set the AXIS_A vel/accel limits to conform to its
identity joint (JOINT_3) values:
[AXIS_A]
MAX_VELOCITY     =   90
MAX_ACCELERATION = 1200 

Please Log in or Create an account to join the conversation.

More
15 Mar 2019 07:54 #128641 by pl7i92
look into display Section
if it is not taken down to a lower value
LIMITED

linuxcnc.org/docs/html/config/ini-config.html



DEFAULT_ANGULAR_VELOCITY = .25 - The default velocity for angular jogs, in machine units per second.

MIN_ANGULAR_VELOCITY = .01 - The approximate lowest value the angular jog slider.

MAX_ANGULAR_VELOCITY = 65.0 - The maximum velocity for angular jogs, in machine units per second.

Please Log in or Create an account to join the conversation.

More
15 Mar 2019 13:52 - 15 Mar 2019 13:56 #128656 by ljask
Setting
[AXIS_A]
MAX_VELOCITY = 90
MAX_ACCELERATION = 1200 worked! These parameters were missing in the sample file so I added them.

How is it related to homing? I have a lot to learn. Thanks.
Last edit: 15 Mar 2019 13:56 by ljask.

Please Log in or Create an account to join the conversation.

More
15 Mar 2019 14:38 #128658 by andypugh
Before you home the machine is in "Joint mode" where you can jog each joint separately.
After homing the machine switches to "World" mode, where you jog the tool-tip in the XYZABC coordinate system.

On many machines the difference between joints and axes is hard to see, but consider a robot arm. With a robot arm you can either jog each elbow joint individually, or you can move the tool around in cartesian coordinate axis space.
The following user(s) said Thank You: ljask

Please Log in or Create an account to join the conversation.

More
16 Mar 2019 14:09 #128739 by pl7i92
you shoudt considder a new MAIN Stepconf file as you edited it from a older system and this may trouble again
as starting with known numbering to a clear stepconf Basic configuration

Please Log in or Create an account to join the conversation.

More
16 Mar 2019 17:05 - 16 Mar 2019 17:08 #128754 by ljask
Related to this, when on a real machine (I'm using the stick Sherline4Axis ini file) I jog the X, Y and Z axes from the keyboard and get a fairly rapid response. When I jog the A axis, it takes 5 sec. or so to accelerate up to full velocity (1500 deg. / in.). If I go to the MDI tab and issue a G0 Ann command, the axis responds immediately and quickly ( i.e. rapid acceleration) moves to the commanded position. None of this is a problem, but I am curious as to what is slowing the acceleration for the keyboard jogs? I am using 2.7.8 and axis interface.
Last edit: 16 Mar 2019 17:08 by ljask. Reason: typo

Please Log in or Create an account to join the conversation.

More
18 Mar 2019 12:36 #128887 by pl7i92
please update to 2.7.14
the issue is inside the interpreter

is the Alowed speed at 100% set

Please Log in or Create an account to join the conversation.

Time to create page: 0.180 seconds
Powered by Kunena Forum