How to configure a XHC-WHB04B pendant ?

More
10 Nov 2020 10:06 #188856 by Nordbär
Hi guys,

i installed a WHB04B pendant in the famous LinuxCNC-V2.8 with help of Peter's (Talla83) Utube-video and the included driver. I followed also the V2.8 documentation.
Have the 4-axis pendant version (LHB04B) with USB-cable and the basic functions are working well, can home all, jog every of the 4 axis, switch diverent coordinate systems, start GCode, etc. (very usefull for a 68.- € pendant with display, delivery included ;--))

But for example: why can i assign Macro1- and Macro2-buttons with functions (e.g. G0 X0 Y0) but not Macro3- and Macro4-buttons ? (Macro5-button works, but not button8 ...)

When i try to find out something, as a newbie i get very fast lost in time and space of the LinuxCNC-universe.

Where to find informations about this topic or who can tell me more please ?

Cheers, Norbert

Please Log in or Create an account to join the conversation.

More
13 Nov 2020 23:25 #189271 by tommylight
The following user(s) said Thank You: Nordbär

Please Log in or Create an account to join the conversation.

More
15 Dec 2020 10:11 - 15 Dec 2020 10:14 #192039 by Nordbär
Hello 'Tommylight',

thank you for advice, i still working on the 37 links i got from this.

This is what i wanted to say, as a normal user it takes a lot of time to get into this theme (and i actually do not want to become a 'specialist' ;--)

It is difficult to see wich information belongs and wich one is outdated and not valid or usefull or ment for something else, a lot of terms that you have never heard before ...

Some things i could adjust till now, but a lot is not clear (different versions / buttons of the pendant ?, auto-mode and the other modes ? etc.)

i think anyone installing this good pendant has nearly the same problems.
Last edit: 15 Dec 2020 10:14 by Nordbär.

Please Log in or Create an account to join the conversation.

More
15 Dec 2020 13:40 #192045 by tommylight

Please Log in or Create an account to join the conversation.

More
15 Dec 2020 19:10 - 16 Dec 2020 22:55 #192065 by alkabal
github.com/LinuxCNC/linuxcnc/blob/2.8/sr...ple-configuration.md


This file is near a ready to use hal file to add to your config.

Download and rename the file example-configuration.md to xhc-whb04b-6-mill.hal put this in your config folder.

So basically you only need to download this file : (untested wget command...)
cd your_config_directory
wget -O xhc-whb04b-6.hal https://github.com/LinuxCNC/linuxcnc/raw/master/src/hal/user_comps/xhc-whb04b-6/example-configuration.md
mv example-configuration.md xhc-whb04b-6.hal


Edit your "know as working config.ini"
nano your_config.ini

for adding
[HALUI]
MDI_COMMAND=(debug,macro0)
MDI_COMMAND=(debug,macro1)
MDI_COMMAND=(debug,macro2)
MDI_COMMAND=(debug,macro3)
MDI_COMMAND=(debug,macro4)
MDI_COMMAND=(debug,macro4)
MDI_COMMAND=(debug,macro6)
MDI_COMMAND=(debug,macro4)
MDI_COMMAND=(debug,macro8)
MDI_COMMAND=(debug,macro9)
MDI_COMMAND=(debug,macro10)
MDI_COMMAND=(debug,macro11)
MDI_COMMAND=(debug,macro12)
MDI_COMMAND=(debug,macro13)
MDI_COMMAND=(debug,macro14)
MDI_COMMAND=(debug,macro15)
MDI_COMMAND=(debug,macro16)

and add to HAL section (i think before POSTGUI_HALFILE)
HALFILE = xhc-whb04b-6.hal

thats all ! (i hope :laugh: )
Last edit: 16 Dec 2020 22:55 by alkabal.
The following user(s) said Thank You: Nordbär

Please Log in or Create an account to join the conversation.

More
02 Jan 2021 02:12 #193786 by Alltrades
Thank you alkabal, tried it and it makes my pendant work.

Please Log in or Create an account to join the conversation.

More
12 Jan 2021 13:22 - 12 Jan 2021 13:29 #195046 by Nordbär
Hi all,
i have had a lot of work and no time for the hobby, now back at my CNC-machine :cheer:

First of all, i am very thankful for the great LinucCNC-system but i still struggle with the pendant:

- i downloaded and followed the instructions of Alkabal
- the XHC-pendant worked (and is very usefull), but still same issues as before
- then i compared the new ini- and hal-files with my old ones's: it is exactly the same as i have had already (as i have got and made them from original LinuxCNC V2.8 - manuals)

As i wrote in my first post and aditionally :
- you can assign Macro1- and Macro2-buttons with functions (e.g. G0 X0 Y0) but not Macro3- and Macro4-buttons ? (Macro5-button works, but not button8 ...)
- when i start LinuxCNC, the pendant is in MPG-mode (you can adjust feed with the rotary-wheel ..). Once you use the pendant, e.g. for jogging the axis, it never comes back to MPG-Mode. If you then run a gcode-programm, you get a lot of errors in LinuxCNC if you touch the rotary-wheel a bit ...
- the most anoying: sometimes the pendant works direct (immediately), sometimes with delay (choppy). for example: sometimes the gcode-programm starts on the first keystroke of the "run"-button, sometimes you need 2 or 3 strokes, sometimes you have to wait some seconds for the next stroke ...

I found a thread in Tommylight's link-collection which deals with the choppy-behavior, but it is too complex for me to understand, have to study more .. (it depends on some definitions elsewhere in LinuxCNC)

So i need more help please.
Last edit: 12 Jan 2021 13:29 by Nordbär.

Please Log in or Create an account to join the conversation.

More
12 Jan 2021 15:01 #195059 by alkabal
Hi

For button macro I don’t know for me all a do button work like others if you create the necessary mdi_command

Fie the mpg and lead mode this is a stuff I have added to this pendant, next to this a change from other github user have broken the stuff but I have rencently push a fix to GitHub, now I think we need to wait for LinuxCNC 2.8.2

Th stuff is done like this, at startup you get mpg feed mode, using con/step for jog/using lead you get spindle feed override and after using lead you get again mpg mode.
Unfortunately No button is dedicated for set the MPG mode so this is the only way.


I have also some issue with sometimes the pendant need to wait more I retry for get the correct mode (manual/mdi/teleop), unfortunately this is something not 100% clear for me.
The following user(s) said Thank You: Nordbär

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 07:27 - 14 Jan 2021 07:29 #195293 by Nordbär
Hi Alkabal,

about the 'chopping' i found a workaround (wich seems easier) at this thread:
" www.cnc-aus-holz.at/index.php?thread/190...stID=22382#post22382 "

Translated with 'deepl-online' the post of Andreas :

Quotation: "I ask because I had with my XHC-WHB04-04 (4 axis variant) under LinuxCNC 2.9 with the driver available there also problems with the handwheel. In the form that the movement of the respective axis followed the rotation of the handwheel only delayed and jerky. At first I also suspected the USB connection and system problems.
But after a lot of searching in the source code and several tests I found the cause:
In the sample configuration for the handwheel (raw.githubusercontent.com/Linu.../example-configuration.md) the following signal connection is created in the section "#machine mode related signals":
net pdnt.mode.teleop whb.halui.mode.teleop halui.mode.teleop
However, the "halui.mode.teleop" signal is not set by LinuxCNC as expected by the driver and then causes timeouts/sleeps in the driver, which in turn causes the delays in transmitting the handwheel movement to LinuxCNC.
After I changed the signal connection to:
net pdnt.mode.is-manual whb.halui.mode.is-teleop
where the net "net pdnt.mode.is-manual" is defined in the example config as:
net pdnt.mode.is-manual halui.mode.is-manual whb.halui.mode.is-manual
Now the handwheel work without any problems."

So i interpretet this as and have done in my XHC...hal :
- commented out the lines starting with "net pdnt.mode.is-manual ..." and "net pdnt.mode.is-teleop ..."
- added the line "net pdnt.mode.is-manual whb.halui.mode.is-teleop"

i do not realy understand this either and perhaps it is nonsens, but it helps ! :P

Now i get 'chopping' only if i try around a lot (find out the 'modes' ...)
With 'normal' working on the CNC it reacts direct now!

Maybe this will bring us forward ;-) ,
regards, Norbert
Last edit: 14 Jan 2021 07:29 by Nordbär.
The following user(s) said Thank You: alkabal

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 13:46 #195313 by alkabal
Hi

Thank you i will need to study that !

If someone can explain more what is really needed to use with pendant, i remember that i does not understand 100% the halui.mode.is-teleop behavior.

Br

Please Log in or Create an account to join the conversation.

Time to create page: 0.172 seconds
Powered by Kunena Forum