How to configure a XHC-WHB04B pendant ?

More
23 Jul 2021 08:40 #215653 by andypugh

Ok this is really broke, I modified the driver to expose joint signals as well. 

That isn't usually necessary, LinuxCNC switches which input pins it looks at depending on mode. 

So, typically, a line like this will jog both:
net x-jog driver.jog-counts-0 => axis.x.jog-counts joint.0.jog-counts

And similarly for the other outputs and axes / joints.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 11:25 - 23 Jul 2021 11:31 #215674 by MRx
No this would still be broke because it switches to teleop mode which won't allow to drive outside the designated area (that was the initial reason why I had a closer look at it).
The current update is very comfortable with my setup and my mill which supports automatic homing (I'm now homing each axis independently using the knob to select x/y/z/a/c and directly with the pendant), also with the lathe which I'm homing manually.
Last edit: 23 Jul 2021 11:31 by MRx.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 11:54 #215677 by andypugh
How does it switch to Teleop? I am a bit confused that a HAL driver can do that.

What is the "it" here?

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 12:06 - 23 Jul 2021 12:38 #215680 by MRx
it? the XHC-WHB04B driver. And yes even the keyboard cannot manually home anymore after using the pendant with the current driver.
it's connected via halui in the configuration to switch the mode, basically that can configuration can also go away I don't see that the driver has to mess around with that at all.

tinyurl.com/36nsd7cj

it's wildly doing that and not correctly either.

After removing that wild code, your configuration would start to work.
Last edit: 23 Jul 2021 12:38 by MRx.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 12:53 #215683 by andypugh
OK, so I see three ways to configure the existing driver, with slightly different behaviour.

1) Connect the halui pins. Appears not to give the desired effect in some cases
2) Loop-back the pin out-to-in but don't connect to halui
3) leave the out unconnected, setp the mode-is-teleop to permanent true.

2 and 3 probably behave the same, and result in no shift to teleop.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 13:05 - 23 Jul 2021 13:06 #215685 by MRx
well the patch works well so far and already solves all the issues, the timed buttons should be refactored into classes.

after that discussion:
- the teleop code should be removed completely from the driver and from the configuration file (I'm already not using it and turning it to dead code)
- instead of creating new pins:
net x-jog driver.jog-counts-0 => axis.x.jog-counts joint.0.jog-counts

should be used.
Last edit: 23 Jul 2021 13:06 by MRx.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 14:03 #215693 by rodw
Teleop mode needs to be set to jog by default. When I set up my hardwired pendant, I got sick of walking back to the console to select Gmocappy's teleop mode jog tab. SO I programmed a button on the pendent to select it. When I do Gmocappy switches to its jog tab.

So just be aware you are overriding default behaviour.

Please Log in or Create an account to join the conversation.

More
23 Jul 2021 14:25 - 23 Jul 2021 15:12 #215698 by MRx
Can you explain your post a little bit more accurate?

Teleop is a mode, and not an option that can be set to jog.

JOG JOINT / JOG TELEOP in the sourcecode.

However there are some sub-configurations in the emc code:
EMCMOT_FREE
EMCMOT_COORD
EMCMOT_TELEOP

in any case it is absolutely wrong to set jogging to TELEOP by default with the XHC pendant. It won't allow the user to home manually anymore (neither with the keyboard nor with the pendant).

The next few updates regarding the XHC-WHB04B pendant in linuxcnc for sure will break the current behaviour and need a configuration file update.
Please elaborate what exactly you need / you're doing so I can also understand that and take care about it.

Plus are you using an XHC-WHB04B? Why should someone wire up a button to teleop mode if the XHC pendant permanently sets it to teleop already. As mentioned your post is very unclear.
Last edit: 23 Jul 2021 15:12 by MRx.

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 03:01 #215730 by rodw
linuxcnc.org/docs/devel/html/man/man1/halui.1.htmlhalui.mode.teleop bit in - pin for requesting coordinated jog mode

I have a industrial hardwired 433 Mhz wireless pendant from XHC. It has a yellow safety button that needs to be pressed and held to activate the MPG. I have the relay on this button wired to the pin above and I can jog at any time regardless of the mode.
Try running up a gmocappy sim and observe this pin halui.mode.is-teleopwhen you change tabs. I think you will find it will only activated when you are on the jog tab. Setting the first pin I mentioned will select that tab in the GUI... A mesa MPG will not jog the machine if you are not on tihs tab.

PS. I never move my machine before its homed becasue its a joint axis gantry machine. i don't have kinstype=both set in my ini file.

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 10:57 #215759 by MRx
I think you are running a wrong configuration if you're using the XHC-WHB04B pendant.

1. once you have homed an axis you are in teleop mode automatically for that axis
2. the XHC pendant (if you are using the same driver) permanently switches to teleop mode (even when not homed).
3. unhome and you're in joint jog mode (non teleop mode)

I still don't see why teleop / non teleop mode should be anything the user should touch directly by himself.
If you want to enable / disable jogging you should look at another pin -- the teleop mode should be clear now?

Please Log in or Create an account to join the conversation.

Time to create page: 0.119 seconds
Powered by Kunena Forum