joint 0 on limit switch errror

More
11 Feb 2021 19:02 #198425 by MarcWeber
I tried getting an old hobby A4 from gocnc.de to work. stepconf test axis x,y,z works.
Starting linuxcnc (2.5.0 cause I used old iso from hidden directory) shows joint 0,1,2 on limit switch errors.
I can manually disable the limits on tab 'manual control' switch machine on and ask all axis to move. But immediately it switches back to error state.

I don't think that old CNC machine has any limits at all neither does it move that fast. I failed googling how to to disable the limit switches. Is there a simple way and do manual homing?

Neither did I find any configs in stepconf which looked like they were related.
I followed this stepconf config guide: gocnc.de/download/EMC-Kurzanleitung.pdf and tried both configs 7 and 8.
7 is probably correct and allowed to switch on the machine page 8 did not.

any hints/ ideas?

Please Log in or Create an account to join the conversation.

More
11 Feb 2021 21:09 - 11 Feb 2021 21:10 #198442 by aleksamc
Add hal and ini files of your configuration at first. Ans also wiring of your cnc machine.
Last edit: 11 Feb 2021 21:10 by aleksamc.

Please Log in or Create an account to join the conversation.

More
11 Feb 2021 21:28 #198447 by tommylight

MarcWeber wrote: Starting linuxcnc (2.5.0 cause I used old iso from hidden directory) shows joint 0,1,2 on limit switch errors.

Seems the limit switches need to be inverted, be it in the hal file by adding -not to each input or by using the stepconf on the PINS page and checking the "invert" selection.

Please Log in or Create an account to join the conversation.

Time to create page: 0.088 seconds
Powered by Kunena Forum