Is there a good way to home the Z axis without a home switch?

More
24 Jul 2021 22:22 #215809 by trainwreck
Hello everybody. I'm trying to figure out if it's possible to efficiently run my machine without a z-axis home/max limit switch. I'm using the gmocappy GUI, the X and Y axis are both 2 synchronized joints, and the Z axis is a single joint. I current have the configuration set up for immediate homing on Z, so when I hit the home all button it just gets homed at it's current position while the other two axes do their thing. The problem is that once that happens I can't move above that point anymore, because it is now "0" and the soft limits don't let me move past that. I'm also not able (as far as I can tell) to move it up to where I want it before homing, because gmocappy doesn't even show you the job buttons before homing if you have synchronized joints. To make matters worse, the Z axis is heavy enough that it falls under its own weight when the machine is powered off, so I can't even move it to the top of travel at the end of a job or something to have it ready for the next day.

I'm sure the correct answer here is to just install the home switch and be done, but my cable chains are really packed plus they are in the back of an enclosure which combined would make pulling another wire through them a nightmare. Is there a workaround that isn't just a bad hack?

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 22:44 #215810 by cmorley
figure out what the machine position is when it 'falls to the bottom' and set HOME_OFFSET to that.

or jog Z to Z0 before homing.

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 02:07 #215833 by trainwreck
Is there a way to enable jogging before homing? That is honestly my ideal situation but I can't seem to figure out how to do it.

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 05:42 #215838 by cmorley
The synchronized joints complicate things.

I'm not sure the answer - in principal you should be able to jog.
If you are using jog MPGs it may be because you don't have the HAL pins for joint jogging connected.

It may be that Gmoccapy doesn't allow you to.

It may be that you must set the kinematics component differently - so it allows individual joint jogging.

I think the setting of HOME_OFFSET is much simpler.
The following user(s) said Thank You: trainwreck

Please Log in or Create an account to join the conversation.

More
31 Jul 2021 21:49 #216508 by andypugh
Setting up a position.txt file might help if the Z doesn't drop when the power is off.

See POSITION_FILE in the [TRAJ] section

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum