Homing with 7i76E with dual gantry setup

More
30 Jul 2021 09:42 #216328 by peterdownunder
I am converting an existing parport system to a Mesa 7i76E.
Have a dual motor gantry setup on X.
Both limits + home are shared on each axis (see photos.app.goo.gl/nNbkp4pRAKySmLAh8) not ideal but is how it was setup and working with the parport setup (more IO with Mesa will allow us to change this)

Currently I can get the Z and Y to home Ok, but when I try to home X only one motor moves.
When I use pnconf to setup the stepgen with tandem it only tests one of the X stepper (that may be just the way it works)
If I play with the pnconf and assign the misbehaving X stepper to another axis it steps ok, so wiring and driver appear Ok.

previously in the parport setup I just ran 3 stepgens and net the x-step to both stepper drivers.

Current setup is here
github.com/peterdownunder/mechmesa

I am sure it is just a setup issue, but it is a config I have never dealt with before

 

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 10:56 #216339 by tommylight
Choose a normal axis/joint for one of the tandem stepgens then choose a tandem for the other, be sure to chose a normal XYZ at the start, not XYZA.

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 10:59 #216340 by mgm
Hy

maybe it is because of the missing entries in the hall ...

setp hm2_7i76e.0.stepgen.00.stepspace [JOINT_1]STEPSPACE
setp hm2_7i76e.0.stepgen.00.position-scale [JOINT_1]STEP_SCALE

greetings
Michael
The following user(s) said Thank You: peterdownunder

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 19:45 #216389 by peterdownunder
I'm pretty sure that is all that I did, with the above results

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 19:46 - 30 Jul 2021 19:48 #216390 by peterdownunder
Thanks Michael, I will give that a try this morning
Last edit: 30 Jul 2021 19:48 by peterdownunder.

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 22:06 #216403 by peterdownunder
another question.

When running pnconf with the tandem x axis setup in the stepgen, should the test x-axis procedure step both motors ?
 

Please Log in or Create an account to join the conversation.

More
30 Jul 2021 23:05 #216410 by peterdownunder
Thanks Michael, that was the problem.

Have been having a problem with the keyboard/mouse auto selecting when I move. Suspect it deleted something I did not notice. Have already had to revert the file once to a previous commit, but did not notice this.

Mouse relegated to the rubbish.
 

Please Log in or Create an account to join the conversation.

Time to create page: 0.091 seconds
Powered by Kunena Forum