Can not get jogging from Encoder after homing

More
12 Sep 2021 18:05 #220347 by slammers
I am in the process of converting one of my mills from Mach3 to LinuxCNC. I am experimenting with a bench setup and a Mesa 7i93 thernet card. I ran the Pncconf wizard to get stared and have added hand wheel encoders for all axis. I choose the gmoccpy interface

I have manualy modified the HAL file to add 

net x-jog-count => joint.0.jog-counts
net y-jog-count => joint.1.jog-counts
net z-jog-count => joint.2.jog-counts

I also set 
set axis.x.jog-enable to true
set axix-x-jog-scale .0001 

When I run the program and power the machine, turning the encoders move the axis as expected. But as sone as I home all axis, the encoders no longer function. Is this normal? The interface says the machie is in manual mode so I expected to be able to move the axis with the encoders.

My goal is to use the mill in manual mode with the encoders and have the encoders be disabled when in auto mode

Shawn





 

Please Log in or Create an account to join the conversation.

More
12 Sep 2021 18:41 #220350 by Aciera
Note that since version 2.8 there is a separation between 'joints' and 'axis'. Roughly speaking 'joints' exist before homing and turn into 'axis' after homing. So to get jogging working after homing you want to change your hal to:

net x-jog-count => joint.0.jog-counts => axis.x.jog-counts
net y-jog-count => joint.1.jog-counts => axis.y.jog-counts
net z-jog-count => joint.2.jog-counts => axis.z.jog-counts

Please Log in or Create an account to join the conversation.

More
13 Sep 2021 14:05 #220442 by slammers
Oh, thanks, I originally was using axis.z.jog-counts but it did not work at all. I will give this a try

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum