Disable homing of an axis

More
08 Nov 2022 17:35 #256221 by turbostew
Hey All,
I have a mill with a 4th (rotary) axis.  I have no home switches on the 4th axis. What I want is to press "home all" and my 4th axis will do nothing but turn the DRO green (indicating it is homed).  I want it to use the current position at startup as the "home position".  Right now it zeros out the position (DRO) when "home all" is pressed.

I actually searched for about an hour and figured this topic was beat to death but I couldn't really find an answer, so I apologize in advance if I missed the obvious.... 

HOME_OFFSET = 0.0
HOME = 0.0
HOME_SEARCH_VEL =     0.0
HOME_LATCH_VEL =      0.0
HOME_FINAL_VEL = 0.000000
HOME_USE_INDEX =      NO
HOME_IGNORE_LIMITS =  YES
HOME_SEQUENCE =       0
HOME_IS_SHARED =      0
VOLATILE_HOME =       0

Please Log in or Create an account to join the conversation.

More
08 Nov 2022 18:01 #256227 by andypugh
Replied by andypugh on topic Disable homing of an axis
That ought to work, but maybe try HOME_SEQUENCE = 1

Please Log in or Create an account to join the conversation.

More
08 Nov 2022 19:13 #256234 by turbostew
Replied by turbostew on topic Disable homing of an axis
I posted my ini file that currently does NOT work....

Please Log in or Create an account to join the conversation.

More
08 Nov 2022 19:59 #256236 by andypugh
Replied by andypugh on topic Disable homing of an axis
Yes, I understand that. And I think it should have worked.
In that I was saying that the problem isn't obvious to me.

Please Log in or Create an account to join the conversation.

More
08 Nov 2022 20:19 #256239 by HansU
Replied by HansU on topic Disable homing of an axis
You could do this with a little macro or a python snippet or so.
Basically
1. save the current position
#<a_pos> = #<_a>
Where #<_a> is a predefined parameter (see linuxcnc.org/docs/html/gcode/overview.ht...ned-named-parameters)
2. do homing
3. modify the offset to restore the old position, here using G54 (^=P1)
G10 L20 P1 A#<a_pos>
 

Please Log in or Create an account to join the conversation.

More
08 Nov 2022 20:57 - 14 Nov 2022 22:29 #256243 by turbostew
Replied by turbostew on topic Disable homing of an axis
Thanks All,

I think i have a solution. I seem to be able to do this using HOME_ABSOLUTE_ENCODER = 2 even though I am not using abs encoders....
Last edit: 14 Nov 2022 22:29 by turbostew.
The following user(s) said Thank You: HansU, sf9090

Please Log in or Create an account to join the conversation.

Time to create page: 2.939 seconds
Powered by Kunena Forum