Writting a PP w/ATC PP will not post plunge feed rate after toolchange

More
16 Mar 2019 22:19 #128778 by allenwg2005
Writing PP for Vetric Aspire CAD/CAM software.

I was just running this test file for my PP and noticed something I can't explain or change, no mention of it in the Vetric manual either.

You will note there is a plunge rate on G01 under "Outside Profile", under "Inside Profile" and "Line" the G01 has no plunge rate.
How do I get those plunge rates to load when I post the file?

Thanks in advance.

%
(Vectric post test file File created: Saturday March 16 2019 - 02:27 PM)
G17 G20 G90 G40 G49 G64 P0.001
(Outside Profile)
T1 M06 (T1 End Mill 0.25 inch)
G43 H1
M03 S12000
G54 (Coordinate System)
G0 Z0.5000X1.0364Y3.3945
G0 Z0.2000
G01 Z-0.2500 F10.0000 G4 P0.5
G2X0.4114Y4.0195I0.0000J0.6250F52.2500
G2X1.0364Y4.6445I0.6250J0.0000
G2X1.6614Y4.0195I0.0000J-0.6250
G2X1.0364Y3.3945I-0.6250J0.0000
G0 Z0.5000
(Inside Profile)
M6 T21 (T21 End Mill 0.125 inch)
G43 H21
S12000 M03
G54 (Coordinate System)
G0 Z0.5000X3.3272Y1.3472
G0 Z0.2000
G01 Z-0.2500 G4 P0.5
G2X3.7647Y1.7847I0.4375J0.0000F52.0000
G2X4.2022Y1.3472I0.0000J-0.4375
G2X3.7647Y0.9097I-0.4375J0.0000
G2X3.3272Y1.3472I0.0000J0.4375
G0 Z0.5000
(Line)
M6 T1 (T1 End Mill 0.25 inch)
G43 H1
S12000 M03
G54 (Coordinate System)
G0 Z0.5000X1.4093Y2.6212
G0 Z0.2000
G01 Z-0.2500 G4 P0.5
G1X3.9449F52.2500
G0 Z0.5000
G0Z0.5010
G0X1.0000Y1.0000
M2
%

Please Log in or Create an account to join the conversation.

More
16 Mar 2019 22:58 #128779 by FariaAl
Do you have this in your Vectric PP?

+
+ Commands output for PLUNGE Moves
+
begin PLUNGE_MOVE
"G01 [Z] [F]"

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 01:23 #128792 by allenwg2005
Here's what I have:

+
+ Commands output for First_PLUNGE Moves
+

begin FIRST_PLUNGE_MOVE
"G01 [Z] [FP] G4 P0.5"

+
+ Commands output for PLUNGE Moves
+

begin PLUNGE_MOVE
"G01 [Z] [FP]"

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 02:48 #128796 by FariaAl
What is the "P" after the "F" for?
I tried with a "P" as you have and it did not work, but it did without it.
Try removing it..

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 12:33 - 17 Mar 2019 12:46 #128814 by bevins

FariaAl wrote: What is the "P" after the "F" for?
I tried with a "P" as you have and it did not work, but it did without it.
Try removing it..


That's F for Feed P for plunge.
I dont know why he is using that as it is for the Shark CNC. Doesnt need it. The default linuxCNC PP works just fine with Linuxcnc, at least in Aspire. I just added the ToolChange to mine and it works fine.

I would think LinuxCNC interpreter would not like it and spit at you or just ignore it.
Last edit: 17 Mar 2019 12:46 by bevins.

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 14:58 #128824 by allenwg2005
Interesting, let me share results both ways.

In the truncated file "Vetric post test" below I used the var commands in the PP for plunge, the first G01 move is at the "Plunge" rate in the tool library, and only the first G01 move has it, any G01 moves under it are at the "Feed" rate in the tool library.

In the file "Vetric post test file" I removed all the plunge commands in the PP, the result is without the plunge commands in the PP G01 moves are all at the "Feed rate".

Any ideas or thoughts?

(Vetric post test File created: Sunday March 17 2019 - 07:21 AM)
G17 G20 G90 G40 G49 G64 P0.001
(Outside Profile)
T1 M06 (T1 End Mill 0.25 inch)
G43 H1
M03 S12000
G54 (Coordinate System)
G0 Z0.5000X1.0364Y3.3945
G0 Z0.2000
G01 Z-0.2500 F10.0000 G4 P0.5


(Vetric post test file File created: Sunday March 17 2019 - 07:17 AM)
G17 G20 G90 G40 G49 G64 P0.001
(Outside Profile)
T1 M06 (T1 End Mill 0.25 inch)
G43 H1
M03 S12000
G54 (Coordinate System)
G0 Z0.5000X1.0364Y3.3945
G0 Z0.2000
G1Z-0.2500F52.2500
G2X0.4114Y4.0195I0.0000J0.6250

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 15:27 #128826 by bevins
What are you trying to do? Editing the post ok, but for what?
Aspire comes with Post processors that work perfectly for linuxcnc.

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 15:34 #128828 by Leon82
Is there a way to force output?
For example in mastercam adding a * in front of the string will force the output

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 15:36 #128830 by allenwg2005
You bet, the standard post in Vetric works fine for paths without toolcahnge in them, you run them one at a time and have to remeasure
the tool each time you change it.
I decided to do a PP with ATC so LCNC could use the tool table G43 H[T] to load tools as the file progresses.

That all works, I just need to get the G01 calls to work with the "Pluge " rate in the library.

Please Log in or Create an account to join the conversation.

More
17 Mar 2019 16:01 #128833 by allenwg2005
I should add, when you look at the PP in Vetric there are no VAR's for the plunge call to happen, but it's in each ngc file where it's needed. (One tool at a time).
Adding ATC seems to have changed this and the only way I could find to add plunge was the VAR's I shared above, the only problem is it just adds it once.

And thanks for all your help folks, I appreciated it.

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum