Any use of RTAI livecd? Where did it go?

More
14 May 2018 12:06 #110724 by AnnoyingMutt
From memory I did:
unxz patches-4.9.4-rt2.tar.xz
cd linux-4.9.4
cat ../patch-4.9.4-rt2.patch | patch -p1

The config file can be tuned but I went with something pretty close to the original huge kernel.
More
14 May 2018 21:53 - 14 May 2018 21:55 #110744 by jmr
Well... Thanks! I can say that Your "howto" is good. All compiled and almost running on Slackware 14.2. For tkimg and deb2tgz i got slackbuilds from SBo. Slapt-get was very nice to install all of that.
Also to run some (? latency-histogram) of the /scripts i needed to run "source rip-environment", and add the dirs to the PATH variable. Is there something more I should know?
Is all of the /usr/realtime stuff coming from RTAI? It seems I have to patch the kernel with rtai patch to let it compile the tools. Can it coexist with -rt patch? I could possibly use the setsmi and also the kernel latency test which displays results in terminal.
One of my test configs cannot load hal_ax5214h. That worked with my quad 8255 board some time ago. The source is out there, along with hal_parport, but it was not build. Should I ask for it specially at some point?
Last edit: 14 May 2018 21:55 by jmr.
More
14 May 2018 23:55 - 16 May 2018 01:52 #110750 by AnnoyingMutt
I'm glad it worked, I had some scribbled notes, and some memory of what I did.

Sometime I go I went thru the Linux From Scratch & Beyond Linux From Scratch thing and got Linuxcnc running on that, but that was more just to see if it would work. I wouldn't recommend it unless you have a fair bit of time on your hands lol

You could source the rip-environment from your profile, to make life easy.

Regrading rtai/preempt It's a case of one or the other:
www.rtai.org/userfiles/downloads/RTAI/rtai-5.1.tar.bz2

Has patches for:
4.4.115
4.4.71
4.9.51
4.9.80

I haven't tried an rtai kernel yet. I just had a look on my server I haven't compiled an rtai kernel for the 4.4.x or 4.9.x series yet.

Just found this, maybe useful.
docs.slackware.com/howtos:software:rtai

Rtai with 64 bit ? I had trouble compiling Linuxcnc, I'm not sure it will work without some major faffing about. SSE2 in kernel space, from what I can gather, is an issue. Tho I maybe wrong, more than likely am, but it would really need a developer stepping in to say for sure.
Last edit: 16 May 2018 01:52 by AnnoyingMutt. Reason: Added link to slackware rtai, comments about 64 bit rtai
More
16 May 2018 11:30 #110787 by jmr
I think I know where is the missing ax5214h driver. It is not compiled when --with-realtime=uspace. Next attempt is with rtai patch, as that is the default with linuxcnc distribution.
There was some strange behavior with that 4.9.4-rt2 kernel on two pentiumIV machines. I could get latency-test to work, however sometimes it would not close. Then I tried also a few times to unpack the kernel source, the result was hanging (D - defunct?) tar process, which could not be killed. New logins, new processes worked, but there was a problem to terminate them. Even joe the editor would not close.
I dont know if thats related, but i got some "NOHZ: local_softirq_pending 02" messages in dmesg.
More
17 May 2018 01:16 #110801 by AnnoyingMutt
ATM I can't comment of the P4 issue, when I did the first build it was inside Virtualbox on a Core i5 with a setup for a 64 bit linux guest. On real hardware I was using an Athlon 64 X2 5200+. The config I posted was for a 64 bit setup. I'll see if I can drag a 32 bit P4 and see how I go.....until then I really can't suggest what the issue might be.
More
17 May 2018 07:57 #110809 by jmr
Maybe I will get back to that later. Maybe it has something to do with HPET which I enabled for the second kernel.
Now I'm trying with rtai.
I had it fail at hal.o ... "error: implicit declaration of function 'rtai_rdtsc'..." - that turned out to be because I selected 586 cpu. Some message somwhere was about "ridiculous" number of people reporting problems... Current version propably requires TSC, and this way it does not work on 486 and (some?) 586. Now i selected p2 or p3 and it DID compile. Now I will try that.
Time to create page: 0.063 seconds
Powered by Kunena Forum