Installing LinuxCNC on Debian 9

10 Jul 2018 18:00 - 04 Aug 2018 15:09 #113960 by BigJohnT
Here is the method I use to install LinuxCNC on Debian 9 and setup for using an Ethernet Mesa card.
Download the latest from here

 and rename it to amd64-netinst.iso

Burn to a CD
Boot from the CD
Graphical Install
Do Not enter a Root Password! Just hit enter.
Debian desktop environment
SSH server
standard system utilities

after booting to Debian 9 open a terminal

sudo nano /etc/lightdm/lightdm.conf
to log in without your user name a password uncomment
and add your user name

CTRL X and yes to save and exit.

Open the Synaptic Package Manager
search for linux-image and install linux-image-

reboot the pc
in a terminal type uname -a it should report back PREEMT RT

Linux d9-uspace 4.9.0-6-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 GNU/Linux

in a terminal
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install dirmngr
sudo apt-key adv --keyserver hkp:// --recv-key 3cb9fd148f374fef
sudo apt-get install software-properties-common
sudo add-apt-repository "deb stretch base 2.7-uspace"
sudo apt-get update
sudo apt-get install linuxcnc-uspace

Configure the network adapter to work with an ethernet card
To find the ethernet adapter name
ip link show
ip a

sudo nano /etc/network/interfaces

auto enp0s25 << change to match your interface name
  iface enp0s25 inet static

Last edit: 04 Aug 2018 15:09 by BigJohnT.
The following user(s) said Thank You: trilobyte, tommylight, AnnoyingMutt, rodw, Grotius, spma, JetForMe
11 Jul 2018 19:56 #114024 by Grotius
Hi John,

Why not cloning a pre configured debian 9 with clonezilla server?
This saves time.... I only tried the cd clonezilla, this works perfect. 15 minutes ready.
Is this an idea to use?
11 Jul 2018 22:20 #114035 by BigJohnT
I guess once you setup the drive cloning it might be a good thing.

12 Jul 2018 05:20 #114044 by tommylight
Or use "SystemBack" that is very friendly and easy to use.
In some cases you have to uninstall casper and install liveboot, but otherwise it works nicely and can also make an ISO that can be booted from a USB.
04 Aug 2018 02:00 #115574 by Vitran

This link you provided is only a few days old, but it is giving a 404 Not Found. Where can one find where the disk images are?
04 Aug 2018 12:31 #115599 by Vitran
That works, thank you. Yesterday it was providing a 404 when I copied BigJohnT's link no matter what I tried, but I was doing it on a different computer.
04 Aug 2018 15:10 #115605 by BigJohnT
I should have known better than to put the file name in the link... it will change.

01 Oct 2018 11:40 #118278 by sirx
Hi admin,

please it's all right until I type this line:

lablpm@PCBCNC2:~$ sudo apt-key adv --keyserver hkp:// --recv-key 3cb9fd148f374fef
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.V8ERg2YaYv --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --keyserver hkp:// --recv-key 3cb9fd148f374fef
gpg: requesting key 8F374FEF from hkp server
?: Host not found
gpgkeys: HTTP fetch error 7: couldn't connect: No such file or directory
gpg: Non sono stati trovati dati OpenPGP validi.
gpg: Numero totale esaminato: 0

Please help me to fix the problem
best regards
21 Oct 2018 15:16 #119161 by BigJohnT
You probably skipped a step.

Time to create page: 0.083 seconds
Powered by Kunena Forum