LinuxCNC running on Ubuntu 18.04 updated to kernel 4.18.12 with Preempt RT

More
09 Oct 2018 23:42 #118610 by irakandjii
FINALLY!!!!!! LinuxCNC runs!!!
I was able to patch and compile the current stable kernel 4.18.15. I used the instructions as laid out in :

www.cnc-club.ru/wiki/index.php/%D0%A3%D1...D%D0%B0_Ubuntu_18.04 I used google translate on this and it worked well
and
forum.linuxcnc.org/9-installing-linuxcnc...04-preempt-rt-kernel

I used the current sources: (cdn because that is where I am, your country may be different)
cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.18.12.tar.gz
cdn.kernel.org/pub/linux/kernel/projects...4.18.12-rt7.patch.gz
Compiled flawlessly, only the normal warnings for strings exceeding 1024 bytes

LinuxCNC compiled flawlessly using the instructions from the Russian site and from the installation guides for LinuxCNC.
There were some minor issues with dependencies that were easily resolved. Instructions provided by make and reference documentation.
All tests passed

System info (Coffee lake)
Gigabyte Z370 with i5 8600k (using -j6 option kernel took about 3 min to compile), board has onboard Parallel Port
16 Gb memory
256 Gb SSD

I ran latency-test and have odd results that need investigation, I expected better.
Max Interval (ns)Max Jitter
Servo thread (1ms)101390313903
Base thread4154317317

I believe these numbers are sufficient, but will read further.

Running Linux system monitor tools concurrently indicates no CPU is above 3% occupancy. Leads me to believe there is lots of room for my other applications.

I am using realVNC to access the system remotely, I suspect it may have an impact.. So I will investigate further.
My guess; there is an underlying process consuming some real-time. I will look in this forum for advice.

Next steps: Finish testing then hook up my CNC board
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
10 Oct 2018 05:29 #118618 by tommylight
You are on the right path to success, everything looks ok, from latency to having enough power for other applications.
Nice work, thanks for reporting back.
The following user(s) said Thank You: irakandjii

Please Log in or Create an account to join the conversation.

More
10 Oct 2018 12:05 - 10 Oct 2018 12:27 #118634 by irakandjii
Thank you.

Very interesting, did a lot of reading last night and better understand the impact of the bios etc. So this morning I went in and turned a few things off in order to experiment.
- turned off all power management funtions
- I am using the onboard cpu based intel 630 GPU, I might have an old graphics card lying around.

So far it is about the same with bios elements turned off, I am curious though and will keep working on it. I will play with the fan monitoring next.

Logged directly into the machine, and I cannot run latency-test or linuxcnc ...file not found. (found in scripts .. )

I see other installations online have an Icon on the desktop with options etc. I might have missed a step, can anyone point me in the right direction on how to get this feature? Is it a problem with reverting back to gnome?
Last edit: 10 Oct 2018 12:27 by irakandjii. Reason: Solved my original problem

Please Log in or Create an account to join the conversation.

More
11 Oct 2018 03:32 #118663 by irakandjii
Update: Installed a graphics card I had lying around,
Jitter dropped to servo ~8000, base 10000
Looks like I have a launch.

Now to just get the software running again.

Please Log in or Create an account to join the conversation.

More
12 Oct 2018 12:12 #118700 by andypugh
To be honest I would take the more compact arrangement of onboard GPU over a small reduction in latency, especially if you don't intend to use software step generation.
The following user(s) said Thank You: irakandjii

Please Log in or Create an account to join the conversation.

More
12 Oct 2018 14:38 - 12 Oct 2018 14:40 #118719 by irakandjii
I will be using a board that uses the parallel port to connect from the pc the controller so I think this is software step generation set-up. But, I have not got quite that far yet in my education to understand the difference.

What you say makes sense though, thank you.

For now, I am trying to really understand what is going on so I can diagnose the inevitable "WTF" happened moments in my future.
Last edit: 12 Oct 2018 14:40 by irakandjii.

Please Log in or Create an account to join the conversation.

More
10 May 2019 13:22 #133351 by k-1
not so easy to do!

you must add:
deb http://old-releases.ubuntu.com/ubuntu/ precise main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ precise main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ precise-security main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ precise-security main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ precise-proposed main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ precise-proposed main restricted universe multiverse

in your source.list, because precise is now old releases ... + you need to solve no_public key issue with old release so:
sudo apt-get install debian-archive-keyring

Than tcl8.4-dev package required is possible to install only in new releases tcl8.5-dev. But these is quite simple to do:
sudo apt-get install tcl8.5-dev tk8.5-dev

+ printui support is no more avaiable so i use these link:
https://www.ubuntuupdates.org/package/core/precise/universe/base/libgnomeprintui2.2-dev

after these ... without any type of latency issue trik and max abuse of pc (glx 4 windows, youtube 3 video, install multiple addictional package during running latency test) and after 2 hour the result is in these pic.

During upload of the image latency base max-jitter go to 100.000 .... asusB250M, I5 7500 ... I try with isol-cpu and fix smi if i have these issue. But probabily not because the result is after 2 hour of work.

regards
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.157 seconds
Powered by Kunena Forum