Need help installing LinuxCNC

10 Mar 2019 18:46 - 20 Mar 2019 21:49 #128264 by Don4
I am having difficulty getting LinuxCNC. I cannot even get a "live" version going. I have never used LinuxCNC before so the installation is all new to me. I may be doing something wrong but I just can't figure it out.

I have a new computer and planned on triple booting Windows 10, Ubuntu 18.04, and LinuxCNC. Windows and Ubuntu installation went without a hitch but I have been trying to get LinuxCNC going for a couple weeks now without success. I tried everything I can think of. I have tried creating a bootable USB from both windows and ubuntu as well as a bootable DVD. Nothing seems to work or be recognized. I have done the md5sum on the iso file and everything looks good. I even did an md5sum -c md5sum.txt to compare what was on the dvd to the md5sum.txt file and each and every file was ok.

When I create dvd or usb from ubuntu the bios does not recognize it and it does not show up as an option for booting. When I create it in Windows 10 it DOES show up in the boot list but it doesn't work.

I have looked for other posts and other sites for help in creating a valid boot dvd/usb and tried several things but still can't get anything to work.

One thing I noticed while doing all this is the newest date of a file on the DVD is Sep 5 2015 for the current release . That makes me wonder if LinuxCNC iso file is current? I see that LinuxCNC has been released on a regular basis in 2017 and 2018 but it looks like I got something older.

I downloaded the file from under the Download link as shown below.

1. Download the image
This section describes some methods for downloading the Live/Install Image.

1.1. Normal Download
Download the Live/Install CD by clicking here:

Is there somewhere else I need to get the iso file from?

Last edit: 20 Mar 2019 21:49 by Don4. Reason: moved update to be a reply rather than an edit

Please Log in or Create an account to join the conversation.

11 Mar 2019 04:05 #128283 by tommylight
That is the old version and that is a "hybrid" image so it has to be done with DD in Linux or with some software in windows that can work with hybrid images, if i remember correctly one is named rufus or similar.
The new version of Linuxcnc is here
The following user(s) said Thank You: Don4

Please Log in or Create an account to join the conversation.

11 Mar 2019 04:56 #128286 by InMyDarkestHour
Use this:

Never had a problem with it at all. Some utilities are "too smart" for their own good.
The following user(s) said Thank You: Don4

Please Log in or Create an account to join the conversation.

11 Mar 2019 07:12 #128295 by pl7i92
hi done
you may also tell us here what you try to do
Linuxcnc SIM on a VirtualMashine install inside Win10
or trying to get a Real mashine going on a Seperate PC

the Stretch is the newest Distro
you may need a more modern PC for running this
wheezy will run under most PC
The following user(s) said Thank You: Don4

Please Log in or Create an account to join the conversation.

20 Mar 2019 21:46 #129118 by Don4
Replied by Don4 on topic Need help installing LinuxCNC
First I want to thank everyone for your help to my original post. I did get farther than I had with the wheezy.iso by using stretch version. But I am still having difficulty.

One person wondered about my hardware. What I have is a brand new machine with an Asus Prime z390-a motherboard and Intel z390 chip-set. The processor is an I7-9700K and I have a 1TB Samsung nvme ssd i am using as my primary storage. I also have 32gb memory.

I do NOT plan to use this computer for running a CNC machine but I wanted to install LinuxCNC on it to learn about it and hopefully do some simulations. I am in the early stages of upgrading a Bridgeport mill to use either LinuxCNC or Mach3 or 4 (hopefully LinuxCNC) and I do not have a computer in my workshop as yet for running LinuxCNC. My intention was to have a triple boot system with Windows 10, Ubuntu 18.04 and LinuxCNC running on it. I installed Windows 10 and Ubuntu with no problems but I seem to be having all sorts of trouble installing LinuxCNC and getting it to go. Let me explain what I tried since my first post.

I had trouble installing the wheezy version so I tried other versions as suggested by tommylight. I first tried the linuxcnc-stretch-uspace-i386.iso thinking that is what I needed since I have an Intel processor. I downloaded the iso and could not get a usb or dvd to work so I gave up on that (similar difficulties to the wheezy version). I did some more reading and found out that amd64 is just the name used for the 64 bit version whereas the i386 is 32 bit.

I then tried linuxcnc-stretch-uspace-amd64.iso and that DID work SORT-OF. I successfully got a live version running except there was no internet connection. I didn't give that much thought thinking maybe I need to install it before the internet will work.

I tried installing the 64 bit version and things were going fine until it got to point of trying to find my network "card". At that point it said something to the effect of not being able to find or recognize my network card and gave me a long list of potential drivers. I don't have a "card" as such, the network connection is part of my motherboard and since I didn't recognize anything in the list I told it to go ahead and install without it. My thought was what harm can that do? If it doesn't work I will just remove it and try something else. So I proceeded on with the installation and things seemed OK until near the end the installer wanted to go to some FTP or other sight to get additional "stuff". Of course that didn't work since I had no internet connection so after getting a bunch of errors I finally got done with the installation.

I tried rebooting and I could not boot to LinuxCNC so at that point I thought I would go back to Ubuntu and see what else I could find about installation and how to get LinuxCNC to recognize my internet connection. When I went back to Ubuntu I was shocked that it took about 10 times longer to boot than normal. Originally Ubuntu booted in about 3 or 4 seconds, now its taking 30 or more seconds. After some research I found this command systemd-analyze blame which apparently tells me the time it takes various services to execute during boot. This is what I am getting (first few lines of output)

10.042s apt-daily-upgrade.service
9.565s fstrim.service
5.078s bolt.service
3.174s NetworkManager-wait-online.service
2.123s plymouth-quit-wait.service
752ms fwupd.service
396ms apt-daily.service
391ms snapd.service
304ms systemd-logind.service
243ms snap-gnome\x2dsystem\x2dmonitor-57.mount

I am not sure what all that means except there are a few services that are taking a long time to execute. I don't have the same results from that command prior to trying to install LinuxCNC but I do know that the boot was fast... on the order of 3 or 4 seconds. Well so much for my thought that it would do no harm installing LinuxCNC. It apparently harmed the boot process for Ubuntu. I am thinking it has something to do with GRUB but am not sure.

I am not sure what to do now. I guess I could wipe out Ubuntu and reinstall but I don't know where all the grub stuff is stored or maybe i could reinstall grub or whatever. If I remove and reinstall Ubuntu will that fix the grub problem? (That is assuming it is a problem with grub?)

So bottom line is I don't have a working version of LinuxCNC and the boot process for Ubuntu is now broken. Any suggestions or recommendations on how to move forward is appreciated. If LinuxCNC won't work on this machine then at least I would like to get the boot process fixed for Ubuntu. (Windows boot still seems to work fine).

Thanks in advance for your help

Please Log in or Create an account to join the conversation.

20 Mar 2019 23:22 #129123 by InMyDarkestHour
OK your Network Interface Card (whether a physical card or part of your motherboard) is not being recognised. Hence debian\linuxcnc not working. This could be no support in the debian kernel or some "non-free" code or binary blob that is not on the standard debian setup.......Yes it can be confusing.

The simplest thing to do, if you do not have anything critical is reinstall Ubuntu, or this link maybe of help:

If you just want to "play around" with Linuxcnc you can install it in a virtual machine :ie VirtualBox which should be packaged for Ubuntu.

If any of this is gibberish or doesn't make sense I'll try to walk you through it....It's hard to judge other's level of skill or knowledge to begin with.

The following can be ignored for now.
Later on you can "image" that installation and install it real hardware.

Please Log in or Create an account to join the conversation.

21 Mar 2019 00:14 - 21 Mar 2019 00:16 #129125 by tommylight
To late, maybe, but if you do not intend to run a machine with that computer you should have just installed the SIM version of Linuxcnc on Ubuntu and be done with it. You can run code and check everything as in a normal installation of Linuxcnc, but it will not control a machine.
There are ready made deb's for sim ( simulator ), so you can still try to install that.

The systemd message you posted says that daily updates are taking over 10 seconds!
That is one of the reasons why i do not use Ubuntu any more, and it also does some indexing at every computer start that keeps the processors running at full throttle for a long time after booting.
I do still use 10.4 with Linuxcnc on some older laptops.
The best thing about Linux in general is that you press the power button on the PC and until you sit in front of it, it is already up and runig, with everything set. Hell on this laptop ( Dell E6510 with SSD ) the BIOS takes longer !
@#$$ Forgot the link to the deb's
Last edit: 21 Mar 2019 00:16 by tommylight. Reason: link

Please Log in or Create an account to join the conversation.

22 Mar 2019 16:24 #129262 by Don4
Replied by Don4 on topic Need help installing LinuxCNC
Thanks again for your help. To give you an idea of my experience doing this sort of thing it was zero before I started. I am a retired aerospace engineer and worked on jet engine control software. I am familiar with software development and have used Unix and more recently before I retired we were using bash with Windows at work.

So Linux itself isn't entirely new to me but I have never did anything with operating systems or system administration. In the past at home I had a Windows only system and my administration amounted to just copying important files to an external drive ha ha.

I am so sick of Windows that I just about gag every time I have to use it but there are some 3rd party programs I am using that only work on Windows. This is the first time I ever built my own system, did any drive partitions, installed OS etc. so please forgive my ignorance on this stuff.

Based on your comments it sounds like LinuxCNC doesn't recognize or support the network on my motherboard (ASUS Prive Z390-A). I am surprised about that since Ubuntu had no problem. Aren't drivers etc. shared between the various Linux organizations?

At any rate I guess I don't need it if I do the virtual box thing with Ubuntu. I am not sure how to do the virtual box yet but there is other work I need to do first. I think I will remove the partitions I had created for LinuxCNC and reinstall Ubuntu. I don't have anything important on it yet so that shouldn't be a problem.

Once I get Ubuntu going again I am not sure how to proceed with the virtual box thing. Can you point me to some instructions on that? Hopefully I won't screw up Ubuntu again trying to do that.

I really appreciate your help.

Please Log in or Create an account to join the conversation.

22 Mar 2019 16:51 #129266 by tommylight
From Ubuntu you have to install VirtualBox or Qemu, once you open them you have to set some parameters like HDD, memory and stuff, point it to an ISO image and click start. From that point on it is the same as having another computer, so proceed with normal install.
This is just a rough version, as i never use it, but i did use it way back for testing USB bootable drives.

Please Log in or Create an account to join the conversation.

22 Mar 2019 18:20 #129269 by InMyDarkestHour

Please Log in or Create an account to join the conversation.

Time to create page: 0.138 seconds
Powered by Kunena Forum