linuxcnc 2.8.0-buster ISO 2020 Sept. 7

More
14 Sep 2020 18:18 #182118 by partec
installation with linuxcnc 2.8.0-buster ISO 2020 Sept. 7 is actually here for me only without apt updates possible, what can be wrong?

File Attachment:

File Name: ERROR.txt
File Size:3 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Sep 2020 21:09 #182139 by tommylight
Seems that there is no networking active.
Are you using a cable or WiFi ?
The following user(s) said Thank You: partec

Please Log in or Create an account to join the conversation.

More
14 Sep 2020 23:18 - 15 Sep 2020 23:33 #182162 by partec
I use cable and could ping some of the servers
network here is with a IPFire 2.25 (x86_64) - Core Update 148
on not debian pc's E-Mail and Internet was workig some way like normal

anyway there behind I just restarted the fiber optic modem, thank you Tom,

with success, now the debian connections become established again
Attachments:
Last edit: 15 Sep 2020 23:33 by partec.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 23:38 - 15 Sep 2020 23:48 #182303 by partec
LinuxCNC 2.8.0 buster Xfce iso installation - experiences report

AUTOLOGIN
sudo nano /etc/lightdm/lightdm.conf

Xfce usage
xset

SCREENSAVER
sudo xset s off

POWER MANAGEMENT
sudo xset -dpms

SETTINGS -> SESSION -> Autostart
uncheck Screensaver (launch Screensaver)

sudo apt-get install gedit

sudo apt-get install screengrab

sudo apt-get install samba

sudo apt install libsmbclient smbclient gvfs-backends

sudo smbpasswd -a USERNAME

make a safe backup copy of the original smb.conf file

sudo gedit /etc/samba/smb.conf

AXIS.INI
[DISPLAY]
EMBED_TAB_NAME= qtscreen
EMBED_TAB_COMMAND= halcmd loadusr -Wn qtvcp_embed qtvcp -d -c qtvcp_embed -x {XID} cam_align

Attachments:
Last edit: 15 Sep 2020 23:48 by partec.
The following user(s) said Thank You: phillc54, tommylight, Aciera, Himarc3D

Please Log in or Create an account to join the conversation.

More
19 Sep 2020 13:50 #182744 by Rallinger
Hello, sorry to all for a maybe dumb question ...
I'm a complete Linux/LinuxCNC Newbie. I'm building my first CNC machine and have to decide which software to use to control it. Linuxcnc in combination with a 7i96 mesa card would be my absolute favorites. However I do only own a 12year old Laptop with a 32bit architecture.

I tried to install the actual ISO provided from the official page. However I cannot boot the PC. It loads the BIOS and then when trying to boot I get a black screen and the BIOS is loaded again from the beginning. No error messages.

My question: is there a way to install and run Linuxcnc 2.8 / Debian 10 on a 32bit architecture?

Thank you very much for any advice!

Please Log in or Create an account to join the conversation.

More
19 Sep 2020 14:01 #182746 by tommylight

Rallinger wrote: My question: is there a way to install and run Linuxcnc 2.8 / Debian 10 on a 32bit architecture?

Unfortunately not.
The following user(s) said Thank You: Rallinger

Please Log in or Create an account to join the conversation.

More
More
19 Sep 2020 15:34 #182752 by tommylight

partec wrote: www.alternate.de/GIGABYTE/GA-J3455N-D3H-...html/product/1503683 ?

Ich weis nicht ! :blush:
Usually those small boards do work well, but there are some that do not, and there is no way of knowing if someone already have not tried it.
Maybe someone here did try it?
The following user(s) said Thank You: partec

Please Log in or Create an account to join the conversation.

More
19 Sep 2020 16:25 - 19 Sep 2020 17:15 #182757 by partec
I bought the ASUS J4005I-C in June, and after testing three more in July, work well and are actually quite cheap




Attachments:
Last edit: 19 Sep 2020 17:15 by partec.

Please Log in or Create an account to join the conversation.

More
19 Sep 2020 23:00 - 19 Sep 2020 23:02 #182793 by dm17ry

tommylight wrote:

partec wrote: www.alternate.de/GIGABYTE/GA-J3455N-D3H-...html/product/1503683 ?

Maybe someone here did try it?


i'm using this mobo on the PnP machine for quite some time. with buster/preempt rt, a PCI servo interface card, 222us servo thread period. works ok except linuxcnc reports unexpected realtime delay *if* started immediately after boot. but after a few seconds it seems to get stable. haven't investigated the cause
Last edit: 19 Sep 2020 23:02 by dm17ry.
The following user(s) said Thank You: partec

Please Log in or Create an account to join the conversation.

Time to create page: 0.190 seconds
Powered by Kunena Forum