LinuxCNC Install using MX Linux 19.4 - Geared Toward New Users

More
21 Mar 2024 22:24 #296510 by phillc54
OK, the top pic in this post  shows that for some reason the link to the sample ngc files is not being created.

In the [RS274NGC] section of the .ini file change:
./:../../nc_files/examples/plasmac/m_files
to:
./:/usr/share/doc/linuxcnc/examples/nc_files/plasmac/m_files

Please Log in or Create an account to join the conversation.

More
21 Mar 2024 22:25 #296511 by acourtjester
Well stop the job, I went back and went over some of the commands in the procedure and last thing was nm-connection-editor and it loaded the GUI for QTPlasmaC with version number 2.10-005.030.
Looks like Phill was correct with it being a networking issue.
A great big THANKS for your help, now I move the controller back to the shop for actual testing and operations.
This I hope corrects the glitches I had with the other version (Arc Ok and THC.
 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Mar 2024 22:53 #296514 by phillc54

When I look at the .INI file is says master 2.9

This doesnt make sense to me, I wasnt aware the ini file showed the version. Either way, I'm going with what was shown in the package manager.


I think that is a minor bug in the PncConf header comments.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
21 Mar 2024 23:22 #296519 by snowgoer540
Ah, that explains it; I havent made a config with PncConf in a coon's age.

Please Log in or Create an account to join the conversation.

More
22 Mar 2024 01:01 #296523 by acourtjester
Ok Phill I did find a bug, I use the pnnconf to make changes to the GUI, I know you guys use a different method.
Anyway what I found was when I did it the line in the INI file is changed by removing the examples folder info that you had instructed me to add../:../../nc_files/examples/plasmac/m_files
I went into Pnnconf to change the mode from 2 to 0 so I had all the buttons (auto voltage for one) and after that the error came back. reentered the examples folder and it work as it should. Thanks again for all the help.
 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Mar 2024 01:07 #296524 by phillc54
Thanks, yes, PncConf overwrites the .ini file, I have a fix in hand but am waiting confirmation that it does work.

Did you try the path I suggested  here ?

Please Log in or Create an account to join the conversation.

More
22 Mar 2024 13:38 #296542 by acourtjester
Yes sir That fixed the error right away, Again Thanks for your time.

Please Log in or Create an account to join the conversation.

More
22 Mar 2024 18:20 #296555 by acourtjester
I did not set a setup page for the THCAD-10 in Pnnconf, and nothing in the manual except the description of how it works. My plasma is setup for 20:1
Is this now handled by the auto voltage setting in the software?

Please Log in or Create an account to join the conversation.

More
23 Mar 2024 14:47 #296578 by kn612
Have you configured the arc voltage input on the 7i76e tb2/th3 page? With that setup then you should come to a mesa thcad page where you can enter the scaling values from the back of your thcad10. It's all done in pncconf.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
23 Mar 2024 15:07 #296581 by acourtjester
Thanks KN612 just added it to my QTPlasmaC with Pnnconf

Please Log in or Create an account to join the conversation.

Time to create page: 0.242 seconds
Powered by Kunena Forum