2.9.4 is released - but not in
forum.linuxcnc.org/29-forum-announcements
?
Looking via Debian - it appears this is only in sid=unstable - so not yet stable or testing - so your install instructions won't work for anyone running anything other than unstable.
That being said, I currently have
2.9.0~pre1+git20230208.f1270d6ed7-1+deb12u1 under bookworm.
And have had some random resets.. Is there a list of what is fixed in 2.9.4 ?
So to install in bookworm you would have to install half of testing as dependencies.
I'm not complaining - like seeing the progress, but hope this might help others that run stable=bookworm.
I put trixie on a laptop for non linuxcnc - runs well, but lots of libs are getting updated at a high pace as the freeze has been approaching . trixie is supposed to release sometime in the second half of the year - when it is ready.
Code:
[color=#000000]The following packages have unmet dependencies: [/color]
linuxcnc-uspace : Depends: python3 (>= 3.13~) but 3.11.2-1+b1 is to be installed
Depends: libc6 (>= 2.38) but 2.36-9+deb12u10 is to be installed
Depends: libglib2.0-0t64 (>= 2.12.0) but it is not going to be installed
Depends: libgtk-3-0t64 (>= 3.11.5) but it is not going to be installed
Depends: libgtk2.0-0t64 (>= 2.8.0) but it is not going to be installed
Depends: libpython3.13 (>= 3.13.0~rc3) but it is not going to be installed
Depends: libstdc++6 (>= 13.1) but 12.2.0-14 is to be installed
Depends: libtirpc3t64 (>= 1.0.2) but it is not going to be installed
Depends: libgtksourceview-4-dev but it is not going to be installed
[color=#ff5454]E: [/color][color=#000000]Unable to correct problems, you have held broken packages.[/color]
Hope this is helpful.