✅ (Solved) EL7342 | Working

More
21 Sep 2021 11:41 #221261 by db1981
Replied by db1981 on topic EL7342
there is something wrong with the linuxcnc installation,

Note: Using POSIX non-realtime should be "using Posix realtime" this is not related to etherlabmaster , linuxcnc-ethecat or ethercat_conf.xml.

Have you compiled linuxcnc by yourself ?

Please Log in or Create an account to join the conversation.

More
23 Sep 2021 07:08 #221403 by juniorfi
Replied by juniorfi on topic EL7342
Hello,

Could be that in the source code there is some problem or in the way I'm doing the installation.
As I mentioned in the last post I used github.com/grotius-cnc/hal-core and not the main LinuxCNC installation.

I will try to use the LinuxCNC installation to see if that error goes away.

Hope to get at least EL7342 working without TwinSAFE at least.

Please Log in or Create an account to join the conversation.

More
23 Sep 2021 09:53 #221416 by juniorfi
Replied by juniorfi on topic EL7342
I installed everything again from starch and that issue about RT is gone. Thanks for that hint.

- When using my own configuration EL7342.xml I got:
74 bit OUT FALSE lcec.0.7.slave-state-op
74 bit OUT TRUE lcec.0.7.slave-state-preop
And without it I got:
74 bit OUT TRUE lcec.0.7.slave-state-op
74 bit OUT FALSE lcec.0.7.slave-state-preop


Does it make any sense? I mean, do I need to use that .XML config without using the TwinSAFE? I Assume that the two yellow lights I got is because the config I have because the power is good for that terminal.


Regards

Please Log in or Create an account to join the conversation.

More
23 Sep 2021 14:36 #221430 by db1981
Replied by db1981 on topic EL7342
Hello,

i can't follow you completly. As far as i know EL7342 is no FSOE/Twinsafe component...

If your config is not working, maybe there are some typo,syntax errors in the xml file.

set ethercat debug level to 1. teminal: "ethercat debug 1", and check the dmesg after starting linuxcnc. (look for any messages that are related to the corresponding slave number.)

Please Log in or Create an account to join the conversation.

More
24 Sep 2021 06:33 #221485 by juniorfi
Replied by juniorfi on topic EL7342
Hello,

Yes that's true it is not a FSOE component. The thing is that I have that attached into an EL9576 + EL6900 + EL1904 + EL2904 + EL9505. So If the TwinSAFE are OK the power goes to the EL7342...

Sadly I lost that functionality (TwinSAFE one), Because I don't know how to setup it and out there is not documentation how to do that picking the config from TwinCAT3.


But yesterday I got the EL7342 working after removing the TwinSAFE terminals I had and change some cables to power up the EL7342 directly. I will try to put what I did here soon.


Thanks again for your help.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
08 Oct 2021 09:19 #222534 by juniorfi
Replied by juniorfi on topic EL7342
To get working the EL7342:

We have to have power up and enable the terminal with:
halcmd setp lcec.0.7.srv-0-enable 1
halcmd setp lcec.0.7.srv-1-enable 1

Then send the command with:
halcmd setp lcec.0.7.srv-0-cmd 1
or
halcmd setp lcec.0.7.srv-1-cmd 1


That's all! :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum