Please HELP config ethercat servo motor

More
25 Jun 2024 15:35 #303756 by abdulasis12
Hi
I try to use EtherCAT servo motor first time.
I read in forum.linuxcnc.org/ethercat/45336-etherc...-step-by-step#237098
I config step by step done
I clone config from github.com/rodw-au/linuxcnc-cia402/tree/main
I Download .XML my servo put in folder and in .hall i add
loadusr -W lcec_conf  HCFA_X3E30.xml

I run LCNC  show massege error:
./cia402.hal:15: lcec_conf exited without becoming ready
6836

how to fix this error ?

 
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Jun 2024 19:28 #303777 by rodw
The XML file you are using is for Twincat on Windows
It is useless for Linuxcnc.
Please review the example XML files in the config you cloned.
You need to write something similar for your drive and other slaves you are using.
The following user(s) said Thank You: abdulasis12

Please Log in or Create an account to join the conversation.

More
26 Jun 2024 01:38 #303803 by onceloved
Are you Chinese? If yes, I can help you with remote configuration.
The following user(s) said Thank You: abdulasis12

Please Log in or Create an account to join the conversation.

More
26 Jun 2024 09:46 #303818 by abdulasis12
YES, china i have any desk

Please Log in or Create an account to join the conversation.

More
26 Jun 2024 09:57 #303819 by abdulasis12

The XML file you are using is for Twincat on Windows
It is useless for Linuxcnc.
Please review the example XML files in the config you cloned.
You need to write something similar for your drive and other slaves you are using.

Thank you for reply MR.rodw
I will read more about etherCAT and try again 
thank you.

Please Log in or Create an account to join the conversation.

More
26 Jun 2024 15:09 - 26 Jun 2024 20:59 #303833 by abdulasis12
I try re download file from github.com/rodw-au/linuxcnc-cia402/tree/main
and first time show error shutdown.hal   i go to # all line
run linuxcnc from cmd
show  this  massege  :
linuxcnc@debian:~/linuxcnc/configs/linuxcnc-cia402-main$ linuxcnc
LINUXCNC - 2.9.2
Machine configuration directory is '/home/linuxcnc/linuxcnc/configs/linuxcnc-cia402-main'
Machine configuration file is 'cia402.ini'
Starting LinuxCNC...
emc/iotask/ioControl_v2.cc 888: iov2: can't load tool table.
linuxcnc TPMOD=tpmod HOMEMOD=homemod EMCMOT=motmod
Note: Using POSIX realtime
Found file(REL): ./cia402.hal
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x2000:0x00, size 2, byte0=112, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.0 sdo 2000:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x2007:0x06, size 1, byte0=5, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.0 sdo 2007:06
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x2007:0x05, size 1, byte0=5, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.0 sdo 2007:05
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x2011:0x00, size 2, byte0=1, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.0 sdo 2011:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x6098:0x00, size 2, byte0=17, error -5, abort_code 06070010)
LCEC: failed to configure slave 0.0 sdo 6098:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x607c:0x00, size 2, byte0=0, error -5, abort_code 06070010)
LCEC: failed to configure slave 0.0 sdo 607c:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x609a:0x00, size 2, byte0=244, error -5, abort_code 06070010)
LCEC: failed to configure slave 0.0 sdo 609a:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x6099:0x01, size 2, byte0=196, error -5, abort_code 06070010)
LCEC: failed to configure slave 0.0 sdo 6099:01
Failed to execute SDO download: Input/output error
LCEC: slave 0.0: Failed to execute SDO download (0x6099:0x02, size 2, byte0=244, error -5, abort_code 06070010)
LCEC: failed to configure slave 0.0 sdo 6099:02
Failed to execute SDO download: Input/output error
LCEC: slave 0.1: Failed to execute SDO download (0x2000:0x00, size 2, byte0=112, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.1 sdo 2000:00
Failed to execute SDO download: Input/output error
LCEC: slave 0.1: Failed to execute SDO download (0x2007:0x06, size 1, byte0=5, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.1 sdo 2007:06
Failed to execute SDO download: Input/output error
LCEC: slave 0.1: Failed to execute SDO download (0x2011:0x00, size 2, byte0=1, error -5, abort_code 06020000)
LCEC: failed to configure slave 0.1 sdo 2011:00
Failed to execute SDO download: Invalid argument
LCEC: slave 0.2: Failed to execute SDO download (0x2000:0x00, size 2, byte0=88, error -22, abort_code 08e49a08)
LCEC: failed to configure slave 0.2 sdo 2000:00
Failed to execute SDO download: Invalid argument
LCEC: slave 0.2: Failed to execute SDO download (0x2007:0x06, size 1, byte0=5, error -22, abort_code 08e49a08)
LCEC: failed to configure slave 0.2 sdo 2007:06
Failed to execute SDO download: Invalid argument
LCEC: slave 0.2: Failed to execute SDO download (0x2011:0x00, size 2, byte0=0, error -22, abort_code 08e49a08)
LCEC: failed to configure slave 0.2 sdo 2011:00
Failed to register PDO entry: No such file or directory
LCEC: master 0 PDO entry registration failed
LCEC: failure, clearing config
LCEC: exiting
LCEC: returning -EINVAL
lcec: rtapi_app_main: Invalid argument (-22)
./cia402.hal:15: waitpid failed /usr/bin/rtapi_app lcec
./cia402.hal:15: /usr/bin/rtapi_app exited without becoming ready
./cia402.hal:15: insmod for lcec failed, returned -1
Shutting down and cleaning up LinuxCNC...
Running HAL shutdown script
iov2: exiting
Note: Using POSIX realtime
LinuxCNC terminated with an error.  You can find more information in the log:
    /home/linuxcnc/linuxcnc_debug.txt
and
    /home/linuxcnc/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal


this my ethercat network
linuxcnc@debian:~/linuxcnc/configs/linuxcnc-cia402-main$ ethercat slaves
0  0:0  PREOP  +  BK1120 EtherCAT Buskoppler
1  1:0  PREOP  +  HCFA X3E Servo Driver
linuxcnc@debian:~/linuxcnc/configs/linuxcnc-cia402-main$ 
some can guild me ?

Thank you.
Asis
Last edit: 26 Jun 2024 20:59 by abdulasis12.

Please Log in or Create an account to join the conversation.

More
26 Jun 2024 20:48 - 26 Jun 2024 20:51 #303849 by abdulasis12
linuxcnc@debian:~/linuxcnc/configs/linuxcnc-cia402-main$ halcmd loadusr -W lcec_conf ethercat-conf.xml
linuxcnc@debian:~/linuxcnc/configs/linuxcnc-cia402-main$ halcmd show pin lcec
Component Pins:
Owner   Type  Dir         Value  Name
4  u32   OUT    0x00000001  lcec.conf.master-count      
4  u32   OUT    0x00000004  lcec.conf.slave-count  
Last edit: 26 Jun 2024 20:51 by abdulasis12.

Please Log in or Create an account to join the conversation.

More
27 Jun 2024 01:17 #303863 by onceloved
加我QQ或微信304394405

Please Log in or Create an account to join the conversation.

More
27 Jun 2024 02:31 #303866 by abdulasis12
LINUXCNC - 2.9.2
Machine configuration directory is '/home/linuxcnc/linuxcnc/configs/linuxcnc-cia402-main/.'
Machine configuration file is 'cia402.ini'
Starting LinuxCNC...
emc/iotask/ioControl_v2.cc 888: iov2: can't load tool table.
linuxcnc TPMOD=tpmod HOMEMOD=homemod EMCMOT=motmod
Note: Using POSIX realtime
Found file(REL): ./cia402.hal
lcec_conf: ERROR: Parse error at line 4: not well-formed (invalid token)
./cia402.hal:9: waitpid failed lcec_conf lcec_conf
./cia402.hal:9: lcec_conf exited without becoming ready
Shutting down and cleaning up LinuxCNC...
iov2: exiting
Note: Using POSIX realtime
LinuxCNC terminated with an error. You can find more information in the log:
/home/linuxcnc/linuxcnc_debug.txt
and
/home/linuxcnc/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal

Please Log in or Create an account to join the conversation.

Time to create page: 0.110 seconds
Powered by Kunena Forum