Is someone using Gmoccapy Plasma ?

More
27 Mar 2016 19:37 #72224 by Michael80
Normally if you set

HOME_SEARCH_VEL = 0

it will home the axis immediatly if you press the homing button

Wiki --> No_Switches

imperial units, sorry not my place, maybe you can ask newbynobi about it, he was programming the interface Gmoccapy

BR

Michael

Please Log in or Create an account to join the conversation.

More
28 Mar 2016 11:25 #72241 by mariusl
You could also set the NO_FORCE_HOMING = 1
and the units is set in the INI file. The default is imperial but you can set it to mm

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
28 Mar 2016 14:37 #72246 by islander261
Thank you, I have my setup working with manual homing now. This is still a test setup with no hardware connected.

The next strange thing is also probably setup related. I am want to use imperial units (inches). In my .ini file in the [TRAG] section I have the LINEAR_UNITS = inch and in the [DISPLAY] section I have INCREMENTS = .1in .05in. .01in. ... But something still isn't right. When I jog using a step move with the resolution set to .1in the DRO shows a move of 2.540. This behavior is the same just scaled if I use another step size. It is almost as if the DRO is still counting in mm. I will be reading up on gmoccapy more today to try and find the problem but any hints are welcome.

John

Please Log in or Create an account to join the conversation.

More
28 Mar 2016 14:41 #72247 by islander261
Sorry I forgot to attach the needed files.

John
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Mar 2016 17:09 #72253 by mariusl
When you look at the "Active Gcodes" do you see an G20 or G21?

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.151 seconds
Powered by Kunena Forum