Gmoccapy Bug?

More
09 Jan 2017 09:16 - 09 Jan 2017 09:17 #85505 by racedirector
racedirector replied the topic: Gmoccapy Bug?

tommylight wrote:

newbynobi wrote: We are at -9 degree celsius?


Minus 13 C here, last night went to -22.
I miss the sun..........who was complaining about to hot????? Wana trade?
:cheer: :cheer:


Me, complaining about our impending heatwave week... today 36C, tomorrow 37C, Wed 40C, Thursday 37C, Friday 42C

If it was possible to trade I would do so in a flash, love cold, HATE heat.

This is 50km north west of Sydney, Australia
Last Edit: 09 Jan 2017 09:17 by racedirector.
More
10 Jan 2017 06:41 #85557 by rodw
rodw replied the topic: Gmoccapy Bug?

racedirector wrote:

tommylight wrote:

newbynobi wrote: We are at -9 degree celsius?


Minus 13 C here, last night went to -22.
I miss the sun..........who was complaining about to hot????? Wana trade?
:cheer: :cheer:


Me, complaining about our impending heatwave week... today 36C, tomorrow 37C, Wed 40C, Thursday 37C, Friday 42C

If it was possible to trade I would do so in a flash, love cold, HATE heat.

This is 50km north west of Sydney, Australia


And me, Another 1000 km further north and closer to the equator in Brisbane Australia.
More
11 Jan 2017 17:38 #85619 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?
@racedirector,

could you test?
I need a result to update also the other releases.

Norbert
More
13 Jan 2017 03:47 #85679 by thor44
thor44 replied the topic: Gmoccapy Bug?
I downloaded the file from github.com/LinuxCNC/linuxcnc now how do I install it?
Sorry I'm still very new to Linux.

Thanks
Orson
More
13 Jan 2017 18:14 #85708 by timmert
timmert replied the topic: Gmoccapy Bug?
I'm using the new Gmoccapy UI with the master release and came across a bug that happens each time.
I start Linuxcnc -> home all -> go to MDI -> if I home again the screen doesn't switch from the jog screen to MDI.
I need to completely restart LinuxCNC to get it working again.
More
14 Jan 2017 08:49 #85732 by racedirector
racedirector replied the topic: Gmoccapy Bug?

newbynobi wrote: @racedirector,

could you test?
I need a result to update also the other releases.

Norbert

Sorry Norbert

Too hot to go in the garage (46C) but got to update today. Did a git pull and ran the same code - no change other than maybe a little less distance.

More
14 Jan 2017 11:13 - 14 Jan 2017 11:13 #85734 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?

I'm using the new Gmoccapy UI with the master release and came across a bug that happens each time.
I start Linuxcnc -> home all -> go to MDI -> if I home again the screen doesn't switch from the jog screen to MDI.
I need to completely restart LinuxCNC to get it working again.


I am not able to reproduce that. If I test with sim, I can home the machine, go to MDI, go back to manual and if I try to home again, I get the message, that the axis is on a limit switch, that is OK, because of simulated home switches.
I can jog all axis to negative values and press home all. All axis get homed and I can switch modes again.

So, what are you doing exactly?
Post the part of homing of you INI.

On my basement mill I can home as much times I like, also no error.

Norbert
Last Edit: 14 Jan 2017 11:13 by newbynobi.
More
14 Jan 2017 11:15 #85735 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?

Sorry Norbert

Too hot to go in the garage (46C) but got to update today. Did a git pull and ran the same code - no change other than maybe a little less distance.


Could you send me your gcode? I have tested on different machines with different codes and I am not able to see so large movements. What release number does the GUI show? Should be 2.2.3 by now.

Norbert
More
14 Jan 2017 11:18 - 14 Jan 2017 11:19 #85736 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?

I downloaded the file from github.com/LinuxCNC/linuxcnc now how do I install it?
Sorry I'm still very new to Linux.

Thanks
Orson


build from source

For newbies it is much easier to use buildbot .

Norbert
Last Edit: 14 Jan 2017 11:19 by newbynobi.
More
14 Jan 2017 11:19 - 14 Jan 2017 11:20 #85737 by timmert
timmert replied the topic: Gmoccapy Bug?

newbynobi wrote:

I'm using the new Gmoccapy UI with the master release and came across a bug that happens each time.
I start Linuxcnc -> home all -> go to MDI -> if I home again the screen doesn't switch from the jog screen to MDI.
I need to completely restart LinuxCNC to get it working again.


I am not able to reproduce that. If I test with sim, I can home the machine, go to MDI, go back to manual and if I try to home again, I get the message, that the axis is on a limit switch, that is OK, because of simulated home switches.
I can jog all axis to negative values and press home all. All axis get homed and I can switch modes again.

So, what are you doing exactly?
Post the part of homing of you INI.

On my basement mill I can home as much times I like, also no error.

Norbert

See attachment.
This is a 2.7 config though. Because I just rolled back.
Attachments:
Last Edit: 14 Jan 2017 11:20 by timmert.
Moderators: newbynobi
Time to create page: 0.095 seconds
Powered by Kunena Forum