Cannot jog Gantry Machine

More
08 Oct 2018 00:37 - 08 Oct 2018 01:06 #118523 by racedirector
So I decided to abandon Pathpilot and go with Gmoccapy instead. I read everything there was to read on gantry machines under 2.8 and then setup my machine. After a few hiccups I ended up with a machine that worked.... sort of.

I setup [KINS] with

KINEMATICS = trivkins coordinates=XXYZ
JOINTS = 4

Then set [TRAJ]
AXES = 4
JOINTS = 4
COORDINATES = X X Y Z

If I set this any other way, for example AXES=3 then LCNC complains about JOINT_3 not existing. It also does not matter if I put X Y Z in coordinates, the problem remains.

JOINT_0 and JOINT_1 are the X motors
JOINT_2 is Y
JOINT_3 is Z

Homing setup with both X's at -1

Homing works fine, both X motors home at the same time, Y homes fines and Z is manual homing.

After that it all turns pear shaped...

Jogging X only jogs 1 motor, JOINT_0, horrible noises result.
Jogging Y actually jogs the other X motor (JOINT_1) resulting in more horrible noises.

I have read both Rods saga with GMoccapy and other threads on how to setup gantry's and don't quite get what I did wrong. Can anyone suggest where I should now look as this is driving me nuts. I thought GMOccapy was ready for gantry machines on 2.8 but something is very wrong here....

Cheers
Last edit: 08 Oct 2018 01:06 by racedirector.
More
08 Oct 2018 01:51 #118524 by PCW
Replied by PCW on topic Cannot jog Gantry Machine
Can you post your hal and ini files?
More
08 Oct 2018 02:03 #118525 by racedirector
Yup, will do the I get home :)
More
08 Oct 2018 03:31 #118526 by racedirector
Just a brain dump but I remember reading somewhere that the individual homing buttons should be disabled in the screen if dual joints are specified. That is not happening on my install, the HOME ALL and the individual Axes home buttons are active.
More
08 Oct 2018 05:31 #118527 by tommylight

racedirector wrote:
I setup [KINS] with

KINEMATICS = trivkins coordinates=XXYZ
JOINTS = 4

Then set [TRAJ]
AXES = 4 <<<<<<<<<<<<<<< remove this
JOINTS = 4 <<<<<<<<<<<<<<< remove this
COORDINATES = X X Y Z


It will work as is, and that is the normal behaviour you describe there.
You have to home the double axis before jogging, otherwise you have to look at it as a machine with 4 axis when in Joint mode. After homing it goes to World mode so you can jog normally.
More
08 Oct 2018 07:33 - 08 Oct 2018 07:43 #118528 by racedirector
Thanks Tommy

Still no go, startup fails complaining about missing AXES

/home/cnc/linuxcnc-dev/scripts/linuxcnc '/home/cnc/linuxcnc/configs/bsww-mesa/bsww-mesa.ini'
LINUXCNC - 2.8.0~pre1
Machine configuration directory is '/home/cnc/linuxcnc/configs/bsww-mesa'
Machine configuration file is 'bsww-mesa.ini'
Starting LinuxCNC...
Found file(REL): ./bsww-mesa.hal
Note: Using POSIX realtime
./bsww-mesa.hal:6: Ini variable '[TRAJ]AXES' not found.
Shutting down and cleaning up LinuxCNC...
Note: Using POSIX realtime
LinuxCNC terminated with an error. You can find more information in the log:
/home/cnc/linuxcnc_debug.txt
and
/home/cnc/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal


I am attaching my files for consideration...

Cheers
Attachments:
Last edit: 08 Oct 2018 07:43 by racedirector.
More
08 Oct 2018 08:06 #118530 by racedirector
Well the AXES things was my doing (fixed now) but still no work. Homes fine, jogs only 1 X motor with X+ and the other with Y+
More
08 Oct 2018 09:05 #118532 by racedirector
While researching this problem I found a fix, thanks to Andy from a while ago. This post: forum.linuxcnc.org/49-basic-configuratio...lease?start=10#95922 fixed the "problem"

in "loadrt trivkens" I added "coordinates=xxyz"

and in "[TRAJ]" I changed coordinates to "X Y Z" only

and the machine now behaves itself. After homing X jog uses both X1 & X2, Y jog does Y only and Z jog does Z.

Now I can go on to adding everything else I need to get it working like Pathpilot.

Thanks those that looked and answered, I do appreciate it.

Cheers
Moderators: newbynobi
Time to create page: 0.105 seconds
Powered by Kunena Forum