Feed override in auto mode

More
24 May 2019 10:58 #134799 by Glemigobles
The max velocity slider doesn't do anything, even when set to 0.

Please Log in or Create an account to join the conversation.

More
24 May 2019 11:33 - 24 May 2019 11:41 #134802 by Glemigobles
I added the lines:

setp halui.max-velocity.count-enable true
setp halui.max-velocity.direct-value true

And now the slider works in MDI (not manual) BUT it reads the values provided in the ini in machine units per second as machine units per minute (actual feed). So the max value of 60 is now 60 mm/min.

EDIT: solved, I thought I had to add a scale parameter but then looked into the ini file and it turned out MAX_VELOCITY was set to 1 instead of 50.

Now, I'd prefer this to be percentage value and work like an actual feed override slider, but I guess that will have to wait. At least it works.
Last edit: 24 May 2019 11:41 by Glemigobles.

Please Log in or Create an account to join the conversation.

More
24 May 2019 13:10 #134806 by pl7i92
Replied by pl7i92 on topic Feed override in auto mode
you getting it better and betterfrom every day on as you dive deeper to the system

i guess you did check the new halui names
uses halui.axis
not joint for the settings of feedoverride feed and jog

Please Log in or Create an account to join the conversation.

More
24 May 2019 19:58 #134845 by cmorley
Replied by cmorley on topic Feed override in auto mode

Glemigobles wrote: The max velocity slider doesn't do anything, even when set to 0.


Well that's not right - The screen slider should work out-of-the-box
Were you using the screen slider or something else?

Chris M

Please Log in or Create an account to join the conversation.

More
25 May 2019 20:57 #134927 by newbynobi
It might help if you post your config folder.

To use the slider, no special commands in hal are needed.

Norbert

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.086 seconds
Powered by Kunena Forum