Jog Z crashes rtapi_app in lathe mode

More
19 Jul 2019 15:04 #139883 by Hakan
Reproduce by using the latest 2.9 from git.
Start linuxcnc, select sim/gmoccapy_lathe
Jog some distance in Z leads to crash.
Jog in X works fine.
Switching to axis, jog in Z works fine.

Some more info here forum.linuxcnc.org/18-computer/36879-ras...pi-4?start=30#139815
It happens on the Intel PC (so not Raspberry Pi related).

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 16:27 #139900 by cmorley
This happens before you home the machine? I seem to confirm that.
This should also affect the 2.8 branch that is coming out.

And yes this is a joint vs axis number problem.
joints in a lathe config are numbered 0 and 1
Axes are numbered 0 and 2
It's not documented very well (and I'm not sure it's the best implementation)
I just noticed this when working on qtvcp and was trying to get a discussion of a solution on the linuxcnc dev list

Chris M

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 17:52 #139903 by Hakan
Yes, before homing. But I just tried and it also happens after homing.
The problem can be seen in the simulator so everyone can reproduce it.

This must be something recent. I have been using a 2.8 gmoccapy for a long time.

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 18:49 #139905 by tommylight
Linuxcnc 2.8pre, gmoccapy 2.3.3.4, linux mint, preempt rt, lenovo m93:
No such issue before or after homing.
Will test other versions later and report back, need food.

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 18:53 #139907 by Hakan
Try latest one, there is where I have seen it.

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 18:57 #139908 by cmorley

tommylight wrote: Linuxcnc 2.8pre, gmoccapy 2.3.3.4, linux mint, preempt rt, lenovo m93:
No such issue before or after homing.
Will test other versions later and report back, need food.


Are you trying the lathe config?

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 19:11 #139910 by cmorley
If I home the lathe config, I can't see the problem in master.
This makes some sense to me as the probable problem is linuxcnc has been directed to jog joint 2 which there isn't one. In axis mode the value 2 = X axis.

So there are two problems here -linuxcnc shouldn't crash if you ask it to jog a joint that is not available, and Gmoccapy needs to use different values for jogging based on joint or axis mode or linuxcnc needs to be smart enough to jog the right axis based on the joint number.

Chris M

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 19:31 #139914 by tommylight

Hakan wrote: Try latest one, there is where I have seen it.

Will do that later, i have on two laptops and a PC.

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 19:32 #139915 by tommylight

cmorley wrote:

tommylight wrote: Linuxcnc 2.8pre, gmoccapy 2.3.3.4, linux mint, preempt rt, lenovo m93:
No such issue before or after homing.
Will test other versions later and report back, need food.


Are you trying the lathe config?

Yes of course, the metric version.

Please Log in or Create an account to join the conversation.

More
19 Jul 2019 21:56 - 19 Jul 2019 21:59 #139930 by tommylight
Hmmmm something fishy going on there:
Two laptops with Mint 19.1, preempt rt, Linuxcnc 2.9pre0.228, gmoccapy 2.3.5 sim lathe metric
Both will start, exit e-stop, and as soon as enable is active it will not react to anything any more, not even close, it has to be forced to quit.
Both work perfectly well and do not crash with the normal gmoccapy, the first in the menu.
Note, one of these laptops can run Linuxcnc with a Mesa 7i92 for days perfectly, the other tends to drop the communication at random from 3 to 30 minutes in.
Last edit: 19 Jul 2019 21:59 by tommylight. Reason: More info

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.115 seconds
Powered by Kunena Forum