Gmoccapy 3.0 crash when using turtle jog

More
14 Oct 2020 17:46 #186114 by tacklem60
Sorry, I am having a hard time understanding what you would like me to try. The joint axis was automatically updated in my ini file the first time I opened LinuxCNC after the update. Are you saying I should get rid of those entries or try something different?

Looking in the KINS entry, it looks like it is currently KINEMATICS = trivkins, I already had the coordinates in the TRAJ section, so I will delete them from the KINS section if it is not needed. Honestly, I don't know how or when a lot of these entries were made so I apologize if it is confusing based on the current ini file.

Please Log in or Create an account to join the conversation.

More
15 Oct 2020 10:38 #186178 by newbynobi
you are welcome as long as we work together to solve the problem ;-)

With window manager I meesn do you use XFCE or Mate or Chinamon or... as Desktop envionment. If you do not know that, just post a Screenshot of the desktop, I should see then witch one you use. I need this information, because the error reports an X11 error.

It will also be helpful to know if you use a propiatary grafice driver as Nvidia or an AMD one.

I will be at home next Monday and I will than be able to install a system like yours and make further tests.
Do the errors also appear if you start a Sim and play around with Sim config?

Try LinuxCNC / gmoccapy / gmoccapy.ini

Norbert

Please Log in or Create an account to join the conversation.

More
16 Oct 2020 01:29 #186242 by tacklem60
I really hope we can work together to get it working! Gmoccapy is absolutely my favorite GUI for LinuxCNC and I would love to get 3.0 working because it has a lot of features that I really enjoy over the past version. I have run plenty of programs now to be confident that the rest of the functionality of the program is working perfectly, it's just the issue with the buttons crashing Linux that I have now and I don't have a quick way to avoid it because I really can't do anything without touching those buttons.

As for the sim configuration, I ran it tonight as you suggested and got the exact same crash I have been experiencing in my system. Separately, something I have noticed now is that I seem to be possibly having latency issues in the crash report? When I run the latency test, I am still getting good numbers all under 10k ns for both base and servo thread even with the system loaded. But with LinuxCNC open, I will sometimes get a latency warning in the control which I never have before and the crash report is saying that there are high latency points detected. So far, it hasn't effected the machine running but I am worried that it could and I never experienced it before.

Attached I added some pictures (quicker for me than screenshots so I hope they are ok). Shows a bit more details of my hardware as well as software. I am still using Ubuntu 12.04 rather than the upgraded 14 version simply because I am worried that if I upgrade, I will have system issues (the same reason I was worried about upgrading LinuxCNC). I am very new at Linux and fear that if I have software issues I may not be able to solve them so I try to stick to what works. Do you think the out of date version of Ubuntu could be the reason? If you recommend upgrading, do you think it will cause any issues for me?

As for drivers, I believe the one picture gives that information. I originally had a separate GPU in the system but was getting extremely bad latency. I removed the GPU and have been using on board graphics since with no issue until now so I am not sure if that has anything to do with it.

I really hope to get it back up and working soon, this is my main CNC machine and with this issue I basically can no longer use the machine as it crashes so often when trying to set WCS and changing jog speeds/incriments so until I can get this fixed I am in some trouble getting work done. I understand you are busy and you definitely don't owe me anything but I really appreciate all of your help you are giving me.

Joe
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Oct 2020 23:40 #186942 by tacklem60
I was wondering if you got any time to look into this? I have been limping by using the control without the ability to change jog speed at all. Using the keyboard I am able to use I and i to move between step sizes but if I touch any button in that section of the GUI (turtle jog, actually touch the different increment buttons, try to touch the -/+ on jog rate) the GUI crashes as I have described.

Regardless if I do this with touch screen or with the mouse, those buttons crash LinuxCNC about 50% of the time when pressed.

For some reason they seem to be the only buttons that cause this. I have been pressing all other buttons inside the GUI and never had an issue. The problem seems to be isolated to that section of the GUI, not sure if that helps with troubleshooting or not.

Joe

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.076 seconds
Powered by Kunena Forum