Use NativeCAM as a deb package now

More
04 Jul 2017 22:27 #95376 by FernV
Using
$ ncam -i inifile -t -c mill
will setup your inifile to use ncam embeded

Use -t only once

Fern

P.S. This thread should be reserved for installation questions only

Please Log in or Create an account to join the conversation.

More
05 Jul 2017 15:56 #95397 by rene-dev
Hi,
Im trying to get this to work with sim/axis_mm.ini from linuxcnc master.
I ran /home/emc/dev/NativeCAM/ncam.py -i axis_mm.ini to change the ini file.
when starting, this happens:
emc@emc:~/linuxcnc/configs/axis$ linuxcnc axis_mm.ini 
LINUXCNC - 2.8.0~pre1
Machine configuration directory is '/home/emc/linuxcnc/configs/axis'
Machine configuration file is 'axis_mm.ini'
Starting LinuxCNC...
Found file(lib): /home/emc/dev/linuxcnc/lib/hallib/core_sim.hal
Note: Using POSIX realtime
sched_setaffinity: Invalid argument
Found file(lib): /home/emc/dev/linuxcnc/lib/hallib/sim_spindle_encoder.hal
Found file(lib): /home/emc/dev/linuxcnc/lib/hallib/axis_manualtoolchange.hal
Found file(lib): /home/emc/dev/linuxcnc/lib/hallib/simulated_home.hal
note: MAXV     max: 53.340 units/sec 3200.400 units/min
note: LJOG     max: 53.340 units/sec 3200.400 units/min
note: LJOG default: 30.480 units/sec 1828.800 units/min
note: jog_order='XYZ'
note: jog_invert=set([])

(gladevcp:11321): libglade-WARNING **: Expected <glade-interface>.  Got <interface>.

(gladevcp:11321): libglade-WARNING **: did not finish in PARSER_FINISH state
**** GLADE VCP ERROR:    With xml file: /home/emc/dev/NativeCAM/ncam.ui : could not create GladeXML object
<commandline>:0: gladevcp exited without becoming ready
Embeded tab command "halcmd loadusr -Wn gladevcp gladevcp -c gladevcp -x 50331808 -U --catalog=mill /home/emc/dev/NativeCAM/ncam.ui" exited with error: 1
Shutting down and cleaning up LinuxCNC...
task: 1216 cycles, min=0.000013, max=0.005653, avg=0.001100, 0 latency excursions (> 10x expected cycle time of 0.001000s)
Note: Using POSIX realtime
LinuxCNC terminated with an error.  You can find more information in the log:
    /home/emc/linuxcnc_debug.txt
and
    /home/emc/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal

Please Log in or Create an account to join the conversation.

More
05 Jul 2017 16:07 #95398 by rene-dev
when I try to run them side by side, I get this error:
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Jul 2017 16:46 #95399 by FernV
It does not seem you are using the deb package, are you ?

Fern

Please Log in or Create an account to join the conversation.

More
05 Jul 2017 16:54 #95400 by rene-dev
no, im using master. I just got a lathe, and would like to work on the lathe stuff, it seems work in progress, and I would like to help.
all the code seems to be there, just some images and tooltips missing...
are all the lathe actions working?
also, I need to use linuxcnc master, because my setup requires that.
Rene

Please Log in or Create an account to join the conversation.

More
05 Jul 2017 18:13 - 06 Jul 2017 00:40 #95406 by FernV

... I need to use linuxcnc master, because my setup requires that.

Why do you have to ? The only time when someone needs to use master is when translating.
There is no advantage in using it, lcnc will erase your setup on each update and you will have to do it again
while with the deb, it will not happen and you will have updates automatically when I create a new version
after testing the new features.

... I just got a lathe, and would like to work on the lathe stuff, it seems work in progress, and I would like to help.all the code seems to be there, just some images and tooltips missing...are all the lathe actions working?

Nice, btw it is all available with the deb.

Most have been tested in the simulator. Conversion of my lathe is not complete yet. I think there are still some garbage files I am not finished using as example.

The only thing not working is tool compensation used when radiusing, I do not know why but the code published by J.T. at
forum.linuxcnc.org/lathe-subroutines-library/26958-radius does not work either.
I was unable to make compensation work on repetitive cuts.

Each feature has to be re-organized in a better order and more user-friendly, and many names changed,
before writing the correct tooltip and finding or creating the correct images.

If you are experienced with lathe stuff, nice because I am not. Changes are mostly needed in the interface files,
the *.cfg ones. The most sensibles are the *.ngc and you should not change them unless there is a bug.

Get familiar with NativeCAM first if you are not, What you can do then is test everything in the simulator, edit the cfg file and save them in ncam/my-stuff sub-directory. This sub-dir will never be overwritten.

You should now delete /home/emc/dev/NativeCAM, edit your ini to remove any references to ncam, then
install the deb like mentionned in the first post of this thread.
It will install with Debian Wheezy, Jessie and Stretch and Ubuntu Lucid and Trusty
I you have another distribution, let me know.

Please keep this thread for installation questions and post any other to the other thread
forum.linuxcnc.org/40-subroutines-and-ng...es-renamed?start=370

Fern

P.S. Also delete completely ncam sub-dir in every directory where you have a inifile
Last edit: 06 Jul 2017 00:40 by FernV. Reason: Add instruction to delete ncam sub-dir
The following user(s) said Thank You: vmihalca

Please Log in or Create an account to join the conversation.

More
06 Jul 2017 16:47 #95438 by SteveT
Hi
I have installed NativeCam and that as worked with out error, I have followed this thread on updating the .ini file but am getting the following errors.

steven@CnC:~/linuxcnc/configs/my-mill$ ncam -i | --ini= my-mill -c | --catalog= mill
bash: --ini=: command not found
bash: --catalog=: command not found
close failed in file object destructor:
sys.excepthook is missing
lost sys.stderr

I am now at a bit of loss at what to do, any help will be appreciated.

Steve

Please Log in or Create an account to join the conversation.

More
06 Jul 2017 17:05 #95440 by lagore
Hi Steve
I think your problem is you should have entered
ncam -i my-mill.ini -c mill
instead of
ncam -i | --ini= my-mill -c | --catalog= mill
replace my-mill.ini with the name of your init file and don't forget the file ext .ini
Edward
The following user(s) said Thank You: SteveT, FernV

Please Log in or Create an account to join the conversation.

More
06 Jul 2017 17:54 #95443 by SteveT
Thanks for your help works now, just need to sort the tool list as that causing it to crash. :-)

Please Log in or Create an account to join the conversation.

More
19 Jul 2017 10:23 #96043 by BigDo
Hi Fern! I've got the same message on a fresh installed ubuntu 12.04.
cnc@cnc:/$ curl -s https://packagecloud.io/install/repositories/FernV/NativeCAM/script.deb.sh | sudo bash
[sudo] password for cnc: 
Detected operating system as Ubuntu/precise.
Checking for curl...
Detected curl...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/FernV_NativeCAM.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.
cnc@cnc:/$ sudo apt-get install nativecamPaketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
E: Paket nativecam kann nicht gefunden werden
cnc@cnc:/$

package nativecam can not be found

how do i fix that?

Niko

Please Log in or Create an account to join the conversation.

Time to create page: 0.113 seconds
Powered by Kunena Forum