Help troubleshoot my Plasmac cfg

More
07 Jun 2019 01:05 #136144 by phillc54
Delete that link and create a new one.

Did you use configurator.py to create your config?

Cheers, Phill.
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:29 #136147 by mkardasi

phillc54 wrote: Delete that link and create a new one.

Did you use configurator.py to create your config?

Cheers, Phill.



Phil, I did indeed use configurator.py. If I'm interpreting ls -l right, all my symlinks are pointing back to themselves?

mkardasi@LinuxCNC:~/linuxcnc/configs/esab-plasmac$ ls -l
total 60
-rw-r--r-- 1 mkardasi mkardasi  980 Jun  5 22:04 esab-plasmac_connections.hal
-rw-r--r-- 1 mkardasi mkardasi 4921 Jun  5 22:04 esab-plasmac.hal
-rw-r--r-- 1 mkardasi mkardasi 8020 Jun  6 20:14 esab-plasmac.ini
-rw-r--r-- 1 mkardasi mkardasi  600 Jun  5 22:04 esab-plasmac_material.cfg
-rw-r--r-- 1 mkardasi mkardasi 1666 Jun  6 21:00 imperial_parameters.txt
-rw-r--r-- 1 mkardasi mkardasi 1666 Jun  6 20:18 imperial_parameters.txt.bak
lrwxrwxrwx 1 mkardasi mkardasi   22 Jun  5 22:04 imperial_startup.ngc -> ./imperial_startup.ngc
lrwxrwxrwx 1 mkardasi mkardasi    6 Jun  5 22:04 M190 -> ./M190
lrwxrwxrwx 1 mkardasi mkardasi   19 Jun  5 22:04 materialverter.py -> ./materialverter.py
lrwxrwxrwx 1 mkardasi mkardasi   20 Jun  5 22:04 metric_startup.ngc -> ./metric_startup.ngc
-rw-r--r-- 1 mkardasi mkardasi 4921 Jun  5 22:04 _original_7i96_base_cfg.hal
-rw-r--r-- 1 mkardasi mkardasi 4073 Jun  5 22:04 _original_7i96_base_cfg.ini
lrwxrwxrwx 1 mkardasi mkardasi   17 Jun  5 22:04 plasmac_axis.py -> ./plasmac_axis.py
lrwxrwxrwx 1 mkardasi mkardasi   22 Jun  5 22:04 plasmac_config.glade -> ./plasmac_config.glade
lrwxrwxrwx 1 mkardasi mkardasi   20 Jun  5 22:04 plasmac_config.hal -> ./plasmac_config.hal
lrwxrwxrwx 1 mkardasi mkardasi   19 Jun  5 22:04 plasmac_config.py -> ./plasmac_config.py
lrwxrwxrwx 1 mkardasi mkardasi   18 Jun  5 22:04 plasmac_gcode.py -> ./plasmac_gcode.py
-rw-r--r-- 1 mkardasi mkardasi 2274 Jun  5 22:04 plasmac.hal
lrwxrwxrwx 1 mkardasi mkardasi   19 Jun  5 22:04 plasmac_run.glade -> ./plasmac_run.glade
lrwxrwxrwx 1 mkardasi mkardasi   17 Jun  5 22:04 plasmac_run.hal -> ./plasmac_run.hal
lrwxrwxrwx 1 mkardasi mkardasi   16 Jun  5 22:04 plasmac_run.py -> ./plasmac_run.py
lrwxrwxrwx 1 mkardasi mkardasi   21 Jun  5 22:04 plasmac_stats.glade -> ./plasmac_stats.glade
lrwxrwxrwx 1 mkardasi mkardasi   19 Jun  5 22:04 plasmac_stats.hal -> ./plasmac_stats.hal
lrwxrwxrwx 1 mkardasi mkardasi   18 Jun  5 22:04 plasmac_stats.py -> ./plasmac_stats.py
-rw-r--r-- 1 mkardasi mkardasi  519 Jun  5 22:04 postgui.hal
lrwxrwxrwx 1 mkardasi mkardasi   11 Jun  5 22:04 README.md -> ./README.md
-rw-r--r-- 1 mkardasi mkardasi 1666 Jun  6 20:11 rs274ngc.var
-rw-r--r-- 1 mkardasi mkardasi 1666 Jun  6 20:11 rs274ngc.var.bak
lrwxrwxrwx 1 mkardasi mkardasi   10 Jun  5 22:04 tool.tbl -> ./tool.tbl

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:34 #136148 by phillc54
Did you run it from ~/linuxcnc-plasmac/configs/by_machine/plasmac or from ~/linuxcnc/configs/esab-plasmac?

Cheers, Phill.
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:38 #136149 by mkardasi

phillc54 wrote: Did you run it from ~/linuxcnc-plasmac/configs/by_machine/plasmac or from ~/linuxcnc/configs/esab-plasmac?

Cheers, Phill.


~/linuxcnc-plasmac/configs/by_machine/plasmac

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:40 #136150 by phillc54
Hmmm, not sure what is happening.

Try:
~/linuxcnc-plasmac/configs/by_machine/plasmac/configurator.py
then select upgrade then your ini file and see if that fixes it.

Cheers, Phill.
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:50 #136151 by mkardasi

phillc54 wrote: Hmmm, not sure what is happening.

Try:

~/linuxcnc-plasmac/configs/by_machine/plasmac/configurator.py
then select upgrade then your ini file and see if that fixes it.

Cheers, Phill.


Looks like the links are correct!

mkardasi@LinuxCNC:~$ ~/linuxcnc-plasmac/configs/by_machine/plasmac/configurator.py
mkardasi@LinuxCNC:~$ cd linuxcnc/configs/esab-plasmac-configurator.py-test/
mkardasi@LinuxCNC:~/linuxcnc/configs/esab-plasmac-configurator.py-test$ ls -l
total 100
-rw-r--r-- 1 mkardasi mkardasi  980 Jun  6 21:46 esab-plasmac-configurator.py-test_connections.hal
-rw-r--r-- 1 mkardasi mkardasi 4073 Jun  6 21:46 esab-plasmac-configurator.py-test.hal
-rw-r--r-- 1 mkardasi mkardasi 8075 Jun  6 21:46 esab-plasmac-configurator.py-test.ini
-rw-r--r-- 1 mkardasi mkardasi  600 Jun  6 21:46 esab-plasmac-configurator.py-test_material.cfg
lrwxrwxrwx 1 mkardasi mkardasi   79 Jun  6 21:46 imperial_startup.ngc -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/imperial_startup.ngc
lrwxrwxrwx 1 mkardasi mkardasi   63 Jun  6 21:46 M190 -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/M190
lrwxrwxrwx 1 mkardasi mkardasi   76 Jun  6 21:46 materialverter.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/materialverter.py
lrwxrwxrwx 1 mkardasi mkardasi   77 Jun  6 21:46 metric_startup.ngc -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/metric_startup.ngc
-rw-r--r-- 1 mkardasi mkardasi 4073 Jun  6 21:46 _original_7i96_base_cfg.ini
lrwxrwxrwx 1 mkardasi mkardasi   74 Jun  6 21:46 plasmac_axis.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_axis.py
lrwxrwxrwx 1 mkardasi mkardasi   79 Jun  6 21:46 plasmac_config.glade -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_config.glade
lrwxrwxrwx 1 mkardasi mkardasi   77 Jun  6 21:46 plasmac_config.hal -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_config.hal
lrwxrwxrwx 1 mkardasi mkardasi   76 Jun  6 21:46 plasmac_config.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_config.py
lrwxrwxrwx 1 mkardasi mkardasi   75 Jun  6 21:46 plasmac_gcode.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_gcode.py
-rw-r--r-- 1 mkardasi mkardasi 2295 Jun  6 21:46 plasmac.hal
lrwxrwxrwx 1 mkardasi mkardasi   76 Jun  6 21:46 plasmac_run.glade -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_run.glade
lrwxrwxrwx 1 mkardasi mkardasi   74 Jun  6 21:46 plasmac_run.hal -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_run.hal
lrwxrwxrwx 1 mkardasi mkardasi   73 Jun  6 21:46 plasmac_run.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_run.py
lrwxrwxrwx 1 mkardasi mkardasi   78 Jun  6 21:46 plasmac_stats.glade -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_stats.glade
lrwxrwxrwx 1 mkardasi mkardasi   76 Jun  6 21:46 plasmac_stats.hal -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_stats.hal
lrwxrwxrwx 1 mkardasi mkardasi   75 Jun  6 21:46 plasmac_stats.py -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/plasmac_stats.py
-rw-r--r-- 1 mkardasi mkardasi  519 Jun  6 21:46 postgui.hal
lrwxrwxrwx 1 mkardasi mkardasi   68 Jun  6 21:46 README.md -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/README.md
lrwxrwxrwx 1 mkardasi mkardasi   67 Jun  6 21:46 tool.tbl -> /home/mkardasi/linuxcnc-plasmac/configs/by_machine/plasmac/tool.tbl
mkardasi@LinuxCNC:~/linuxcnc/configs/esab-plasmac-configurator.py-test$

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 01:59 #136152 by phillc54
That's good, is your config working now.

Cheers, Phill.

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 02:10 #136153 by mkardasi

phillc54 wrote: That's good, is your config working now.

Cheers, Phill.


Yes sir. I just had to recreate the config again with configurator.py. It didn't like like the period in machine name. "esab-plasmac-configurator.py-test" changed it to "esab-plasmac-configurator-test" and it loads just fine.

Thank you very much Phil and all that responded. Your help was invaluable.
-MK

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 02:41 #136158 by phillc54

mkardasi wrote: Yes sir. I just had to recreate the config again with configurator.py. It didn't like like the period in machine name. "esab-plasmac-configurator.py-test" changed it to "esab-plasmac-configurator-test" and it loads just fine.

Thank you very much Phil and all that responded. Your help was invaluable.
-MK

You are welcome, thanks for the report. I will add some error checking for that scenario.

Cheers, Phill.

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum