Help troubleshoot my Plasmac cfg

More
06 Jun 2019 02:39 #136000 by mkardasi
I'm upgrading my parport/G540/stepper machine running 2.7.9 to a 7i96 & THCAD on 2.9.0pre0 and have encountered an error, with a plasmac based config, I can't figure out. I my config works on 2.9.0pre0/Axis and I used configurator.py to create the plasmac specific config. I'm trying to plasmac on 2.9.0 using Axis and here is a snip of the the output with DEBUG_ALL set.

emcAxisSetMaxAcceleration(1, 220.0000) returned 0
emcAxisSetLockingJoint(1, -1) returned 0
emcAxisSetMinPositionLimit(2, -2.1000) returned 0
emcAxisSetMaxPositionLimit(2, 0.0100) returned 0
emcAxisSetMaxVelocity(2, 3.1667) returned 0
emcAxisSetMaxAcceleration(2, 70.0000) returned 0
emcAxisSetLockingJoint(2, -1) returned 0
NML_INTERP_LIST(0x55b3555f27a0)::append(nml_msg_ptr{size=32,type=EMC_TRAJ_SET_TERM_COND}) : list_size=1, line_number=0
NML_INTERP_LIST(0x55b3555f27a0)::append(nml_msg_ptr{size=96,type=EMC_TRAJ_SET_G5X}) : list_size=2, line_number=0
NML_INTERP_LIST(0x55b3555f27a0)::append(nml_msg_ptr{size=96,type=EMC_TRAJ_SET_G92}) : list_size=3, line_number=0
NML_INTERP_LIST(0x55b3555f27a0)::append(nml_msg_ptr{size=32,type=EMC_TRAJ_SET_ROTATION}) : list_size=4, line_number=0
emc/task/emctask.cc 405: interp_error: File not open
File not open
Interpreter stack: 	 - int Interp::_read(const char*)  - int Interp::_execute(const char*) 
emcTaskPlanInit() returned 4
emc/task/emctaskmain.cc 3085: can't initialize interpreter
note: MAXV     max: 10.000 units/sec 600.000 units/min
note: LJOG     max: 10.000 units/sec 600.000 units/min
note: LJOG default: 2.500 units/sec 150.000 units/min
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
waiting for s.joints<0>, s.kinematics_type<0>
A configuration error is preventing LinuxCNC from starting.
More information may be available when running from a terminal.
Shutting down and cleaning up LinuxCNC...
(time=1559786979.793797,pid=26793): Deleting 5 channels from the NML_Main_Channel_List.
(time=1559786979.793819,pid=26793): Deleting emcCommand NML channel from NML_Main_Channel_List.

I have attached the entire debug & my ini file. I'm running Stretch/9.9 & 4.9.0-9-rt-amd64 #1 SMP PREEMPT, plasmac source is up to date. Is there an obvious error in that I'm overlooking in my config?
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 03:14 #136002 by islander261
Hi

Did you set your rip-environment before starting? It looks like you are trying to run from the installed directory and not the rip build you did if you followed the common instructions.

Try and start from a terminal. Then copy and past your terminal output (text) to a file and post it here. Also post your .hal files.

John
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 03:38 #136004 by mkardasi
Hi John,

Yes rip is set, I just use a bash script for less typing. Attached is the a full terminal log & my .hal files.

Thank you,
-MK
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 08:08 - 06 Jun 2019 08:35 #136015 by phillc54
Did make complete without errors and did you do:
sudo make setuid
after make completed.

Edit: Could you post your bash script.

Cheers, Phill.
Last edit: 06 Jun 2019 08:35 by phillc54.
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 13:20 #136040 by mkardasi
Phil,

Yes. I've attached my run and update scripts. Compiled without error. Used the published instructions
git clone git://github.com/phillc54/linuxcnc-plasmac
cd linuxcnc-plasmac/src
./autogen.sh
./configure --with-realtime=uspace
make -j4
sudo make setuid

-MK
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 14:01 #136049 by rodw
Your rip-environment script call is wrong. It requires another dot. Try

. ../scripts/rip-environment

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 15:27 #136065 by islander261
Hi

The file tool.tbl can't be found and that is the start of why things are failing to start, this is most likely caused by not getting the environment set correctly. So in a terminal in your home directory try this:
. linuxcnc-plasmac/scripts/rip-environment
linuxcnc
The first line that is dot space.
Then pick your configuration from the launcher. If your configuration doesn't show up in the launcher then you will need to put your configuration in the~/linuxcnc-plasmac/configs directory and try again. Note if you just do a copy and paste most of the links will be broken and need to be fixed. Copy the terminal output (text) to a file and post if this doesn't work.

John
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 22:32 - 06 Jun 2019 22:38 #136117 by phillc54
The . is a short form for source so the script should be fine.

Run that line in a terminal then run env and post the results.

Edit: it may be better to try:
$ source ~/linuxcnc-plasmac/scripts/rip-environment
or another option is:
$ ~/linuxcnc-plasmac/scripts/linuxcnc
which will set the environment then run linuxcnc

Cheers, Phill.
Last edit: 06 Jun 2019 22:38 by phillc54.
The following user(s) said Thank You: mkardasi

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 23:45 #136132 by mkardasi

The . is a short form for source so the script should be fine.

Run that line in a terminal then run env and post the results.

Edit: it may be better to try:
$ source ~/linuxcnc-plasmac/scripts/rip-environment
or another option is:
$ ~/linuxcnc-plasmac/scripts/linuxcnc
which will set the environment then run linuxcnc

Cheers, Phill.


I tried both commands, unfortunately problem remains same terminal failure.

Executed "$ source ~/linuxcnc-plasmac/scripts/rip-environment" followed by "$ env" and have attached the results.

If this information is of any help I can run the "/linuxcnc-plasmac/configs/by_machine/plasmac/axis/imperial_plasmac.ini" config just fine. Attached for reference is the terminal output of the imperial_plasmac.ini run with DEBUG = 0x7FFFFFFF

Thank you gentlemen for your help thus far.
-MK
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 00:22 - 07 Jun 2019 00:28 #136140 by mkardasi
Made some progress! With RS274NGC_STARTUP_CODE commented out I can get AXIS to load. It seems that my link to to imperial_startup.ngc is broken. I get a blank file when I nano ~/linuxcnc/configs/esab-plasmac/imperial_startup.ngc
Attachments:
Last edit: 07 Jun 2019 00:28 by mkardasi.

Please Log in or Create an account to join the conversation.

Time to create page: 0.094 seconds
Powered by Kunena Forum