Not getting torch up/down signals

More
04 Nov 2019 03:30 #149525 by Cranktown
I've run into an issue setting up my thc with plasmac. Totally new to all of this so no judgy judgy ok

I've created a machine with plasmac in the gmocappy and now that I've gone to test my thc, the graphical 'arc ok' comes on as it should but it shows nothing for the torch up and down. I've skimmed through the hal files, found nothing suspicious, I've done a continuity test for each input at the bob and were good.

Kinda hoping I've missed something dumb, any ideas?

Please Log in or Create an account to join the conversation.

More
04 Nov 2019 03:35 #149526 by phillc54
What mode are you running PlasmaC in.

I assume you mean they don't come on while cutting.

You need to have in The Run Panel:
THC - either Enabled or Auto
Cut Paramenter - THC Enabled if the above is Auto

If you need more help it may may be best to post your .ini and .hal files as well
The following user(s) said Thank You: Cranktown

Please Log in or Create an account to join the conversation.

More
04 Nov 2019 18:50 #149550 by Cranktown
I'm running it in mode 2 with a proma thc.

I do have it set to enabled, not sure about the cut parameter setting though (I'm not in front of the machine I'll check later)

I'm not actually cutting while checking this, just running the test mode on the proma, could that be a factor?

I'll post the hal and ini files once I'm off work today

Thanks for the reply man!

Please Log in or Create an account to join the conversation.

More
04 Nov 2019 19:46 #149551 by tommylight
Set the test time on the Proma to 5 or more seconds so you have enough time to check what is going on.
The following user(s) said Thank You: Cranktown

Please Log in or Create an account to join the conversation.

More
04 Nov 2019 22:20 - 04 Nov 2019 22:21 #149558 by phillc54

I'm not actually cutting while checking this, just running the test mode on the proma, could that be a factor?

The THC Up & Down LED's are outputs, so they only operate when the Z axis is actually told to move by the THC.
The THC will not be active because you are not cutting.
If you want to see if the connections are correct you could go to the Settings page then Halshow.
Select the WATCH page then select pins named plasmac.move-up and plasmac.move-down so they appear in the WATCH page.
They should follow the Proma outputs.
Last edit: 04 Nov 2019 22:21 by phillc54.
The following user(s) said Thank You: Cranktown

Please Log in or Create an account to join the conversation.

More
05 Nov 2019 02:12 #149568 by Cranktown
Sweet it all seems to be working just fine, figured it was something dumb I was missing.
Thanks a lot!

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.201 seconds
Powered by Kunena Forum