Small Hole Feed Override not Resetting

More
24 Apr 2020 00:27 #165328 by Uthayne
Can anyone else duplicate this?

Under the "extras" tab, select the bolt hole circle. Any diameter is fine, but pick a hole diameter under what is set in the settings for "Small Hole Settings". Default is 1.25 in diameter and 60% speed.

If I run this job, and then go back to a different job that I've programmed, I notice that it doesn't clear the 60% speed reduction. For example, after I ran the bolt hole circle with small holes (0.25" dia) in 1/4" aluminum plate, which my material file is set up for 70 ipm, it runs it at 42 ipm which is 60%. This is correct. The problem is when I jump back to a program I made with no small holes but a single cut out of a square, it is still applying the 60% factor when it should not be. This is not allowing THC to activate as plasmac:cut-feed-rate still shows at 70 ipm but it is cutting at 42 ipm, so always under velocity lock threshold.

If I start linuxcnc fresh and go straight to the part I've programmed, it cuts it at 70 ipm, per material settings.
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Apr 2020 01:18 #165336 by phillc54
I did some work on 15 & 17 April that seems to have fixed this.

I just did a test and it seems ok BUT I introduced anew bug where if you enable an offset for kerf width it puts the hole centre in the wrong place by half the kerf width. I will fix that and post back here when it is done.

Please Log in or Create an account to join the conversation.

More
24 Apr 2020 04:54 #165351 by phillc54
Another one of my errors, a fix has been pushed.
The following user(s) said Thank You: Clive S, Uthayne, CNCFred

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.116 seconds
Powered by Kunena Forum