Plasmac hal file mods for 7i96 and THCAD (from the guide) question

More
03 May 2020 22:52 #166543 by dvn4life1972
I'm going through the plasmac guide, and it says if you have a Mesa 7i96 you first need to add some lines in the hal file...



My question, being a layman, is where do I add this within my hal file? The machine file or custom file? And I have no idea where within a hal file any of this would be inserted into.

Pat
Attachments:

Please Log in or Create an account to join the conversation.

More
03 May 2020 23:31 #166546 by phillc54
Those examples are if you have a THCAD connected to a 7i96.

In the machine hal file would be fine.
The following user(s) said Thank You: dvn4life1972

Please Log in or Create an account to join the conversation.

More
03 May 2020 23:36 #166547 by dvn4life1972
Yes, I have a 7i96band THCAD-10. Where in the file do I put it? And do I include the header that says the frequency ratio?

Pat

Please Log in or Create an account to join the conversation.

More
03 May 2020 23:41 #166549 by phillc54
Just the three setup lines.

Somewhere just before the axis_a would be fine.
The following user(s) said Thank You: dvn4life1972

Please Log in or Create an account to join the conversation.

More
04 May 2020 00:23 #166552 by dvn4life1972
Thanks Phil. I'll give it a go.

Pat

Please Log in or Create an account to join the conversation.

More
04 May 2020 01:32 #166560 by dvn4life1972
Got the plasmac config running. I'm still going through the checklist in the guide, and I'm at the point it says to press the probe test button. There isn't one.

Pat

Please Log in or Create an account to join the conversation.

More
04 May 2020 01:35 #166561 by phillc54
I thought I had them in both Axis and Gmoccapy.

You will need to edit your ini file then and add one or change an existing button:

linuxcnc.org/docs/2.8/html/plasma/plasma...#custom-user-buttons

Please Log in or Create an account to join the conversation.

More
04 May 2020 01:47 #166562 by dvn4life1972
It wasn't you Phil. I had to maximize the window (it already looked maximized) and then it was there. I got the clue after I went into the INI to add the button and saw it, as well as several others, in there. Sorry for the confusion!

Pat
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.149 seconds
Powered by Kunena Forum