Pin '10' does not exist

More
05 Jun 2020 19:27 #170270 by Kale Dobrohoczki
I am trying to set up a PlasmaC system and I keep getting an error. I have a working base machine that can move the steppers but I don't have it hooked up to the plasma cutter yet. Everything seems to be working at that point.

I opened up the PlasmaC Configurator and set up the paraport pins that way: ArcOk, Up, Down, Ohmic Probe, Ohmic Enable. It saves and sets up all the necessary files but when I try to launch it the error window opens up. It states that there is an error in the <>connections.hal and that whatever pin I assign to the ArcOk does not exist. I've tried switching the pins but to no avail.

I'm using linuxcnc 2.8. I've been following the PlasmaC user guide. I'm willing to try anything.
Thanks,

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 19:51 #170272 by Clive S
Replied by Clive S on topic Pin '10' does not exist
Can you post the config files ie. all the hal files from the config machine dir.

And a screen shot of the error message . I think I have seen this before

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 20:01 #170273 by Kale Dobrohoczki

File Attachment:

File Name: plasmac_config.hal
File Size:3 KB

File Attachment:

File Name: working_co...ions.hal
File Size:1 KB



Do I have all the relevant hal files attached?
Thanks for the help.
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 20:14 #170274 by tommylight
Replied by tommylight on topic Pin '10' does not exist
Pin 10 does not exist, that is true.
That should be something liek
parport.0.pin-10-in
or similar depending on what you are using.
You should give more info about what you are using and how it is setup.

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 20:37 #170276 by Kale Dobrohoczki
I'm using a parallel port break out board: www.amazon.com/KOOBOOK-Breakout-Interfac...id=1591388506&sr=8-3

Only one parallel port. I'll be using an external up-down style THC(mode 2 I believe). Pins 2 through 7 are dir and step. Pin 17 is my spindle(torch) on.

My goal is to get the table to probe the material for Z and execute the Gcode. I'm using soft limits and no end-stop switches at the moment.

So I may have a syntax problem? I'm not sure what is the right way


Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 20:44 #170277 by tommylight
Replied by tommylight on topic Pin '10' does not exist
Of course, there is no parprort.0.....
There is one to many R there.

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 20:56 #170278 by Kale Dobrohoczki
Thanks so much! All this time I thought I was a linux noob and it turns out its just my typing skills. I suppose both are true. How humbling.
The following user(s) said Thank You: tommylight, Clive S

Please Log in or Create an account to join the conversation.

More
05 Jun 2020 21:18 #170283 by tommylight
Replied by tommylight on topic Pin '10' does not exist
No worries, you are welcomed, always.

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.112 seconds
Powered by Kunena Forum