Ignore probe during cut

More
17 Aug 2021 15:46 #217994 by mariusl
I have a proximity sensor as probe connected to the ohmic probe input. It works well but I get ohmic probe trips during the cut. The probe does sense correctly when this happens. I would like to disable the probe during the cut and then re-enable before the next pierce.
I was thinking to an and2 and connect the ohmic-enable and the torch-on signals to the and gate and route the output of the and2 to the ohmic-enable signal.
Will this make trouble in any other area of use?
 

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 16:14 #217998 by andypugh

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 16:40 #218000 by mariusl
Replied by mariusl on topic Ignore probe during cut
I think my problem is not the same. It would seem that PlasmaC actually looks at the probe input while cutting and will pause when it is tripped. I dont want this to happen as my probe is very close to the material. I only have about 10mm sense length

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 16:43 #218001 by andypugh
Replied by andypugh on topic Ignore probe during cut
LinuxCNC looks at the probe input, and stops if it triggers on a non-probe move.

I think that the component there blocks the probe input if the motion type is not "probing" so prevents this.

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 18:24 #218006 by mariusl
Replied by mariusl on topic Ignore probe during cut
Is was hoping to do that with built-in components as I dont have a dev install on the customers machine.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 18:50 #218007 by andypugh
Replied by andypugh on topic Ignore probe during cut
OK, in that case you would need to convert motion.motion-type to a float then use wcomp to see if it is close to the number that corresponds to probing. Then use and2.

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 20:42 #218013 by rodw
Replied by rodw on topic Ignore probe during cut
Plasmac has a probe enable signal that becomes active during probing. You may be able to and2 the probe input with that. Should work.
When I had this issue pre-plasmac, I used one of the digital outputs and placed M62-M65 around my probing routine to use and2 with.

Please Log in or Create an account to join the conversation.

More
17 Aug 2021 23:42 #218028 by phillc54
Replied by phillc54 on topic Ignore probe during cut
You should be able to use a and2 as you suggested without compromising anything. Connet plasmac.ohmic-enable to an and2 input then connect your probe hardware pin to the other and2 input then connect the and2 output to plasmac.ohmic-probe .

@andypugh, PlasmaC is a bit (lot) odd in that it doesn't use the motion.probe-input or G38 commands for probing, it does probing within the component.

Please Log in or Create an account to join the conversation.

More
18 Aug 2021 06:43 #218042 by mariusl
Replied by mariusl on topic Ignore probe during cut

You should be able to use a and2 as you suggested without compromising anything. Connet plasmac.ohmic-enable to an and2 input then connect your probe hardware pin to the other and2 input then connect the and2 output to plasmac.ohmic-probe .

@andypugh, PlasmaC is a bit (lot) odd in that it doesn't use the motion.probe-input or G38 commands for probing, it does probing within the component.

I thought I had the same problem on a machine before and could not remember how I solved it. Now that you gave the solution I realized that was exactly how it was solved. (I think Covid zapped my brain)
Thanks a lot mate.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.074 seconds
Powered by Kunena Forum