Config for a XY PlasmaC Help

More
10 Oct 2021 21:58 #222800 by swepeter
Hey

Is it possible to configure the PlasmaC with no Z axis? 

I only want X and Y like a laser engraver. 
I am running a mesa 7i96 card. 

My second problem is the "plasmac:torch-on".
I have connected a led on the out01 TB3 to simulate, but it never lights up. 

This is my config now
How can I get around the net plasmac:float-switch? 
#***** PLASMA CONNECTIONS *****
#net plasmac:arc-ok-in hm2_7i96.0.gpio.001.in => db_arc-ok.in
net plasmac:float-switch hm2_7i96.0.gpio.000.in => db_float.in
# net plasmac:breakaway {YOUR BREAKAWAY PIN} => db_breakaway.in
# net plasmac:ohmic-probe {YOUR OHMIC PROBE PIN} => db_ohmic.in
# net plasmac:ohmic-enable plasmac.ohmic-enable  => {YOUR OHMIC ENABLE PIN}
net plasmac:torch-on => hm2_7i96.0.gpio.001.out
#net plasmac:move-up hm2_7i96.0.gpio.002.in => plasmac.move-up
#net plasmac:move-down hm2_7i96.0.gpio.000.in => plasmac.move-down

#***** MULTIPLE TOOL ENABLE *****
# set to 1 to enable a scribe or spotting
setp plasmac.multi-tool 0

#***** SCRIBE CONNECTIONS *****
# net plasmac:scribe-arm plasmac.scribe-arm => ***YOUR_SCRIBE_ARMING_OUTPUT***
# net plasmac:scribe-on  plasmac.scribe-on  => ***YOUR_SCRIBE_ON_OUTPUT***

# FAKE ARC-OK CONNECTION
net plasmac:torch-on => db_arc-ok.in




Thanks for the help 
/Peter

Please Log in or Create an account to join the conversation.

More
10 Oct 2021 23:48 #222810 by phillc54
I am not sure if it relies on having a Z axis, you could try it and if it fails just make up a simualated Z axis.

Did you have the torch Enabled?

 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 08:42 - 11 Oct 2021 08:44 #222826 by swepeter
Yes it was enabled. I have tried the test torch button also but no luck.

Regarding the Z axis. It is looking for the float and if I have it always pressed I get an error that it was already pressed before probing. 
Last edit: 11 Oct 2021 08:44 by swepeter.

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 08:49 #222828 by phillc54
Check what the plasmac.torch-on hal pin does when you try to fire the torch.
 

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 08:57 #222829 by swepeter
If I press the button so the float switch light goes off the Halmeter for plasmac.torch-on becomes true.
But the led on the Mesa out 01 is still dark

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 09:00 #222830 by phillc54
I have just noted that you are using a 7i96, the output pin would be hm2_7i96.0.ssr.00.out-01

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 09:10 #222831 by swepeter
Thanks! that worked.

Now just to the problem of not having a z axis

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 09:17 #222832 by phillc54
If you post a backup of your config made from the Backup button in the Config panel I could take a look tomorrow to see if I can sort something out for you.

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 09:26 #222833 by swepeter
So sorry what config panel?

Please Log in or Create an account to join the conversation.

More
Moderators: phillc54
Time to create page: 0.104 seconds
Powered by Kunena Forum