Run From Line

More
25 Nov 2021 05:02 #227555 by CFE
Run From Line was created by CFE
Hi All,

I am having issues with 'Run From Line' command. Every time i try to use this it comes up with error 'QTvcp ERROR! message #1 see photo attached.
Run From Line check box is enabled in the parameters tab. I have read this section in the manual and i have tried both selecting the line in the preview screen and than after restarting QtPlamacC selecting line in G-code window. Then cycle start button changes to 'selected line 351' than i click the selected line button, but rather than the run from window dialog box appearing the following error in photo attached appears, than QTPlasmaC shuts down!!!. i have tried this multiple times, at different positions, on straight lines, on arcs, etc. Every time the same error message shows up than QTPlamaC shuts down when i try and get rid of the message

Any suggestions?

Thankyou in advance
Regards To,
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 05:53 #227557 by phillc54
Replied by phillc54 on topic Run From Line
Can you post your gcode file.

This should be in the PlasmaC section of the forum, we do run from line a bit differently.

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 06:34 #227559 by CFE
Replied by CFE on topic Run From Line
Sorry i was looking through the forum and forgot to go back to the right section before writing the 1st message my apologies, do i need to restart this question in the PlasmaC section?

Please find G-code attached

Thankyou
Tim
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 07:55 #227563 by phillc54
Replied by phillc54 on topic Run From Line
No, it is OK, hopefully Tommy will see it and move it.

I can see what is wrong, I have it partially fixed now and I will push it tomorrow.

Try editing this line N20 G17 G91.1 by removing the G91.1 and see if that works for you
 

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 08:26 #227564 by tommylight
Replied by tommylight on topic Run From Line
Done.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 21:53 #227592 by CFE
Replied by CFE on topic Run From Line
Thanks Phil
I removed the G91.1 from the G-code and tested it as per manual. The same error still shows up than QTPlasmaC shuts down when you remove the error screen.

Please Log in or Create an account to join the conversation.

More
25 Nov 2021 22:41 - 25 Nov 2021 23:23 #227595 by phillc54
Replied by phillc54 on topic Run From Line
I see another issue, can you remove the period from the end of this line N50 M190 P16.

Edit: if you click Retry on the error message it may not crash QtPlasmaC

Edit2: I have the fix ready to push if you can confirm that removing the G91.1 and removing the trailing period allow you to run from line correctly.
Last edit: 25 Nov 2021 23:23 by phillc54.

Please Log in or Create an account to join the conversation.

More
26 Nov 2021 01:41 #227605 by CFE
Replied by CFE on topic Run From Line
Success!! once i removed the period as requested, 'Run from line' worked perfectly,

Thankyou very much Phil

Please Log in or Create an account to join the conversation.

More
26 Nov 2021 01:42 #227607 by CFE
Replied by CFE on topic Run From Line
I forgot to try the Retry button this morning but I did try it yesterday and QTPlasmaC seemed to stall, sitting there thinking

Please Log in or Create an account to join the conversation.

More
26 Nov 2021 01:43 #227608 by phillc54
Replied by phillc54 on topic Run From Line
Great, thanks. I will push the fix shortly.

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.071 seconds
Powered by Kunena Forum