Disable probe routine to run a router

More
30 Sep 2022 17:46 #253115 by Daddio
Hi everybody,
I am trying to run a router on my plasma table that runs qtplasmac but am not able to get past the probing routine.  My process so far has been to home z axis, move it to where I want it to start its plunge which is right above the material, I then zero Z axis.  However, when I click cycle start it probes for the the material height which it won't find because I have the float switch locked out.  Is there a way to disable the probe routine in a code snippet in SheetCAM at the beginning of a cut and then enable it at the end of cut?  I'd like to be able to home z, move to the start of my plunge height, turn on the router, and then tell it to go without a probing sequence.
Thanks,

Please Log in or Create an account to join the conversation.

More
30 Sep 2022 19:03 #253119 by snowgoer540
Why don't you just duplicate the pertinent parts of your config and run it on another screen like Axis?  QtPlasmaC/PlasmaC is built for plasma.

That said, to answer your question, you can keep Z motion with the following line in a gcode file:
#<keep-z-motion> = 1

Just note that this was really just intended for a diamond drag scribe, or a marker, or something like that.

linuxcnc.org/docs/devel/html/plasma/qtpl....html#_keep_z_motion

Please Log in or Create an account to join the conversation.

More
01 Oct 2022 04:20 #253142 by Daddio
Yes, I am using the  #<keep-z-motion> = 1 so that my z axis moves. Isn't there an M code that disables the initial probing routine and one to re-enable it? I know I can set up a new screen like Axis, but it seems like there should be a way to do it with M codes.

Please Log in or Create an account to join the conversation.

More
01 Oct 2022 04:43 #253144 by phillc54
Probing in QtPlasmaC is controlled by the plasmac component and it is not able to be bypassed.

Please Log in or Create an account to join the conversation.

More
01 Oct 2022 15:57 #253183 by snowgoer540

Yes, I am using the  #<keep-z-motion> = 1 so that my z axis moves. Isn't there an M code that disables the initial probing routine and one to re-enable it? I know I can set up a new screen like Axis, but it seems like there should be a way to do it with M codes.


Maybe I am a bit confused as to what you are trying to accomplish. I am not understanding why you need to disable the probe, unless you are trying to use M3 to start your spindle. In that case, I agree with Phill, there is no way to override the probe it's part of the component.

But if you are starting the spindle on your router manually, then I am not sure I understand why keep-z-motion wouldn't work for you.

Say I had this simple program to cut a 4" circle with plasma:

Warning: Spoiler!


I could use keep z motion to do the same program with a diamond scribe, or marker, etc, but I do need to remove the M3 and M5 starts and stops:

Warning: Spoiler!


In the latter example, you would set Z0 as the point where the tip of your tool touches the material manually before starting the program. Then when you run, it will cut .25" deep in this example.

I say all of that, but I think the easiest solution is to just make another config to call up and use a purpose built GUI like Axis when you want to use it as a router table...

Please Log in or Create an account to join the conversation.

More
01 Oct 2022 16:52 #253189 by Daddio
I am starting the router manually from one of the user buttons connected to a relay, so I am not using M3 to start the router spindle.    The problem is the float switch.  Currently, I have it locked out on its floating head for router because otherwise it will constantly be tripped during operation. 

There are two scenarios with the float switch at cycle start:
1. Float switch not locked out:  At cycle start, Z will be able to find the material during probing routine and will be ready to run.  However, the float switch will immediately be tripped when the router contacts the wood and the program will fault out.
2  Float switch locked out:  At cycle start, Z will fail to find the material during probing routine and will fault out.

So it seems there are two solution paths:
1.  For scenario 1, make the floating head rigid so no more float, then use the float switch for the initial probe routine to find the material, then ignore the float switch during routing.  How can I ignore the float switch input after a probing routing?
2.  For scenario 2, make the floating head rigid (I've already done this), manually jog the router into position, zero z, then skip the probing routine, and run the job.  How can I skip the probing routine? 

Thanks

Please Log in or Create an account to join the conversation.

More
01 Oct 2022 21:08 - 01 Oct 2022 21:45 #253200 by snowgoer540
For scenario 1, float switch tripping makes sense.  That would cause it to stop the program.
For scenario 2, I still dont understand why it's probing, unless you are leaving M3 commands in the gcode.

Can you please post the gcode you are trying to cut with the router?
Last edit: 01 Oct 2022 21:45 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
02 Oct 2022 00:14 #253212 by snowgoer540

2.  For scenario 2, make the floating head rigid (I've already done this), manually jog the router into position, zero z, then skip the probing routine, and run the job.  How can I skip the probing routine? 


Reread this. To answer your question explicitly:

1. Remove M3/M5 commands. M3 will cause the probing routine.
2. Add the line #<keep-z-motion> = 1 near the top of the gcode file.
3. Add your appropriate Z movements before and after your cut path.

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.159 seconds
Powered by Kunena Forum