Having problems with my THCAD-10

More
02 Dec 2023 15:58 - 03 Dec 2023 00:26 #287029 by aabtech
     
Hi, I have a new plasma machine which I bought recently that has CNC ports and has 1:1 ratio divider and am using 1M ohms at each leg of + and - of the plasma machine which will give you 21:1 ratio but the THC doesn't move up and down but I can see the THCAD-10 LED light blinking fast when cutting and blink slowly when not cutting. i have attach my logs.
Attachments:
Last edit: 03 Dec 2023 00:26 by aabtech.

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 18:09 #287037 by tommylight
Screenshot when cutting, not cutting, and settings page

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 19:14 #287045 by rodw
the light on the board  shows your wiring to the thcad is correct.
Next step is to confirm that it is being read correctly by the mesa encoder.
open halshow and find the encoder you are using. Does the velocity pin ove at all or does it stay static.

If its static, then this is probably missing from your hal file.
setp hm2_7i76e.0.encoder.00.counter-mode  1
setp hm2_7i76e.0.encoder.00.filter        1
setp hm2_7i76e.0.encoder.00.scale        -1
I thought it was added by pncconf

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 19:15 #287046 by rodw
Once your encoder velocity is responding correctly, 
enter your thcad calibration data into the qtplasmac gui as per the instructions.

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 23:56 - 03 Dec 2023 00:21 #287052 by aabtech
# ---ARC VOLTAGE ENCODER---
net plasmac:arc-voltage-in <= [HMOT](CARD0).encoder.00.velocity
setp [HMOT](CARD0).encoder.00.counter-mode 1
setp [HMOT](CARD0).encoder.00.filter 1
setp [HMOT](CARD0).encoder.00.scale -1

this is how it look like in hal. my board is 7i96s
Last edit: 03 Dec 2023 00:21 by aabtech.

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 23:59 #287053 by aabtech
 

File Attachment:

File Name: AABTECH_20...2-02.hal
File Size:9 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
03 Dec 2023 00:46 - 03 Dec 2023 06:04 #287054 by aabtech
       
Attachments:
Last edit: 03 Dec 2023 06:04 by aabtech.

Please Log in or Create an account to join the conversation.

More
03 Dec 2023 11:58 #287085 by tommylight
Wrong polarity on THCAD input, or wiring not correct from THCAD to Mesa 7i96S.
Open the "halshow" and check if the encoder is counting correctly.

Please Log in or Create an account to join the conversation.

More
03 Dec 2023 20:45 #287139 by rodw

Open the "halshow" and check if the encoder is counting correctly.

THis is the step I told you to do earlier but you didn't
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
03 Dec 2023 21:58 - 03 Dec 2023 21:59 #287143 by tommylight

Open the "halshow" and check if the encoder is counting correctly.

THis is the step I told you to do earlier but you didn't


Yes you did Rod, i just reminded him.
Last edit: 03 Dec 2023 21:59 by tommylight. Reason: tags

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.684 seconds
Powered by Kunena Forum