Probe Basic Help

More
29 Jan 2022 22:04 - 29 Jan 2022 22:05 #233490 by natholego11
Replied by natholego11 on topic Probe Basic Help
our hal files look to be almost identical but im still not getting and data to the Probe_basic DRO for the spindle.

i feel like my connection between the correct hal pins and what you showed me earlier is not correct.

here is my hal and ini file.
Attachments:
Last edit: 29 Jan 2022 22:05 by natholego11.

Please Log in or Create an account to join the conversation.

More
29 Jan 2022 23:17 #233500 by Lcvette
Replied by Lcvette on topic Probe Basic Help
#==================
# SPINDLE
#==================

[SPINDLE_9]
P = 0.0
I = 0.0
D = 0.0
FF0 = 1.0
FF1 = 0.0
FF2 = 0.0
BIAS = 0.0
DEADBAND = 0.0
MAX_OUTPUT = 6225
ENCODER_SCALE = -4096
OUTPUT_SCALE = 6225
OUTPUT_MIN_LIMIT = -6225
OUTPUT_MAX_LIMIT = 6225

Please Log in or Create an account to join the conversation.

More
29 Jan 2022 23:36 #233501 by Lcvette
Replied by Lcvette on topic Probe Basic Help
Man I'm really sorry, I was thinking about it and it's been 5 years since I setup my configs and I rarely look at the spindle speed. So I went and checked and mine isn't connected either.. I will tinker with it to connect and let you know what is needed.

It actually dawned on me that I bought a high end load sensor back then I intended to install and I completely forgot a out it.. need dig around and find that too and get it installed and connected and working!

Please Log in or Create an account to join the conversation.

More
30 Jan 2022 13:04 #233537 by natholego11
Replied by natholego11 on topic Probe Basic Help
so for now your artificially displaying the speed? basically whatever the SXXXX M3/M4 code had? and not an actual encoder signal?

I am using a DMM DST-120 motor ( the biggest thing they had) which obviously has a built in encoder, and that is the signal I am feeding my 7i96.

Please Log in or Create an account to join the conversation.

More
30 Jan 2022 23:02 #233591 by Lcvette
Replied by Lcvette on topic Probe Basic Help
the gui is setup like that for those not using encoder feedback. it is a way to see the commanded speed and any speed adjustment calculated from the increase of the spindle override setting. for encoder feedback machines I am making the left side spindle rpm display a stacked widget with two readouts. the user can set which they want to be visible in the settings page. I am making the encoder feedback readout a hallabel with a predefined pin base name that will be in the custom_postgui hal file. they will just need to edit for main hal file net pin they want to pull data from. in my case it will pull from the filtered net pin. that should cover everyone and leave it flexible for any type of float input.

however while setting up a py2 dev machine i noticed some breakage that needs to be resolved prior to me pushing a new update for the deb10 version. so may be a few days until that is sorted out.

Please Log in or Create an account to join the conversation.

More
01 Feb 2022 12:28 #233707 by natholego11
Replied by natholego11 on topic Probe Basic Help
Thanks for the update. Ill wait till then!

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.095 seconds
Powered by Kunena Forum