Double X-Axis gantry problems

More
28 Jul 2012 07:13 #22548 by Miselph
PCW wrote:

Also, have you run a latency test on this machine? large latency can cause apparent ferrors


The latency values were 10130 for both threads.

Please Log in or Create an account to join the conversation.

More
28 Jul 2012 09:43 #22551 by ArcEye

[edit] I did have an acceleration rate of 50mm/s^2 but I turned it down to check the problem and may not have turned it back up in the attached file [/edit]


You will have to advise which of the MAX_ACCELERATION figures in your zip are current.

The ones in your .ini file are bizarre, X 1mm/s/s, Y 100 mm/s/s, Z 300 mm/s/s, A 1 mm/s/s.

100 is probably at least 3 times too high for a small stepper machine, I would advise try setting all of them to 15-20 mm/s/s and test from there.

Also note that your servo period is the default 1,000,000.
As you are using an external pulse generator, not sure if this doesn't need bringing down, PCW would be best to advise, I have no experience with the Mesa boards

regards

Please Log in or Create an account to join the conversation.

More
28 Jul 2012 15:17 #22560 by Miselph
Hello once again,

I have now changed the FERROR and MIN_FERROR values so that they are the correct way round. I have also reduced the acceleration and made the values the same in the ini and hal files.

The machine will function correctly without giving any joint follow errors in joint mode, in MDI mode and it will excecute programs correctly without any problems but I am still unable to jog in world mode as I get joint follow errors if I try and move anything other than very very slowly.

My current config is attached.

Thanks again,

Chris

File Attachment:

File Name: Realistic-...b07e.zip
File Size:7 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
31 Jul 2012 12:07 #22627 by andypugh
This all seems a bit odd, I will try to have a play with your config in a simulator tonight. (No promises though)

Please Log in or Create an account to join the conversation.

More
03 Aug 2012 22:08 #22745 by andypugh
I couldn't use a simulator, I needed to try it on the real 5i25/7i76 machine. (luckily, I have one).

I made the problem go away by setting the stepgen maxaccel parameters to 0 in the HAL file.
However I seem to recall PCW saying that that was a bad idea.

It is, anyway, a bad idea in this case because the underlying problem is that there is _no_ acceleration limit applied when jogging in your config.
I am not sure why that would be, as there definitely is in a trivkins, and gantrykins is just a slightly complicated trivkins.

Please Log in or Create an account to join the conversation.

More
03 Aug 2012 22:35 #22746 by andypugh
I think I fixed it :-)

You need an entry in the [TRAJ] section of your INI file

[TRAJ]
...
DEFAULT_ACCELERATION = 20
...

Actually, all your accelerations seem a bit low really. Also, your stepgen-maxaccel values in the HAL file need to be 25% higher than the axis accelerations.

Please Log in or Create an account to join the conversation.

More
04 Aug 2012 11:11 - 04 Aug 2012 11:24 #22758 by BigJohnT
Andy is there something that needs to be in the manual about this?

I also don't see that entry in the gantry sample config... should it be there?

I also just tested the gantry config and it jogs fine in world mode so it there more to it than meets the eye? The only thing funny is the A axis shows up in world mode but does nothing it seems.

John
Last edit: 04 Aug 2012 11:24 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
04 Aug 2012 12:36 #22766 by andypugh
BigJohnT wrote:

Andy is there something that needs to be in the manual about this?

It is there in the INI config, but perhaps not stressed.

I also don't see that entry in the gantry sample config... should it be there?

I think so.

I also just tested the gantry config and it jogs fine in world mode

Try sliding the speed slider to max and try again. It f-errors when you release the button.

Please Log in or Create an account to join the conversation.

Time to create page: 0.277 seconds
Powered by Kunena Forum