[SOLVED] Home switches stopped working between runs. Troubleshooting guidance.

More
26 Jun 2019 01:08 #137845 by tommylight
Those issues you are having beg the question: do you have proper grounding for the computers/ machines ?
Also if your computer locks at random, disconnect the parallel port cable from it and do a stress test by copying some large files and watching YouTube at max quality your computer can handle.
If by any chance it survives all that torture but it locks while the PPort is connected, shut it down, grab a multimeter and check why and how it voltage over 5V getting to your parallel port.

Please Log in or Create an account to join the conversation.

More
26 Jun 2019 15:55 #137909 by clunc
I pulled the machine apart and reseated the parallel port card and memory sticks. I ran MEMTEST86 on the RAM, which showed no errors. Both computer and CNC are connected to grounded outlets. I investigated and found that I have a 220V-to-24VDC power adapter and verified that it is supplying 24V to the proximity switches.

The computer is still booting and behaving weirdly--sometimes boot after error messages, sometimes not making it that far, sometimes losing keyboard or mouse after making it to the desktop.

The machine is dual-boot and Windows boots and is stable. It may be that I can reinstall the rtai kernel for Ubuntu 12.04, but I don't find it offered among the offerings at:
www.linuxcnc.org/iso/

I am meanwhile also woring to configure a replacement computer to test that the CNC machine itself operates normally. Initially I'm just going to install LinuxCNC on whatever Linux OS is on it (non-RT) and see if axes will move and proximity switches will be detected. If those work, I'll install latest-and-greatest from an ISO image.

...and, on that subject, I went looking for the vaunted "LinuxCNC Stretch ISO" and found this repository:
www.linuxcnc.org/testing-stretch-rtpreempt/

However, although "LinuxCNC 2.7" is referenced in the page title, I wonder, based on what I think I read, if 2.7 might refer to 'r12' and 'r13' is 2.8?`

Please Log in or Create an account to join the conversation.

More
26 Jun 2019 21:04 #137927 by mkardasi
No. I used the r13 iso file and 2.7.14 is packaged.

Please Log in or Create an account to join the conversation.

More
27 Jun 2019 19:56 #138027 by andypugh
Once you have 2.7 running it is easy to change to 2.8 (or master/2.9)

instructions are at buildbot.linuxcnc.org

(though I prefer to make the repository changes in the Synaptic GUI rather than edit the sources file). The stanzas needed are the same.

Please Log in or Create an account to join the conversation.

More
01 Jul 2019 16:08 #138307 by clunc
Finally... relief. The "home switch" inputs to my 5-axis CNC interface card failed, probably from a power event because my controller computer also needed to have Linux and LinuxCNC reinstalled. Another server which was also left running failed to reboot as well.

I happened to have a spare interface card on-hand, but postponed changing it out until I had checked out other, easier, things to check.

I ran MEMTEST86 on the computer's memory. Check.
I booted a Linux Livedisk and ran fsck on the hard drive file system. Check.
I reinstalled Linux 12.04 with the RTAI image in the existing Linux partition--without repartitioning or reformatting, and reinstalled LinuxCNC. Check. (My user account data in /home/<username>/ were preserved--which means that my LinuxCNC configs survived as well.)
I ran LinuxCNC and checked that the LED indicators for the home signals (in Show hardware config) did not in fact change state. Check. (Y home actually did function. X and Z didn't.)
I moved the parallel port cable to the second parallel port adapter card (surprised me too that I found it), reconfigured the port address in stepconf, and verified that the LED indicators failed to change on that port as well. Check.
I checked that the LEDs on the home switches themselves (SNO-4) did light when the axes came into proximity. Check.
I checked that the inputs to the home-switch pins on the interface card did toggle between 0 and supply voltage (24V). Check.
I checked the cabling along the moving gantry all the way back into the power/control space, verifying that there were no signs of damage. Check. (Both X and Z have cabling on the gantry. As they had failed, I was sure I'd find cable abrasion somewhere along the gantry cabling. But no.)

With all this done, at various times over several days as I could muster the motivation to try something else, I finally had what I needed to face what had now become the last-ditch try, swapping out the interface board.

I was more than a little surprised to find out that it worked just-fine-thank-you.

Before celebrating however, I edited my Z-axis's HOME_SEARCH_VELOCITY from +2.5 to +0.1 and pledged to myself to rough-position the axes near the home switches before attempting homing. (This started out, if you recall, with me RAMMING the Z-axis HARD up against it's stop. TWICE. Now at least, at least on Z, it will creep up to the switch, with me hovering over the ESC. The X- and Y-axis homes are set in their middle-of-travel, so there's a lot more time, and much less urgency, to observe the switch being missed.)

"For my next trick, I'd like to build an independent LinuxCNC control box, so I can just switch over if the primary fails."

My deep thanks to you good people for offering clear advice and encouragement.

[ASIDE: During all this, we had house guests. Two of my siblings and their families. I struggled to have my face say, "Stay as long as you like!" while my blackest thoughts ran more like "If you're not going to help me get my machine back up, you're useless! Get out!" However each day I got up a little earlier and got in several good reps of bashing my head against things before they strolled out for breakfast. After breakfast though, it was all site-seeing and family outings' fun until bedtime. Bah! ;^) ]

Please Log in or Create an account to join the conversation.

More
01 Jul 2019 22:45 #138338 by tommylight
Hmmmmmm......24V !
Are you certain that BOB can handle 24V on the inputs ? Most of them work with 5V. Some voltage dividers will do that job nicely, or just plain resistors on the inputs, with some math to get the values.

Please Log in or Create an account to join the conversation.

More
02 Jul 2019 01:05 #138362 by clunc
Yep. It's worked great for literally years. (I had a vague recollection that "I was not the kind of person to willy-nilly hook up random voltages and hope they worked," but I couldn't remember for sure.)

I checked the spec:
3、Wide range external power supply voltage ,12 - 24V, and has preventing reverse
connection function.
(I'm not sure I checked it earlier, but at least I checked it now, right?)

I found a 240VAC/24VDC power supply to drive it: because the machine uses 240VAC.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
02 Jul 2019 17:09 #138418 by tommylight
Nice, glad your back up and running.
Thanks for reporting back.

Please Log in or Create an account to join the conversation.

Time to create page: 0.095 seconds
Powered by Kunena Forum