[SOLVED] Home switches stopped working between runs. Troubleshooting guidance.

More
24 Jun 2019 17:35 - 01 Jul 2019 16:14 #137745 by clunc
(I knew I should've stayed home.) [EDIT: exec sumry. Prob. power event. Reinstalled Linux and LinuxCNC but 5-axis CNC interface board also failed. Details here .]

When I got back from an out-of-town trip, I fired up my CNC and set about homing it for a new project. It promptly jammed the Z-axis into the roof of travel... I removed the spindle, wrenched the axis free, using a Vise-Grip on the precision-ground ballscrew threads, figuring I had left it too high, ran it down a couple of inches below the home switch--and did it again... As Bugs Bunny used to say, "What a maroon!"

After that I decided to check the X and Y homing and found that they, too, do not function.

They worked fine when I ran a model just before leaving town.

The switches are the proximity (magnetic?) type and wired as independent inputs to a "Mach-3-style interface board" connecting pins 12, 13, and 15 of the parallel port to the home switches X, Y, and Z respectively. Wiring to the board looks fine and DB25 connectors are tight on both ends. I have restarted LinuxCNC, v2.7.14-112.

A couple of times when machine behavior was Very Strange Indeed in the past, I discovered that I had stepped on the too-short USB power cable providing 5V to the interface board, unplugging it--not good. This time I verified that it is connected. The wires running from the switches are protected by those self-rolling-up cable-management systems (or have been--I will have to crawl under the machine to verify there has been no damage--not an easy feat in my cramped quarters). However, there has been no indication of "trauma" or "violence": it worked before, I turned it off for a few days and now it doesn't work.

It's worth noting that the Linux machine, v12.04LTS, was left on all that time, as was LinuxCNC.

It's as if a setting somewhere "disable home switches" has been set.

If anyone has thoughts about what might explain this, I could use and would appreciate the help. (I'm bound for the underside of the machine: 6'1" in <4x4x3...)

[EDIT: I got to thinking that maybe there was a "power event" while I was gone and rebooted the machine, and in fact Linux complained about stuck or stalled (forgot the term used) CPU cores and seemed to be in a rut, so I rebooted again in recovery mode, during which I did an 'fsck' (clean) and a 'dpkg repair.' The latter downloaded and installed LinuxCNC v2.7.14-138, but it too does not sense the home switches.]
Attachments:
Last edit: 01 Jul 2019 16:14 by clunc. Reason: edit description

Please Log in or Create an account to join the conversation.

More
24 Jun 2019 18:03 #137747 by clunc
I found this thread from an outside-the-forum search, which I'd failed to find with an in-forum search:
forum.linuxcnc.org/49-basic-configuratio...g-problems-on-z-axis

i'll be checking for broken wires/loose grounds. It seems more likely to be a single, common ground to explain none of them working rather than three simultaneous signal-wire failures.

When the X-axis carriage is in the "home" position, these variables have these values:
axis.0.home-state 0
axis.0.home-sw-in FALSE
axis.0.homed FALSE
axis.0.homing FALSE

None of them changes state when passing through home.

Please Log in or Create an account to join the conversation.

More
24 Jun 2019 22:36 - 24 Jun 2019 22:38 #137756 by clunc
For future thread-readers, I found this page (again) containing a program to use with 'halrun' to test the parallel port:
wiki.linuxcnc.org/cgi-bin/wiki.pl?Parallel_Port_Tester

However, in my case, I have not seen my Ubuntu 12.04 machine boot up twice in the same way in four separate boots... I think I've been too lucky too long and now face squarely what I've always dreaded: getting a new computer to run LinuxCNC to run the CNC machine, with my customized interface.

I've been advised, variously, and some weeks ago, to learn to compile LinuxCNC from source, to use a Mesa card to assume the real-time-computation burden off the CPU, and to try Linux Mint. I am now in a 'Go' condition for all of these.

I will start another thread to solicit info about what people have used lately to do the job. [Actually, although there's a fair chance my motherboard or parallel port is damaged, I intend to take the approach of installing Linux Mint on a 2nd hard drive to see if it--might--still--work.]
Last edit: 24 Jun 2019 22:38 by clunc.

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 00:39 #137764 by tommylight
Open Linuxcnc, in the "machine" menu there is "show hal configuration", on the left side navigate to "parallel port.0.pin10 and 11 and 12 and 13 and 15" those are the inputs, now on the right top side click on show, then on the left side click on each of the above mentioned pins, now you have on the right side LED's showing the state of the inputs, press on each of them and check if the led changes color.

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 01:15 - 25 Jun 2019 01:15 #137770 by rodw
Also, the new Stretch ISO probably negates the need to install Mint and compile Linuxcnc.
But Damn, that Mint is nice and compiling is fun!

But yes, always do as Tommy says and check signals are working with Halsow before proceeding. I had a home switch fail over the weekend (prox sensor).
Last edit: 25 Jun 2019 01:15 by rodw.

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 02:14 #137771 by clunc
Tommy,
I can't quite follow the instructions with my v2.7.14-138 in this sense.

1. I got to the Machine->ShowHalConfig
2. and on the LHS found, for example, Pins->parport->0->pin-10-in
3. clicking on it, pin-10-in, on the LHS enters the following into the SHOW tab (nothing is entered in the WATCH tab):
Component Pins:
Owner Type Dir Value Name
12 bit OUT TRUE parport.0.pin-10-in
12 bit OUT FALSE parport.0.pin-10-in-not
4. clicking, for example, pin-10-in, again does not show anything of interest
5. opening the WATCH tab and clicking on, for example, pin-10-in, does enter a Yellow "LED" with the name "parport.0.pin-10-in" into the WATCH tab and clicking pin-10-in on the LHS does NOT change the color (pin-10-in-not behaves similarly with a dark red "LED" which does not change color when clicked again)

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 04:03 #137775 by rodw
Its not something that lets you change something but shows you whats going on. So if you now activate a home switch or whatever that pin is connected to, can you see the state change?

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 10:53 #137788 by clunc
Ah. Press/activate the home switch itself.

Although I didn't move it, I had the X-axis actually parked in front of its proximity switch, triggering the switch's LED, but the pins parport.0.pin-10-in[-not] didn't look any different than the others (that is, they showed yellow and dark red).

Before your reply, I was preparing a couple of screenshots to clarify when my mouse froze, which appears to be a recurring symptom now.

I did crawl under the machine and checked the wiring along its length and found no damage to any cabling and that it's all still safely tied away from obstacles.

I think the explanation is that my machine has gone crazy. Supporting this theory is the fact that a fileserver on my network now won't boot.

I can't take any more of the forum's time without being able to assure you that I'm working with a healthy computer.

Thanks fellows.

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 12:11 #137794 by rodw
It might be worth putting a multimeter on your proximity sensor output. I had one fail on a home switch the other day and on a 24V system, I was getting 12 volt and 3 volt for on and off. The LED would come on when triggered but glowed dimmer than normal. In this case, replacing the sensor fixed the problem.

The -not pins are there simply as a convenience as they are the inverse of the normal input pin so it will always be the opposite of the pin. (The colours represent on and off)

Please Log in or Create an account to join the conversation.

More
25 Jun 2019 22:09 #137829 by clunc
Good point.

I forgot how they get power, but since none work, it's possible they source from a single source which has failed. I actually do have a spare "Mach3 board"--back from when I mistakenly thought it had failed when I had only inadvertently unplugged its 5V USB supply.

Please Log in or Create an account to join the conversation.

Time to create page: 0.129 seconds
Powered by Kunena Forum