MaxNC T2 lathe

More
05 Nov 2010 02:01 - 05 Nov 2010 02:02 #5093 by yugami
Replied by yugami on topic Re:MaxNC T2 lathe
I'm not sure if its intended this way but I have to hold the button down to keep an output toggled.

Because of this I can't do extensive testing but 1 interesting thing that came to light is that if I hold 17 high 10 lights up for a couple seconds then goes dark.

Click 17, 10 lights up green, theres a noise (you can feel the spindle of the motor jerk a little), 10 goes back to red, high pitch whine starts.

[time passes]
Somehow I just got the z axis to work. X is disconnected from the controller so now I'm going to shut down and try that.

I have HALScope monitoring Z phase A and B - pin 17 and pin 10. 17 is tied to xenable.

Trying to use X when its hooked up pegs pin 10 again and it doesn't go back down. Theres a little jerk to the spindle, 10 goes high, then nothing works.

So X being the easiest to test has been the problem. Z works fine.

if 10 is supposed to signal an encoder issue then I'll have to look there.

This is a used unit that was not treated well during shipping.

File Attachment:

File Name: maxnc_t2-d...6ce7.hal
File Size:3 KB
Attachments:
Last edit: 05 Nov 2010 02:02 by yugami. Reason: attached current config files

Please Log in or Create an account to join the conversation.

More
05 Nov 2010 11:43 #5096 by BigJohnT
Replied by BigJohnT on topic Re:MaxNC T2 lathe
You could change the push button to a check button...

www.linuxcnc.org/docview/html//hal_pyvcp.html#r1_6

John

Please Log in or Create an account to join the conversation.

More
08 Dec 2010 03:13 #5922 by yugami
Replied by yugami on topic Re:MaxNC T2 lathe
I've been pulled out of town, but just before that happened I finished the last of the wiring and configuration and I'm happy to say it seems that I have full functionality (haven't done any tool change stuff or anything, just spindle/axis).

I'll post the config up when I get home for other peoples reference.

Please Log in or Create an account to join the conversation.

More
28 Dec 2010 21:52 #6291 by yugami
Replied by yugami on topic Re:MaxNC T2 lathe
Attached is what I have so far.

No threading because they output the hardware pulses to 4 and 5.

I'll need to do a fix on the cable/converter end before i can pursue threading.

File Attachment:

File Name: maxnc_t2-d...a88b.hal
File Size:4 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Dec 2010 21:53 #6292 by yugami
Replied by yugami on topic Re:MaxNC T2 lathe
And the INI

File Attachment:

File Name: maxnc_t2-c...bedd.ini
File Size:2 KB
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.447 seconds
Powered by Kunena Forum