× Forum Header

Configuring A rotary axis to substitute for the Y axis

More
29 Jan 2019 19:26 #125198 by dgarrett

If using trivkins in the development version then the only
change you need to make is from...


You also need to make sure the number of joints is specified
correctly, example:
[KINS]
KINEMATICS=trivkins coordinates=xazy kinstype=both
JOINTS = 4
...

(Using kinstype=both is helpful in seeing what goes on
prior to homing for the axis gui)

Recommendations for consistency:
Ref: linuxcnc.org/docs/master/html/getting-st..._axes_specifications


trivkins man page:
linuxcnc.org/docs/devel/html/man/man9/trivkins.9.html

Please Log in or Create an account to join the conversation.

More
29 Jan 2019 19:27 #125199 by Chris401
May try that if I am not happy with the code Vcarve pro generates for the cylindrical projects. On my config problem I punted and used the XYZA in stepconfig and just defined A to be on my normal Y driver and Y using pins not really connected to anything. Runs manually now. Naturally with a phantom Y I need to run without my limit/home switches and its has been a long time since I have run without so need to figure out how to past that now. First attempt was manually adding home_search_vel=0 to axis section and still got the “cant run MDI commen...” message.

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 20:32 #125491 by Chris401
Leon,
I figured out how to get Vcarvepro to output angular movements and and am running an XYZA with a nonexistent Y axis. It now works but the A axis seems to be turning at the same magnitude in degrees/min that the linear axis moves in inches/min. Obviously the rotation is pretty darned slow. Moving the right amount just getting there slowly. Is that just something that needs overcome in the G code or is there a linuxcnc end fix?

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 20:35 #125493 by Chris401
Andy,
I have Vcarve ouputing A moves now and the machine is moving the right amounts. But the feed for the A axis is the same in deg/min as the linear is in inches/min. Obviously kind of slow. Is there a linuxcnc fix for rotational moves or does that just have to be a G code fix?

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 20:53 #125494 by Grotius
In rotary files, the feed rates are up to 30000 mm/min when rotating without G1 commands.
So you need to add fast command's in your gcode file, like

Y5 Z68 A-220 F35000

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 20:54 #125495 by OttoDidact
I think what you are looking for is inverse time mode.

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 21:32 - 01 Feb 2019 21:33 #125499 by Leon82

OttoDidact wrote: I think what you are looking for is inverse time mode.


Yes. Inverse time or TCP would feed correctly

In mastercam you can set the machine definition to post this. So there should be a setting in the cam software
Last edit: 01 Feb 2019 21:33 by Leon82.

Please Log in or Create an account to join the conversation.

More
More
02 Feb 2019 15:02 #125541 by andypugh
Try inverse time mode.
There is a filter file somewhere on this forum to automatically convert to inverse time.

Please Log in or Create an account to join the conversation.

Time to create page: 0.105 seconds
Powered by Kunena Forum